Page 18 of 85 FirstFirst ... 891011121314151617181920212223242526272868 ... LastLast
Results 171 to 180 of 841

Thread: AMP v1.0 Worklog

  1. #171
    Newbie minicoopS007's Avatar
    Join Date
    Sep 2005
    Location
    Gaithersburg
    Posts
    31
    Quote Originally Posted by LightningMac
    I know the guys working on Harmony have an XM palette working on their program, maybe you can ask them about it?

    I have a XMPCR and would love to have that available in AMP as well, plus I know there is a mod out there to convert a normal XM receiver to work with USB...
    Wouldn't that be nice...

    XMPCR is discontinued but you could find some boxes on ebay. However you could send "magic codes" to the XM Direct tuner to make it act like an XMPCR. Thats what we've done with Harmony. Harmony interfaces with the XM Direct tuner through a stripped down-modified version of MacXM. I modified the core XM classes and created a cocoa/java application (HXM). Harmony talks to HXM through UI scripting. We can afford to do this since we always now what HXM will look like. I found Applescript support for a java app painful.
    After all that blah,blah,blah... I am going to share my XM classes with aychamo and leave it to him to decide how he wants to implement it.

    aychamo look for xm classes this weekend.

  2. #172
    Low Bitrate jdisenberg's Avatar
    Join Date
    Dec 2005
    Location
    Kentucky
    Posts
    78
    hmmm.... I will try that tonight. Yeah, it is a xenarc but I haven't sen that stuff yet. I am excited again, because this program looks so promising in a car. Even with it in the strange resolution I drove around last night testing everything and I like it a lot. Great job and keep up the work...

    What about a wardriving program to search for open networks?

  3. #173
    AMP Creator aychamo's Avatar
    Join Date
    Jun 2006
    Posts
    505
    Hey Jdisenberg, take a picture of it in your car on the Xenarc (even it's in the ****ty resolution!) I'm dying to see it on a Xenarc! (4 days till I get mine!)

    Here's an updated working screenshot of the working webbrowser with the current "skin" on it. It functions pretty well. I think there's enough space between the buttons so that you don't have too many problems with a touchscreen.

    I swear to god I can't wait to try this out on a damn touchscreen

    I'll upload this version the new webbrowser screen as soon as I finish the web browser favorites. Well, the favorites are finished, but I have one really small, but infuriating bug I can't figure out. Once I get that worked out I'll upload the version. I suppose it'll be a fully functional web browser.

    As far as a war driving program, I have no current plans to do that myself. I'll add a screen off the main config where you can run external programs of your choosing, so that everyone can kinda configure it a bit more to their needs.



    (lol I refuse to get rid of my round back buttons -- I want to keep some FrontRow feel to it!) - lol and if you find that video on youtube.. don't blame me for wasting 4 minutes it's my buddies from back in high school - 7 or 8 years ago)
    -

  4. #174
    Constant Bitrate
    Join Date
    Feb 2005
    Posts
    124

    Screens

    Very nice !! LIKE LIKE !! Good work u 2 !!

    Bug ?
    When u quit AMP, and the shark is running it crashes :-)

    Screens attached showing an 800x600 screen. Note that the image sizes have been halved to save space but ratios remain the same. The slideshow users the entire 800x600 scrren btw. Hope this helps
    Attached Images Attached Images    
    __________
    rgds, raceer


  5. #175
    Constant Bitrate
    Join Date
    Feb 2005
    Posts
    124

    Via DOCK ?

    Quote Originally Posted by aychamo
    As far as a war driving program, I have no current plans to do that myself. I'll add a screen off the main config where you can run external programs of your choosing, so that everyone can kinda configure it a bit more to their needs.
    Perhaps the items in the users dock can be read by default to provide a list via the preferences with a tick box or the reverse of the visuals screen. ie. you click on ones you WANT to run (or allocate to a AMP button to run). This would mean that in order to run an external program all one would need to do is drag it to the dock and set it in preferences....this then configures (like a preset) a button in AMP to run the app.... convoluted ?

    maybe even another option in preferences to preload at startup....

    just a thought...
    __________
    rgds, raceer


  6. #176
    AMP Creator aychamo's Avatar
    Join Date
    Jun 2006
    Posts
    505
    Hey!

    That's a reallly interesting idea!

    It looks pretty neat wtih the orange scroll bar. AMP uses a certain system setting for calculating the gradient of the highlight bar. To change this, go to "System Preferences", and then "Appearance", and then "Highlight Color."

    To be honest, I had never thought of changing the scroll bar color, it was just used as a reference. That's really clever of you to do that! And, to be honest, this is one of the aspects of software development that I think is absolutely fascinating. When users think of doing things in software that was never "intended." It's actually pretty damn amazing you can just change that color in system preferences and the scroll bar changes color immediately. (If anyone plays games online, it's amazing seeing the way people come up with to exploit the gaming engine,, it's truly fascinating)

    Here's how I'm screwing around with it. Have AMP open, then Command-Tab to a different program and bring up system preferences -> appearance -> highlight bar. You can change it to whatever in the dropdown, or do "Other". Just have the system preferences window on top of the AMP window, and see it as you do it.

    That's really damn clever man Good find!

    - It looks interesting on 800x600! Are you guys having problems getting your comp's into 800x480? I hope it's not a problem. I'll find out soon enough when my Xenarc gets here (days and counting!)

    - re: radioSHARK crashing. Yeah, I have that problem too. It's sporadic though. All I do is send it a message to shut down, and it crashes. I'm not really sure why. I guess the good thing is it isn't crashing while it's running -- lol! Are you Command-Q'ing out of AMP, or through the Shutdown menu?

    I just got back from Superman.. Great damn movie! I'm going to put a little work into the radioSHARK favorites.

    I've got the browser favorites' finished. It's an interesting system. As you know, everything in a touch screen environment has to work differently, and use as few clicks as possible, and yet be intuitive. I'm not looking at any other front end, so I'm just trying to see what comes easiest for me.

    Basically, if you are looking at a webpage and you wnat it in your favorites, you click on the favortites button. This pops up a list of your favorites. From here, you can either click on a favorite that is listed and it will go to that page, or you can click on a + button next to the favorite, and it puts your favorite in there. Short, simple, sweet, and works great. - Also, in this updated browser your "Home" page is your first link. (For now, I will probably change how this works later.)

    Heres a screenshot.. Ahh, screw it, lol, here's the version to DL

    http://www.aychamo.com/amp/AMP.zip
    -

  7. #177
    Constant Bitrate
    Join Date
    Jun 2006
    Posts
    126
    Aychamo, im liking the broswer a lot more. did you ever get my email about radio shark? i dont have one so i cant use it but i was jw.

  8. #178
    AMP Creator aychamo's Avatar
    Join Date
    Jun 2006
    Posts
    505
    Hi Jakob!

    I sure did - I emailed you back!! I'm working on that area now!

    Ayhamo
    -

  9. #179
    AMP Creator aychamo's Avatar
    Join Date
    Jun 2006
    Posts
    505
    .. I've love to see a picture of AMP running in 800x480 on a Xenarc!!
    -

  10. #180
    Variable Bitrate
    Join Date
    Feb 2006
    Posts
    262
    Awesome job on the browser!

Similar Threads

  1. vw mk4 monson amp and another amp
    By colorless in forum Car Audio
    Replies: 34
    Last Post: 09-05-2012, 11:43 AM
  2. del
    By hanzacra in forum General Hardware Discussion
    Replies: 5
    Last Post: 11-27-2007, 03:41 AM
  3. Amp running hot...??
    By Emerica2843 in forum General Hardware Discussion
    Replies: 5
    Last Post: 02-08-2006, 06:40 PM
  4. Amp running hot...??
    By Emerica2843 in forum Car Audio
    Replies: 6
    Last Post: 01-29-2006, 08:29 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •