Page 4 of 85 FirstFirst 123456789101112131454 ... LastLast
Results 31 to 40 of 841

Thread: AMP v1.0 Worklog

  1. #31
    Low Bitrate
    Join Date
    Oct 2005
    Posts
    70
    sorry to be picky is there a way to browse the itunes library by playlist? or select a certain playlist? that would be awsome. and if it were possible... what about if the way the songs were sorted stayed the same? because i know where the songs are placed in my playlists. so it makes it alot easier.

  2. #32
    AMP Creator aychamo's Avatar
    Join Date
    Jun 2006
    Posts
    505
    hey there!

    I definitely am adding playlist support, and they *should* stay in the same order
    -

  3. #33
    AMP Creator aychamo's Avatar
    Join Date
    Jun 2006
    Posts
    505
    Quick note guys, if you do the diagnosis I suggested above (on pg2), if that's the cause of your problem, then I found the bug, i just have to fix it now. I swear I'm going to fail out of school because of you guys ;-) jk
    -

  4. #34
    Variable Bitrate
    Join Date
    Feb 2006
    Posts
    262
    I confirmed it, I only have one song with album art since most of the way I imported my songs didn't include them, and that ONE song plays without crashing, so I'd say you found that bug!

    Just a thought, I enjoy the simplicity of the look of the program, so for the buttons and menus, I'd just change the color of them and make the buttons translucent, *aqua effect* to add a bit of a classy look to some of the buttons and other pages you may make for it. In the Radio Shark Page I'd change the over all color to purple or blue or something... Just my 2 cents and thanks for all the great work!

  5. #35
    AMP Creator aychamo's Avatar
    Join Date
    Jun 2006
    Posts
    505
    Heya!

    Yeah, I'm pretty sure I've gotten rid of the bug. For those interested, originally when I did the "music import" it also saved the album art in the database. The resulted in like an 80meg database (for ~5000 songs). It took forever (like over a minute) for the program to load.

    I realized what a stupid design decision that was, so I only store the path to the album art now. What was happening, in the bug, is that my method that extracts album art from songs was returning blank data for those without album art (which was fine for the first method, but not for this). Now I have a 1px blank picture that it loads, and everything seems to be fine now.

    I'm going to work most of this day on the features I talked about up above. I'll upload that version hopefully tonight, and I hope you will all be pleased with it so far.

    LightningMac, I'm not sure I understand what you mean about the buttons. Do you like the ones now? Or not? If so, which ones are you recommending to change? I've got a new little background a kinda cooler new look for the radio menu (thanks to raceer).

    I'm open to all suggestions (except making the screen bigger, lol, it's designed for the 800x480 screen! -- which I haven't been able to test yet,still waiting on the xenarc)
    -

  6. #36
    Constant Bitrate Sharkbite86's Avatar
    Join Date
    Apr 2006
    Location
    California
    Posts
    191
    holy cow it would seem you are right! It crashes on every song i play that does not have an album artwork image!! Hope you can fix that! GREAT CATCH!

    Edit: oops well nevermind i guess yo just fixed it

  7. #37
    Variable Bitrate
    Join Date
    Feb 2006
    Posts
    262
    for the most part I think the buttons look a little too simplistic, how about using the program to create a nice looking "Aqua glass" looking buttons

    http://www.apple.com/downloads/macos...onbuilder.html

  8. #38
    AMP Creator aychamo's Avatar
    Join Date
    Jun 2006
    Posts
    505
    Ok, I've just updated the 1st page 1st post with the new DL link, and a list of what I changed/added:

    Major Changes:
    * You *need* to delete ~/Library/Application Support/AMP/AMP.plist !!
    * Repeat: Delete the above file! ~ is a shortcut for /users/YourUserName
    * Did you delete it yet?
    * Ok, now once you start it, you *need* to reimport your *music* !! [iTunes]

    - VIDEO_TS folders are now playable; A folder with a VIDEO_TS folder should be in your top level hierarchy of ~/Movies. For instance, the following are valid VIDEO_TS movie format:
    ~/Movies/Wedding Crashers/VIDEO_TS
    ~/Movies/Kill Bill/VIDEO_TS
    (VIDEO_TS should be capitalized)
    - iTMS Protected Video Files should be playable, ONLY IF they are imported via your iTunes music database!
    - iPhoto style slideshows
    - No more crashing while playing audio without album art (oops, sorry guys)
    - Scan Up/Down, Seek Up/Down for radioSHARK
    - AMP will remember which volume it was set at on the last shutdown
    - Visualizations! These are quartz composer files I got from: http://www.zugakousaku.com/index.cgi?quartz .. I think they look pretty nice!

    - For the protected video files, the *only* option is to use QuickTime Player as an external app. Yes, this sucks (thanks Apple.) I tried to make it look as nice as I could. It's not so bad. To exit a movie, just click on the screen, and "drag" the file position to the end. It's actually really easy and quick once you do it.

    - There should be 12 visualizations, they play at random, so.. Just keep clicking. If everbody hates one particular one or something I can remove them, but they are all pleasing (to me) in their own way.

    You really need to delete the AMP.plist, and then start AMP and reimport your music! This will eliminate the crashing bug!
    -

  9. #39
    AMP Creator aychamo's Avatar
    Join Date
    Jun 2006
    Posts
    505
    LightingMac, those blue buttons look nice. I checked out that program but you gotta register it to make anything. Anyone up for photoshopping some? There are a lot of good tutorials if you google "aqua buttons"

    --

    Please let me know of any bugs or any issues in the latest version!
    -

  10. #40
    AMP Creator aychamo's Avatar
    Join Date
    Jun 2006
    Posts
    505
    Quote Originally Posted by chakd
    Hehe sorry I meant can is can I make it full screen when watching videos
    Hey!

    When it uses the built-in video player, it makes it the same size as the screen ultimately will be 800x480; but when it plays a DVD, or has to shell out to QuickTime (ugh), or does the iPhoto style slideshow, it uses the fullscreen, regardless of the resolution. Ultimately, on 800x480, everything will be fullscreen and look pretty smooth! (relatively speaking)
    -

Similar Threads

  1. vw mk4 monson amp and another amp
    By colorless in forum Car Audio
    Replies: 34
    Last Post: 09-05-2012, 10:43 AM
  2. del
    By hanzacra in forum General Hardware Discussion
    Replies: 5
    Last Post: 11-27-2007, 02:41 AM
  3. Amp running hot...??
    By Emerica2843 in forum General Hardware Discussion
    Replies: 5
    Last Post: 02-08-2006, 05:40 PM
  4. Amp running hot...??
    By Emerica2843 in forum Car Audio
    Replies: 6
    Last Post: 01-29-2006, 07:29 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •