Results 1 to 8 of 8

Thread: BU- 353 not compatible with Windows 8

  1. #1
    Variable Bitrate
    Join Date
    Aug 2003
    Location
    Plymouth , MN
    Posts
    313

    BU- 353 not compatible with Windows 8

    I finally decided to upgrade my CarPC to use Windows 8 as the OS.
    I did this primarily because it is the much faster booting up with a solid state hard drive than any other versions of windows out there.
    However I have had to trade off a few things to get this.
    Notable of which is now my dependable GlobalSat BU-353 GPS receiver.
    honestly I am not 100% certain if it is because I am running the 64- bit version of the OS butt I noticed that my GPS receiver would constantly not start in the device manger.

    I uninstalled and re-installed the Prolific Serial to USB drivers and I kept having the same problem I was beginning to think my receiver had a problem but when I put it on my test Laptop running the 32 bit version of Windows 7 it worked fine.
    Last night I tried to visit the Globalsat US website to download the drivers again thinking that I may have corrupted something and lo and behold their website states in bold red print that the BU-353 W(weatherproof) is incompatible with Windows 8. Even their comparison of the two devices on their site states that it does not.
    Seeing as how I know a lot of us on these forums use this receiver, I thought I'd mention it for those who are planning on upgrading to Windows 8 or buying this specific receiver for their CarPC running windows 8.
    2002 Chevrolet Avalanche
    Zotac NForce 610i ITX, 2GB RAM, 2.6 GHz Intel Pentium Dual Core CPU, 320 GB Hard Drive, 12' VGA touchscreen monitor, 3D mouse
    My Worklog : http://www.mp3car.com/vbulletin/work...avalanche.html

  2. #2
    Maximum Bitrate
    Auto Apps:loading...
    VegasGuy's Avatar
    Join Date
    May 2009
    Location
    Las Vegas
    Posts
    588
    The current prolific drivers do not support the older BU-353 chipsets (as stated on their website). You can use the older prolific drivers, though, and they will work with Windows 8.

    I have a copy of the older 1.5.0 version of the Prolific Pl2303 drivers here:
    http://repo.centrafuse.com/centrafus...ler_v1.5.0.exe

    I've tested these with Win8 x64 and they seem to work well.

    Windows Update will try to update the older driver to the new version. If this happens, you can use the rollback function in device manager to get back to the correct version. Supposedly, you can tell windows update to ignore that driver for future updates, but I haven't figured out how to do it yet.

  3. #3
    Variable Bitrate
    Join Date
    Aug 2003
    Location
    Plymouth , MN
    Posts
    313
    thanks vegasGuy.
    However I am getting the following message when attempting to use the link.


    404 - File or directory not found.
    The resource you are looking for might have been removed, had its name changed, or is temporarily unavailable.

    I'll search around the net for the older drivers and give them a shot if I find them.
    Thanks
    again for pointing me in the right direction.
    2002 Chevrolet Avalanche
    Zotac NForce 610i ITX, 2GB RAM, 2.6 GHz Intel Pentium Dual Core CPU, 320 GB Hard Drive, 12' VGA touchscreen monitor, 3D mouse
    My Worklog : http://www.mp3car.com/vbulletin/work...avalanche.html

  4. #4
    Maximum Bitrate
    Auto Apps:loading...
    VegasGuy's Avatar
    Join Date
    May 2009
    Location
    Las Vegas
    Posts
    588
    Sorry about that... link was truncated:

    http://repo.centrafuse.com/centrafus...ler_v1.5.0.exe

  5. #5
    Variable Bitrate
    Join Date
    Aug 2003
    Location
    Plymouth , MN
    Posts
    313
    Quote Originally Posted by VegasGuy View Post
    Sorry about that... link was truncated:

    http://repo.centrafuse.com/centrafus...ler_v1.5.0.exe
    Thanks
    It seems I also had version 1.4.17. I installed that and it worked but windows keep reverting to a newer driver dated 2013.
    I will try this and if it still does not work, I'll try to find that driver file location and delete it.
    Thanks for the info.
    2002 Chevrolet Avalanche
    Zotac NForce 610i ITX, 2GB RAM, 2.6 GHz Intel Pentium Dual Core CPU, 320 GB Hard Drive, 12' VGA touchscreen monitor, 3D mouse
    My Worklog : http://www.mp3car.com/vbulletin/work...avalanche.html

  6. #6
    Maximum Bitrate Mickz's Avatar
    Join Date
    Sep 2009
    Location
    Australia
    Posts
    812
    To Stop Windows 8 automatically Installing Drivers.

    1. Go to System
    2. Advanced system settings
    3. Hardware Tab
    4. Device Installation Settings.

    OR

    1. Go to Device and Printers.
    2. Right Click on the Computer Name (icon).
    3. Select "Device Installation Settings"
    Last edited by Mickz; 02-27-2013 at 07:22 PM.
    GA-Z77N-WIFI, i5-2400S, 8GB, Intel 520 128GB SSD, M4-ATX Modified, 2 Rev Cams, 2 Web Cams
    8" 16:9 TRANSFLECTIVE, Win8-64, Dual GPS RX and Garmin PC + Odyssey Nav, FM-DAB+, BB-Rec
    T-Screen HVAC control, custom microcontrollers, code and FE. CarPC Project

  7. #7
    Maximum Bitrate
    Auto Apps:loading...
    VegasGuy's Avatar
    Join Date
    May 2009
    Location
    Las Vegas
    Posts
    588
    Quote Originally Posted by Mickz View Post
    To Stop Windows 8 automatically Installing Drivers.

    1. Go to System
    2. Advanced system settings
    3. Hardware Tab
    4. Device Installation Settings.

    OR

    1. Go to Device and Printers.
    2. Right Click on the Computer Name.
    3. Select "Device Installation Settings"
    Thank you!!!

  8. #8
    Variable Bitrate
    Join Date
    Aug 2003
    Location
    Plymouth , MN
    Posts
    313
    Thanks all. it works fine now although i went a slightly different route and reverted to the older driver in the device manager and windows remembered my choice.
    2002 Chevrolet Avalanche
    Zotac NForce 610i ITX, 2GB RAM, 2.6 GHz Intel Pentium Dual Core CPU, 320 GB Hard Drive, 12' VGA touchscreen monitor, 3D mouse
    My Worklog : http://www.mp3car.com/vbulletin/work...avalanche.html

Similar Threads

  1. Replies: 0
    Last Post: 12-20-2011, 03:11 PM
  2. iGuidance 2009 and V 4.02 NOT WINDOWS 7 Compatible
    By d11 in forum iGuidance GPS Software
    Replies: 18
    Last Post: 03-31-2010, 08:28 PM
  3. Replies: 6
    Last Post: 11-28-2006, 12:23 AM
  4. Is this LCD, VGA compatible?
    By Warpath in forum Newbie
    Replies: 4
    Last Post: 01-11-2005, 04:33 AM
  5. Windows 95-98 networking + Windows machine booting in dos mode every time...
    By SkinnyBoy in forum General Hardware Discussion
    Replies: 29
    Last Post: 08-21-2001, 12:18 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •