Ok, this is a brain buster!

I installed a PAC AAI-NIS2 in my 2005 G35 coupe with Factory XM radio. I plugged a Monster Cable 1/8" -> RCA cable into the free-floating RCA inputs on the PAC brain (labeled Input 1). There is nothing plugged into Input 2 on the PAC brain.

Basically, the car decides what mood it is in and picks for me as to which source to use... the source hooked up to the PAC (iPhone in this case) or the source of the factory XM radio.

Can you not have both XM and PAC Aux-in installed and functioning? If so, how do you tell the car which source to use?

I can not for the life of me figure out what makes it switch between sources of the AUX in from the PAC piece, versus the factory XM radio. When the PAC aux in works, it uses both XM1 and XM2 channels on the factory head unit. While the PAC aux in works, clicking any preset button on either XM1 or XM2 does nothing.

The preset buttons DO NOT magically switch between the two sources.

case1: I will be on the XM-1 source with XM playing, press preset 1 with the iphone plugged in and playing, and nothing happens... still uses the XM source and switches stations to whatever is XM preset 1.

case2: I will start my car. Turn on my radio, which was left on the XM source option from the main (factory) head unit before being turned off. XM radio will play. With the car still on, I will turn off the radio. I will turn the radio back on. Now the XM won't play and the PAC aux in will be selected, even if there is nothing plugged in to the PAC input (iPhone not attached to input cable). Sometimes I can turn the radio on and off a hundred times and it won't ever switch to the PAC aux in.

case3: When I first tested it out, I was on XM 1, playing XM radio. I just kept cycling through the head unit sources/modes by pressing the Radio button. After about 2 minutes, I cycled through and landed on XM1 (AM, FM1, FM2, XM1, XM2) for the n-th time and magically the iPhone was playing. When the iPhone does play (the PAC aux in source is the active source), I can't get XM radio back even if I stop the iPhone, unplug it and cycle the Radio button. Power off the radio, power it on, leave it on XM1 before power off, leave it on another source besides XM1 or XM2 before power off, leave it on preset 1 or 2 before power off, leave it on preset 3-6 before power off, NOTHING MAKES A DIFFERENCE. I will power the radio back on and it still is on the PAC aux in source. The only way XM works again is after I shut off the car and come back some time later. If I shut off the car and turn it back on right away, its still on the PAC source.

How does the PAC piece know when to use its source instead of the XM source passing through? Line voltage?

This is starting to frustrate me as I can't choose what to listen to, making this piece virtually useless.

All I know when I get in my car is that one or the other will work.

Anyone out there have problems with this PAC piece with factory radio installed and working prior to install?

Thanks in advance.

-ikon