Page 1 of 2 12 LastLast
Results 1 to 10 of 16

Thread: Another yet speaker noise problem, not sure if it's ground loop

  1. #1
    Newbie
    Join Date
    Nov 2007
    Posts
    47

    Another yet speaker noise problem, not sure if it's ground loop

    Hi guys,
    Here is my problem: I have this buzzing noise in my speakers until I turn ON PC.
    My system hooked up as follows: from USB sound card into AUX Input of my HU. I used to have ground loop, so I got the ground loop isolator installed. It was just fine for few days than I got this noise back again. I grounded audio cable to the chassis and the problem solved. But in some time I've noticed that I have thin noise in my speakers when PC is OFF and HU is turned on AUX Input. If I switch to either CD or Tuner, this noise goes off. Also it goes off if I turn ON PC.
    I just have no idea where to look for a problem.

    I forgot to add, that I run laptop as carpc with Lilliput screen, The screen is wired to the back of cig. lighter thru molex connector and laptop is powered via inverter. Inverter gets it's power straight from the battery via relay.

    Thanks in advance.

  2. #2
    Low Bitrate
    Join Date
    Sep 2007
    Location
    Raleigh, NC
    Posts
    106
    I had a very similar problem when I went from an onboard audio card to an external one. The problem is that since the external sound card is grounded through the pc, the ground only functions when the PC is on and device drivers loaded (At least this is how it was explained to me). I fixed the problem by using a relay to turn on the amp only after the pc had booted and the exteral card turned on.

  3. #3
    Newbie
    Join Date
    Nov 2007
    Posts
    47
    do you use your carpc thru HU as well?

  4. #4
    Constant Bitrate
    Join Date
    Mar 2008
    Posts
    162
    I wouldn't imagine it would be an issue if it only happens when you are in auxiliary input and your PC is off.

    If you want to see if your PC is causing it, just unplug the auxiliary wire from your HU and see if it goes away.

    But again, why do you need to have your auxiliary input active when your PC is off?

  5. #5
    Newbie
    Join Date
    Nov 2007
    Posts
    47
    well, when I start the car, it turns on the HU first. I don't have any auto start hardware for my laptop so I have to do it manually by pressing the start button. During these few seconds between I started the car and PC booting, I have this weird noise I''d like to get rid of...

  6. #6
    Constant Bitrate
    Join Date
    Mar 2008
    Posts
    162
    Hm, thats not so much car audio as it is a power issue.

    It could just be a weird loop when your HU is trying to draw a signal from your PC when it is off..it just gets a buzz.

    Only way I can see that being fixed for cheap is to go to radio shack and buy a transistor. Then splice into the wire going into your auxiliary input and place the transistor there.

    A transistor has 3 connectors. Positive, Negative, and a switch. You would wire the switch up to your PC's Power supply.


    I made a diagram. You would probably need a resistor to keep from blowing the transistor.
    A transistor is really tiny. I just made it large in the image for viewing purposes.



    It just acts as a switch. It will not send any signal through the wire (as if nothing was connected at all), until the PC is turned on.


    Now, I have no idea if this would actually fix your problem, or if there is a better way. But is is an idea on a possibility.

  7. #7
    Newbie
    Join Date
    Nov 2007
    Posts
    47
    should it be spliced into ground audio wire? I have rca cable running into aux input. Well, its a special aux adapter for my Pioneer HU.

  8. #8
    Constant Bitrate
    Join Date
    Mar 2008
    Posts
    162
    Well, your first test would be to unhook the auxiliary input, and see if you still have the noise.

    If the noise goes away then this method should work.

    You can try to use it on the negative wire of the RCA cord. If that doesn't work you can have a separate transistor on both the negative and positive wires of the RCA cord.

    You may want to test it out with an old cord first, but I am guessing this method should take care of your problem.

  9. #9
    Newbie
    Join Date
    Nov 2007
    Posts
    47
    I will try as soon as I have time, thanks a lot. I''ll post my results.
    Thanks again.

  10. #10
    Constant Bitrate
    Join Date
    Mar 2008
    Posts
    162
    Be sure to talk to a guy at radio shack about them. There are different kinds of transistors.

    Tell him what you are trying to do, and he should be able to tell you what size resistor and what type of transistor you would need.

    I would tell you, but it has been a while since I have messed about with transistors, and they are named by number.

    Like, a Type 9309 transistor. I have not committed all the types to memory lol.

Page 1 of 2 12 LastLast

Similar Threads

  1. Need ideas for ground loop noise
    By dawgdan in forum Newbie
    Replies: 1
    Last Post: 04-01-2007, 08:36 PM
  2. Universal charger causes VGA noise, where to ground?
    By swift_gti in forum Power Supplies
    Replies: 3
    Last Post: 01-02-2007, 08:43 PM
  3. Replies: 0
    Last Post: 03-25-2005, 06:09 PM
  4. ground loop isolator help
    By digital chaos in forum General Hardware Discussion
    Replies: 10
    Last Post: 03-11-2001, 01:38 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •