Results 1 to 5 of 5

Thread: ground loop isolator problems

  1. #1
    Newbie
    Join Date
    Aug 2008
    Posts
    6

    ground loop isolator problems

    hey guys, i've got the dreaded hum and have been reading heaps and trying to troubleshoot it the last couple of days.

    It's a pretty lound hum, can hear easily over music, the main source seeming to come from the cpu fan. When i put my finger in the fan the hum changes pitch.

    I've tried basically everything to fix it. I've basically grounded everything i can thing of to -ve straight from the battery with jumer leads. I've tried grounding the ground point on my m2-atx DC power suppy, the amp, the outer sheath of RCA leads. I've also tried grounding PC and AMP together, pc to rca, amp to rca, nothing decreasing the buzz.
    Headphones from computer, there is no buzz, Ipod to amp, no buzz. Shorted RCA cable to amp, no buzz.
    However when the PC is running off an external power supply and is isolated, the noise problems are gone, obviously indicating a ground loop and that both the PC and AMP are operating correctly right? What i can't understand is that grounding everything i can think of makes no noticable decrease in the noise!

    ANYWAY, i did go out today and buy a $20 "car stereo line isolation transformer" today as most here recommend with these problems, assuming that this would fix my issues.
    When it's plugged inline with my RCA from computer to amp, the volume is DRASTICALLY decreased to almost nothing. Boost the gain on my amp right up and the sound is obviously.....broken.
    I CAN however ground the outer sheath of the rca going into the amp which brings the volume back up to normal. If i ground from the same point as the amp and pc's grounds, i get the same hum(not QUITE as loud though) as there's 88 Ohms from those grounds to battery (i know that's alot, but grounding either of them to battery still doesn't fix the problem!)
    but if i ground straight from the battery the hum is almost inaudable.

    My question is, are you SUPPOSED to have to ground the outer RCA connector after the ground loop isolator to get these things to work? isn't the whole idea that you DON'T have to do that, and just plug them inline? I'm going to buy a good heavy guage wire tomorrow and go a temporary fix from batt to ground the RCA, but that can't be the right way to do it can it?

    I appologise for the length of the post but would appreciate anybody's input! I've read heaps of posts and the FAQ's on this forum but nobody seems to have the same ground loop isolator problems i do

  2. #2
    Maximum Bitrate Woofnstuff's Avatar
    Join Date
    Oct 2007
    Location
    Auckland
    Posts
    570
    you should not have to ground anything with an isolator.. thats what you are trying to avoid is the grounding of something

    BUT depending on how its isolating you may have issues.. as you mentioned

    a good isolator will have transformers in it, cheaper ones do it with electronics, and usually work ok
    real cheap one will just lift the earth / ground and you will only get the + wire fed thru the device..

    you mentioned that with a short rca cable you got no buzz.
    check and re check where your "long" cable goes, past or along with ANY power wires, video cables etc?

    did you make your own rca cables or buy pre made? do they have any shielding? and is the shielding the wire that carries the audio... or is there a red and black wire and a metal shield?

  3. #3
    Newbie
    Join Date
    Aug 2008
    Posts
    6
    yea thats what i was thinking, shouldn't HAVE to ground any of this. One thing i was thinking though, does an amp typically have the outer conductor of it's RCA in grounded to the car?

    And nah nah, i meant ive tried a shorted together cable, the signal wire shorted to the outer ground wire. Plugging that into the amp just proves that it's not generating noise it'self when it's getting a clean (shorted) signal. But yea, i've tried different cables run straight from the computer to the amp away from all other cables (everything is in bits at the moment), so i know it's not an interference problem. And yep, bought all my cables, cables alone have cost a fortune

    Going to go play a bit more with it now and see how frustrated i can get

  4. #4
    Vendor - Qube colin's Avatar
    Join Date
    Dec 2006
    Posts
    796
    I just want to point out that you should not have 88 ohms.
    That's a significant resistance and dissipates heat just like any other resistance. Time to upgrade your wires man.

  5. #5
    Newbie
    Join Date
    Aug 2008
    Posts
    6
    well i've found out what my problem is, confused how i didn't pick it up earlier but here it is. I have a 4 channel amp, and the two channels i was using are broken. From the good channels, i'm getting about 1kOhms between the rca's ground and the ground of the amp, the broken ones are open circuit.
    That explains why my ground loop isolator was ridiculously faint when i plugged it in, as there wasn't a circuit made for the second half of the transformer in the isolator. It doesn't explain why when i plugged an ipod into the same two channels i could hear sound though, and i did it a couple of times with a mate

    anyway, If anyone has similar problems to me, another thing to check on your amp other than the usual tests, would be that the outer bit on your amps rca's are not open circuit to the ground on the amp.

    Thanks to all those that replied, and yea colin, i just pulled apart all my crusty ground points today and dremeled them up clean. 0.0 Ohms it reads now

Similar Threads

  1. Induced noise/Ground loop trouble shooting guide.
    By Will Albers in forum Car Audio FAQ
    Replies: 138
    Last Post: 01-28-2011, 08:37 AM
  2. Alternator Whine Only With Carputer
    By tbird2340 in forum Car Audio
    Replies: 25
    Last Post: 06-29-2007, 02:36 AM
  3. Re-Ground HU or Ground Loop Isolator?
    By Incinorator in forum Car Audio
    Replies: 5
    Last Post: 04-20-2006, 07:52 PM
  4. I tried everything, can't get rid of this ground loop
    By intense in forum General Hardware Discussion
    Replies: 3
    Last Post: 07-10-2005, 08:58 AM
  5. Pinout Color Codes / Tables
    By gummybear in forum General Hardware Discussion
    Replies: 4
    Last Post: 05-12-2005, 03:05 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •