Results 1 to 6 of 6

Thread: Speaker posts melted itself clean off

  1. #1
    Maximum Bitrate
    Join Date
    Jul 1999
    Location
    Birmingham, Alabama (War Eagle!)
    Posts
    700

    Speaker posts melted itself clean off

    I couldn't believe it, but it happened.

    I have a pair of Diamond Audio Hex 5.25" components and yesterday while I was doing some software updates to the carpc I noticed that the audio sounded a bit off. I sat in all of the seats in the car to try and pinpoint what was going on and then it hit me, i wasn't getting any mids on the passenger side of the front of the car. Plenty of highs were coming in from the tweeters, but no mids coming from the 5.25".

    I immediately headed to the trunk to the Memphis Belle amp to make sure everything was snug and nothing looked out of place. It as I expected turned up perfect, I then moved back to the front to check the crossovers that I have mounted in the kick panels. That all looked in order as well. The only thing left to do was to hit up the speaker itself.

    What I found was crazy, the block that holds the speaker posts had completely melted off as well as the soldered wires that connect the speaker to the posts themselves.

    I had never heard of anything like this. Mostly i've just heard of speakers "blowing" if improper power or volume levels are put to them, but never electrical issues like that.

    I'm totally left without a way to fix it, the wires had completely melted so i can't solder it back, and I can't get in touch with the individual I purchased it from (basically an ebay type of purchase). The speakers are also out of warranty :/

    Any suggestions?

  2. #2
    Variable Bitrate SickVette's Avatar
    Join Date
    May 2005
    Location
    Wesley Chapel, Fl
    Posts
    325
    15 years installing car audio and I have never seen that....learn something new everyday. I will venture say though that if the wires melted the voice coil is shot also and the speaker is a paper weight. What I would be concerned about it what caused the melt down. I do not think AC could do that....could be wrong......but I would think your amp was sending DC to the speaker. I would use a mulitmeter on that speakers output on the amp. Also check the wires for a dead short.

  3. #3
    Maximum Bitrate
    Join Date
    Jul 1999
    Location
    Birmingham, Alabama (War Eagle!)
    Posts
    700
    SickVette,

    Thanks for the quick response. I was worried there may be something afoot with the wiring, but why all of a sudden did something like this happen? I've had it installed for nearly 2.5 years. Is it safe to assume that I would have the same problem on down the line in another year or two if I were to just replace the speakers?

    It completely boggled my mind, in fact, it even melted the Diamond Audio Technologies sticker that is right above the speaker post block off, as well as some of the clear plastic that is on the bottom of the magnet.

    I'm with yhou though, i think its completely dead and needs a completely replacement :/

  4. #4
    Variable Bitrate SickVette's Avatar
    Join Date
    May 2005
    Location
    Wesley Chapel, Fl
    Posts
    325
    I think if you hook another speaker up it is going to melt also. I would check everything twice before you did and then I would hook up a crap throw away to speaker before you loose another DAT speaker. Sucks it happened.

  5. #5
    My Village Called 0l33l's Avatar
    Join Date
    Jul 2004
    Location
    Berkeley, CA
    Posts
    10,516
    Quote Originally Posted by defsquad
    Any suggestions?
    New speakers.

  6. #6
    Banned xdjxklusivex's Avatar
    Join Date
    Dec 2004
    Location
    Diamond Bar, CA (909,951)
    Posts
    2,742
    Quote Originally Posted by 0l33l
    New speakers.

    go buy pos verge brand from circuit city like 10 bucks for a pair for 5.25's hahaha

Similar Threads

  1. car amp with default speakers?
    By 273BeLow in forum Car Audio
    Replies: 51
    Last Post: 03-29-2005, 11:53 PM
  2. Using advanced search to read the last 'X' posts
    By Bugbyte in forum General MP3Car Discussion
    Replies: 9
    Last Post: 03-06-2005, 05:38 PM
  3. ****PIC ! CDT CL-61 6.5" New Car Speaker Comp !PIC ****
    By neema12 in forum Classified Archive
    Replies: 4
    Last Post: 12-19-2004, 05:44 PM
  4. Replies: 11
    Last Post: 09-02-2004, 03:11 PM
  5. More than 10 posts in main page "Last 10"
    By gork in forum Mp3car Forum Suggestions/Comments
    Replies: 5
    Last Post: 07-29-2004, 06:00 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •