Results 1 to 9 of 9

Thread: HELP!!!..Problem with my Kenwood KDC-MP5028... :(

  1. #1
    Variable Bitrate BIzFlawless's Avatar
    Join Date
    Oct 2005
    Location
    Texas
    Posts
    231

    Question HELP!!!..Problem with my Kenwood KDC-MP5028... :(

    Whats up everyone! I dont know if anyone has had this problem with there kenwood or even just with any other headunit, but its ****ing me off because I have no sound and no idea WTF is wrong with my head unit! And Im hoping someone might know the solution to my problem......well the story goes....I was messing with my dash one day so I could rewire my headunit and my VGA in dash....well I got done, put the dash back like it was...turned on the car and In dash was working fine but NOT THE HEADUNIT! I have checked several times to if I could find out the problem and I found nothing its all hooked up perfectly, checked all fuses (on radio and in car) and nothing . Even ed and came up with nothing!Its like its not getting any power but It is because when I push the eject button it ejects the CD but thats all it does...no display, no sound, nothin! I tried it out in my homeboys car and It did the exact same thing! NOTHING! I have no clue what could be the prob! I was thinking maybe it was the detach face but how could that be? its only 1 month old!....Please any advice would be appreciated!

    This is my headunit
    Name:  KENKDCMP5028.jpg
Views: 2564
Size:  3.6 KB

    http://www.cardomain.com/item/KENKDCMP5028

  2. #2
    Variable Bitrate BIzFlawless's Avatar
    Join Date
    Oct 2005
    Location
    Texas
    Posts
    231
    Anyone?!

  3. #3
    Low Bitrate dfk70's Avatar
    Join Date
    Sep 2005
    Location
    Sterling, VA
    Posts
    69
    If the display doesn't light up when the key is turned on, I would suspect that your switched power lead fuse is blown.
    2003 F-150 Harley Davidson Edition
    -----------------------------------------------
    "The horse is here to stay, but the automobile is only a novelty - a fad." --- Marshall Ferdinand Foch, French military strategist, 1911

  4. #4
    MySQL Error MatrixPC's Avatar
    Join Date
    Sep 2003
    Location
    Beach City, Socal
    Posts
    4,053
    2004 Matrix XR A7N8X-VM/400 AMD XP-M 2500+, DS-ATX
    89 Supra Turbo P3 600E@750/Abit BE6 II, Alpine M-BUS Car2PC.
    Y2K Accord Dell GX150
    RoadRunner is the best FE PERIOD
    EmoRebellion is a SCAMMER

  5. #5
    MySQL Error jcdillin's Avatar
    Join Date
    May 2003
    Location
    Miami, FL
    Posts
    4,043
    or if it's a detachable face unit, the contacts are dirty or the switch that lets the HU know the face is closed has gone bad.
    肚子笑痛了
    S60 Install

  6. #6
    Variable Bitrate BIzFlawless's Avatar
    Join Date
    Oct 2005
    Location
    Texas
    Posts
    231
    Sup guys, Thanks for all replys! they are all very much apreciated! .......well I figured out what was wrong with it. It was a microchip in the detach face that was blowin...how the hell that happened I have no idea! but I spoke to kenwood and Im still under warranty only thing is they want me to ship it in, with the original reciept! I cant find that damn paper anywhere! ....do you think that bestbuy would have it on file still? was only like 2 months ago... I paid cash for it....

  7. #7
    MySQL Error MatrixPC's Avatar
    Join Date
    Sep 2003
    Location
    Beach City, Socal
    Posts
    4,053
    You can try and ask, but I am not sure they give you a dub or not.

    BestBuy did give reprinted receipt I know it cuz I made them do it for me. Why? Some a$$hole fu<kup my Bestbuy card.
    2004 Matrix XR A7N8X-VM/400 AMD XP-M 2500+, DS-ATX
    89 Supra Turbo P3 600E@750/Abit BE6 II, Alpine M-BUS Car2PC.
    Y2K Accord Dell GX150
    RoadRunner is the best FE PERIOD
    EmoRebellion is a SCAMMER

  8. #8
    Variable Bitrate BIzFlawless's Avatar
    Join Date
    Oct 2005
    Location
    Texas
    Posts
    231
    Well wish me luck! I will try tommorrow, and get loud with them if I gotta, its worth the try

  9. #9
    Newbie
    Join Date
    Mar 2007
    Posts
    1
    hey, I'm new and I'm not sure if this is where i need to be or not. I also have a kenwood receiver kdc-mp 5028 and i need the codes to. any way you can help.

Similar Threads

  1. Kenwood "BUS" (MZ-BUS?) RCA input?
    By inik in forum General Hardware Discussion
    Replies: 8
    Last Post: 09-14-2008, 11:26 PM
  2. Car Idle - power/amp problem?
    By TheFaze in forum Car Audio
    Replies: 1
    Last Post: 12-15-2005, 11:10 PM
  3. had an all day (9 hr) problem at work....
    By wizardPC in forum Off Topic
    Replies: 13
    Last Post: 10-20-2005, 11:50 AM
  4. power on problem ??? help please anyone
    By Pingo1969 in forum Power Supplies
    Replies: 26
    Last Post: 04-07-2004, 07:47 AM
  5. I can't connect my hard drives + fan problem
    By haisook in forum General Hardware Discussion
    Replies: 0
    Last Post: 02-03-2004, 09:42 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •