Page 1 of 2 12 LastLast
Results 1 to 10 of 16

Thread: sub n amp

  1. #1
    Newbie
    Join Date
    Feb 2006
    Posts
    9

    sub n amp

    ok i got a 2000watt legacy amp and a db audio 15 inch raptor 1200watt. Is this a good combination? Would i overpower and blow the sub ?

  2. #2
    Newbie
    Join Date
    Apr 2006
    Posts
    10
    Need more info. What is the RMS on each? Is the sub 2 ohm, 4 ohm, or 8 ohm? How many channels does the amp have? Is it bridgeable? If it is what is the RMS when bridged and at what ohm? You can get all that info off the box and/or manual.

  3. #3
    Constant Bitrate
    Join Date
    Feb 2006
    Posts
    146
    It'll work as long as you keep your gains down, so that you are not making the sub overextend. Just because you CAN blow that sub with that amp, doesn't mean you HAVE TO. You've been warned.

    TUNE!

    http://www.350z-tech.com/zwiki/Tutor...plifier_Tuning

  4. #4
    Newbie
    Join Date
    Feb 2006
    Posts
    9
    thx furball ill try that.
    coleman i dont know what your talkin bout lol i jus want some bass!

  5. #5
    _
    Join Date
    Mar 2004
    Location
    Little Elm, Texas
    Posts
    13,500
    well, you had better learn fast then if you don't know what he's talking about.

    what's the ohm configuration?

    what are the RMS ratings (not max, rather RMS - look for the word RMS and tell us what's next to it)
    Jan Bennett
    FS: VW MKIV Bezel for 8" Lilliput - 95% Finished

    Please post on the forums! Chances are, someone else has or will have the same questions as you!

  6. #6
    Maximum Bitrate 3onDubs's Avatar
    Join Date
    Aug 2005
    Location
    Anaheim Hills, Ca
    Posts
    847
    Quote Originally Posted by Red GTi VR6
    what are the RMS ratings (not max, rather RMS - look for the word RMS and tell us what's next to it)
    ...and because the brands are raptor and legacy, divide those numbers by two...lol.
    PostCount++


    - SrCsTc's Bezel
    - Alpine W200/H701
    - ED Nine.2X
    - OZ Matrix Elites
    - ED Nine.1
    - Idmax 12's

  7. #7
    FLAC
    Join Date
    Sep 2004
    Location
    Falls Church, VA
    Posts
    904
    Sorry friend, but I have to say you have some very low end equipment. Do not get your hopes up and expect trouble down the road. The 2000 and 1200 watts that you had stated are not actual watts. They are HIGHLY over rated. Expect a couple hundred watts, keep the gains down and do NOT use any loud button or turn the bass above 0. Yes, it will be louder if you do, but you will blow them up.

  8. #8
    Newbie
    Join Date
    Feb 2006
    Posts
    9
    i neva knew this equipment was so crap. What about the same legacy 2000 watt amp, 2 channel 2 ohm bridgeable with that 5000 watt jbl sub ?

  9. #9
    Newbie
    Join Date
    Feb 2006
    Posts
    9
    jbl sub is 800 watt rms i think

  10. #10
    Maximum Bitrate 3onDubs's Avatar
    Join Date
    Aug 2005
    Location
    Anaheim Hills, Ca
    Posts
    847
    Quote Originally Posted by rudebwoy110
    i neva knew this equipment was so crap. What about the same legacy 2000 watt amp, 2 channel 2 ohm bridgeable with that 5000 watt jbl sub ?
    If you ever asked around anywhere on any audio forum or at any audio shop, anybody will tell you that legacy = crap (along with pyle, etc.).

    If you have a 2000 watt amp that is decent and you didn't pay over 500 bucks for it, it's probably a sucky amp...you would know if you had a good amp.

    What are you trying to accomplish with your system? My advice is to take out everything audio related from you car, sell it all, and start over....but this time, be sure to ask for advice before buying the amps. If you do stick with that combo, don't ever show it to anyone.
    PostCount++


    - SrCsTc's Bezel
    - Alpine W200/H701
    - ED Nine.2X
    - OZ Matrix Elites
    - ED Nine.1
    - Idmax 12's

Page 1 of 2 12 LastLast

Similar Threads

  1. vw mk4 monson amp and another amp
    By colorless in forum Car Audio
    Replies: 34
    Last Post: 09-05-2012, 11:43 AM
  2. del
    By hanzacra in forum General Hardware Discussion
    Replies: 5
    Last Post: 11-27-2007, 03:41 AM
  3. Amp running hot...??
    By Emerica2843 in forum General Hardware Discussion
    Replies: 5
    Last Post: 02-08-2006, 06:40 PM
  4. Amp running hot...??
    By Emerica2843 in forum Car Audio
    Replies: 6
    Last Post: 01-29-2006, 08:29 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •