Page 1 of 3 123 LastLast
Results 1 to 10 of 23

Thread: Hmm, what do we have here? Is that a new 5.1 amp???

  1. #1
    FLAC
    Join Date
    Sep 2004
    Location
    Falls Church, VA
    Posts
    904

    Hmm, what do we have here? Is that a new 5.1 amp???

    Came home to find this nifty little amp sitting in my doorway...

    Its the Autotek MM5.1. Its br nd new this year and replaces the hifonics 5.1 from years past. Same amp manufacturer, just a better input section. I havent hooked it up yet and I honestly do not expect the quality of the PG MS series stuff i normally use, but it will do for my 5.1 digital experiments.

    More to come...
    Attached Images Attached Images  

  2. #2
    Maximum Bitrate 3onDubs's Avatar
    Join Date
    Aug 2005
    Location
    Anaheim Hills, Ca
    Posts
    847
    That's a nice amp Will....let us know how you like it once you get it installed. Does it require a head unit or some sort of a controller to select the input and control volume?
    PostCount++


    - SrCsTc's Bezel
    - Alpine W200/H701
    - ED Nine.2X
    - OZ Matrix Elites
    - ED Nine.1
    - Idmax 12's

  3. #3
    Newbie pengu's Avatar
    Join Date
    Aug 2004
    Location
    Canberra, Australia
    Posts
    11
    Got a product page, or info about it? autotek's website lists nothing.
    www.Bobs-Bits.com - Where Stupidity meets Reality

  4. #4
    FLAC
    Join Date
    Sep 2004
    Location
    Falls Church, VA
    Posts
    904
    Yup, couldnt find it on their site yet either. Im installing it now. Will get some info asap

  5. #5
    FLAC
    Join Date
    Sep 2004
    Location
    Falls Church, VA
    Posts
    904
    Well i have had the amp installed for a day now. Have to say i REALLY like it. It has plenty of power for my 6 speakers and once i figured out the DSP i was good to go. There are a couple cons... First being you have to turn the amp on everytime you hop into the car with the remote. It does not turn on alone with a remote signal. Kinda funky and I hope i never lose/break the remote! The remote is a little handy for volume control and the ability to pop out stereo vs Phantom surround at the touch of a button. Secondly there is a popping sound when Prologic pops up on WinDVD. Im sure I will be able to fix it eventually.

    The amp allows for coax, optical or analog inputs and 4.1 or 5.1. There is the ability to control each channel independently and an override for the pro logic if needed. It has a video input and output to allow for a video game or secondary DVD hookup

    As far as specs go, I will have to look at the manual, but i believe its 50 watts by 5 rms and 1 x 200

  6. #6
    It ain't easy being a green moderator meddler's Avatar
    Join Date
    Aug 2002
    Location
    Steps out the front of Henson's workshop or Sydney
    Posts
    2,782
    What is the price? It is a bit odd that you have to turn it on with the remote, but there should be a work around. It would be interesting to have a closer look at the specs.
    Never let the truth get in the way of a good story

  7. #7
    Maximum Bitrate 3onDubs's Avatar
    Join Date
    Aug 2005
    Location
    Anaheim Hills, Ca
    Posts
    847
    Nice...now we have another 5.1 amp to add to the list. There might be a way to hardwire a remote turn on upon signal detection...but you'd probably need a hardware engineer to help out (unless you know aobut that stuff...i wouldn't know where to start).

    For the windvd, you could turn the amp off, start the program, then turn it back on...but that would be annoying i bet.
    PostCount++


    - SrCsTc's Bezel
    - Alpine W200/H701
    - ED Nine.2X
    - OZ Matrix Elites
    - ED Nine.1
    - Idmax 12's

  8. #8
    Newbie
    Join Date
    Apr 2006
    Location
    Illinois
    Posts
    14
    Eclipse HU

    FRONT
    MTX TXC6.1
    MTX TA5302 Amp

    BACK
    MTX 2x 7512X2-D
    MTX TA7801 Amp

  9. #9
    Newbie millc5's Avatar
    Join Date
    Nov 2005
    Location
    CA
    Posts
    53
    Quote Originally Posted by Will Albers
    Well i have had the amp installed for a day now. Have to say i REALLY like it. It has plenty of power for my 6 speakers and once i figured out the DSP i was good to go. There are a couple cons... First being you have to turn the amp on everytime you hop into the car with the remote. It does not turn on alone with a remote signal. Kinda funky and I hope i never lose/break the remote! The remote is a little handy for volume control and the ability to pop out stereo vs Phantom surround at the touch of a button. Secondly there is a popping sound when Prologic pops up on WinDVD. Im sure I will be able to fix it eventually.

    The amp allows for coax, optical or analog inputs and 4.1 or 5.1. There is the ability to control each channel independently and an override for the pro logic if needed. It has a video input and output to allow for a video game or secondary DVD hookup

    As far as specs go, I will have to look at the manual, but i believe its 50 watts by 5 rms and 1 x 200
    Will,
    I am trying to get info on this very amp. Glad to see someone has one, even Maxxsonics doesn't seem to have much to share.

    Anyway, one of the things I was told is that on this AMP they added a remote Bass control, is that true?

    Also, if its like the Hifonics version remote on does work with the Analog RCA inputs, it just wont activate the digital inputs until you hit the power button. I believe its a limitation of the chipset used for DTS/Dolby decoding. I have mine setup with RCA and Toslink so it fires up like a normal amp for music. I can hit the power button on the remote if I want to use the Toslink feed for DVD with surround.

    Thanks.

  10. #10
    FLAC
    Join Date
    Sep 2004
    Location
    Falls Church, VA
    Posts
    904
    Quote Originally Posted by MTX73

    Absolute PoS

Page 1 of 3 123 LastLast

Similar Threads

  1. For those who want true 5.1 Dolby Digital and DTS
    By antimatter in forum Car Audio
    Replies: 89
    Last Post: 06-29-2007, 11:54 AM
  2. 4 to 6 channel amp recomendation for 5.1 DD
    By antimatter in forum Car Audio
    Replies: 68
    Last Post: 09-23-2006, 06:44 PM
  3. Amp running hot...??
    By Emerica2843 in forum Car Audio
    Replies: 6
    Last Post: 01-29-2006, 07:29 PM
  4. PG Octane 5.1 v. Alpine DSP...
    By 3onDubs in forum Car Audio
    Replies: 15
    Last Post: 12-11-2005, 01:55 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •