Results 1 to 5 of 5

Thread: a/d/s/ PH15 amp

  1. #1
    Newbie
    Join Date
    Jul 2006
    Posts
    1

    a/d/s/ PH15 amp

    Hi,

    I have an a/d/s/ PH15 amp (6channel) and an a/d/s/ PQ20 amp (4 channel). Both do not have built in crossovers. I do however have a couple a/d/s/ 642ix crossovers sitting around.

    My question is to someone who is familiar with these old school a/d/s/ amps. What I want to do is use the 4 channel PQ20 (Ch1 & Ch2, Ch3 & Ch4 in bridged mode) to power my front speakers and use the PH15 (Ch1 & Ch2, Ch3 & Ch4 in bridged mode) to power my rear speakers. Then I would like to bridge Ch5 & Ch6 to power my single 8" 4 ohm sub.

    My question is regarding the DIN to RCA cable for the PH15. According to the a/d/s/ PH15 manual that can be seen here: http://www.4shared.com/dir/544401/2400a929/sharing.html, it appears I need some kind of break-out box? to reassign the pins on that DIN cable when in bridge mode. Anybody out there have any experience bridging channels with the PH15? Thanks.

  2. #2
    _
    Join Date
    Mar 2004
    Location
    Little Elm, Texas
    Posts
    13,500
    This forum is dedicated to CarPCs. Your question doesn't appear to have anything to do with CarPCs.

    As such, I would recommend hitting up a dedicated car audio forum.
    Jan Bennett
    FS: VW MKIV Bezel for 8" Lilliput - 95% Finished

    Please post on the forums! Chances are, someone else has or will have the same questions as you!

  3. #3
    Newbie
    Join Date
    Jul 2006
    Posts
    48
    We just used Y cables to get the signals to bridged channels on the last PH15 install I did. (10 years ago...)

  4. #4
    Newbie
    Join Date
    Oct 2006
    Posts
    3
    you dont need to use the pq20 for the front speakers. the ph15 will cover all of your front & rear speakers with no problem. the great thing about old a/d/s amps are that they are unregulated.

  5. #5
    Newbie
    Join Date
    Oct 2006
    Posts
    3
    so i was wondering if you would like to sell one of your 642ix crossovers...?

Similar Threads

  1. vw mk4 monson amp and another amp
    By colorless in forum Car Audio
    Replies: 34
    Last Post: 09-05-2012, 10:43 AM
  2. del
    By hanzacra in forum General Hardware Discussion
    Replies: 5
    Last Post: 11-27-2007, 02:41 AM
  3. Amp running hot...??
    By Emerica2843 in forum General Hardware Discussion
    Replies: 5
    Last Post: 02-08-2006, 05:40 PM
  4. Amp running hot...??
    By Emerica2843 in forum Car Audio
    Replies: 6
    Last Post: 01-29-2006, 07:29 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •