Results 1 to 7 of 7

Thread: 96 eddie bauer explorer audio system

  1. #1
    Newbie
    Join Date
    Aug 2006
    Location
    Washington
    Posts
    2

    96 eddie bauer explorer audio system

    I was wondering if it is possible to change the JBL sub and amp in the very back with aftermarket sub and amp of the eddie bauer 96 ford explorer. Or even if i have to just disable the stock sub and somehow wire around it. Some have said i need to get a new sterio, but others have said I can do it so im just looking for suggestions. Thanks all.

  2. #2
    Maximum Bitrate Naamanf's Avatar
    Join Date
    Sep 2003
    Location
    Colorado
    Posts
    508
    2007 Tahoe
    Opus with iBase 896 and Pentium M 735 Transflective Xenarc Alpine DVA-9861, PXA-H900, Sinfoni 45X2 (2) 90x2, Genesis Dual Mono, JL 1000/1 (2), Focal Be tweeters, ScanSpeak Revelator Mids, Dynaudio MW170, Dayton 12" Ref.

    My Install

  3. #3
    FLAC
    Join Date
    Jul 2001
    Posts
    1,109
    That audio system is kinda weird. Both amps are in the back next to the sub. The wires in the dash feed the stock amps but instead of looping back to the dash like most Fords do, the wires go straight to the speakers. That's a REALLY odd sized sub and it's an odd impedance too. Your best bet is disabling it and going aftermarket.

  4. #4
    Newbie
    Join Date
    Aug 2006
    Location
    Washington
    Posts
    2
    Does tthe stock sterio work with aftermarket subs and amps?

  5. #5
    FLAC
    Join Date
    Jul 2001
    Posts
    1,109
    The radio itself? Possibly, but why would you keep one part of a 10 year old stock system if you're putting in aftermarket gear?

  6. #6
    Newbie
    Join Date
    Jan 2006
    Posts
    6
    the factory radio will work with after market subs/amps as long as you buy a line output converter.

    but I agree with shadow. why keep one piece of a ten year old system? and the sound wont be that great using a line output converter.

  7. #7
    FLAC
    Join Date
    Jul 2001
    Posts
    1,109
    as long as you buy a line output converter.
    He's got factory amps so there's no high level output out of the radio. I'm not sure what kind of voltage is coming out of the radio so I don't know if it'll work with aftermarket amps.

Similar Threads

  1. OEM Navigation Connectors
    By Mr Castulucci in forum General Hardware Discussion
    Replies: 15
    Last Post: 07-20-2010, 06:25 PM
  2. How to mounting 94 Mazda mx6 audio system?
    By tonyso68 in forum Fabrication
    Replies: 1
    Last Post: 01-11-2006, 10:39 PM
  3. Audio problems, Epia Sound, and FAQ stuff
    By gothate in forum Newbie
    Replies: 2
    Last Post: 06-16-2005, 05:04 PM
  4. Question about audio system for CRV99
    By blahblah in forum General Hardware Discussion
    Replies: 7
    Last Post: 11-13-2001, 04:56 PM
  5. Connect hand held MP3 player to car audio system?
    By jasonwood in forum General Hardware Discussion
    Replies: 3
    Last Post: 10-31-2001, 12:30 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •