Page 2 of 2 FirstFirst 12
Results 11 to 16 of 16

Thread: How complete is it?

  1. #11
    CarFrontEnd Creator iamgnat's Avatar
    Join Date
    Jul 2004
    Location
    NoVA
    Posts
    867
    Well ain't that spiffy

    I just loaded a4 on my Mac Pro and it has the same issue that you describe (are all the UI elements grouped in the center of the screen?). I works on my MBP though (haven't gotten it out to the Mini yet).

    I'll poke at it before I go home tonight and see if I can't figure it out.

    -dave
    My pathetic worklog.
    CarFrontEnd (now it's own sub-forum!!!!)

  2. #12
    Newbie
    Join Date
    Dec 2003
    Posts
    18
    Dave,

    Fresh install of CFE, not an upgrade.

    UI elements are aligned to screen edges/corners as they would be on a smaller display.

    CFE is ticking over using 3-4% of the CPU, not doing anything particularly obvious. Time continues to update sanely.

    cmd-opt-esc causes it to quit immediately.

    HTH, happy to try anything new you come up with.

    Oh, also it looks like you might have an obi-wan with the left side of your buttons; there's a thin white stripe between the left half-circle and the button body itself.

    = Mike

  3. #13
    CarFrontEnd Creator iamgnat's Avatar
    Join Date
    Jul 2004
    Location
    NoVA
    Posts
    867
    Ok, I think I found the problem. Not seeing your screen, i'd have to guess (based on my case) that the elements were not where they were supposed to be.

    The problem on my Mac Pro was attributed to the elements being bound to the wrong side This was actually causing the buttons to appear under the splash view so you couldn't click on them.

    There is a weird artifact issue going on when I switch driver sides though (again, didn't see this on my MBP) that I still need to track down though.

    Apparently my installer package is not compatible with the Tiger version of PackageMaker so I can't offer a new installer until some time this evening, but if you are familiar with Xcode feel free to grab the latest changes and compile it yourself to see if that fixed your issue as well. It will probably be late tonight (go home, dinner, dog to vet, spend time with wife who is gone for a week and a half starting tomorrow, then build new installer ) before I get a new installer.

    Off to futz with the artifacting before I get out of here.

    BTW - The lines on the buttons are a known issue. They are better on some screens/resolutions than others. It is an artifact how I piece together the background image for them. I would like to dynamically generate the backgrounds, but I don't understand all the image drawing and core image stuff (and haven't found anyone that does yet). I really need to take another crack at fixing it as they irritate the hell out of me.

    -dave
    My pathetic worklog.
    CarFrontEnd (now it's own sub-forum!!!!)

  4. #14
    CarFrontEnd Creator iamgnat's Avatar
    Join Date
    Jul 2004
    Location
    NoVA
    Posts
    867
    Ok. I've bundled up 1.0a5 and put it up. See the change log thread for the details, but hopefully this fixes your issues.

    Let me know.

    Thanks,
    -dave
    My pathetic worklog.
    CarFrontEnd (now it's own sub-forum!!!!)

  5. #15
    Newbie
    Join Date
    Dec 2003
    Posts
    18
    Looks like it's working as intended, now; thanks.

    Since you're still working on the UI, I'll zip the lip for a bit, but I'll keep watching. I would definitely ignore the button cosmetics issue for now and work functionality. 8)

    = Mike

  6. #16
    CarFrontEnd Creator iamgnat's Avatar
    Join Date
    Jul 2004
    Location
    NoVA
    Posts
    867
    Glad it works.

    Any and all comments are welcome, just keep in mind that I may not jump on them depending on my feelings on the subject and what else i'm working on

    I think i'm about done with the 1.0 UI and API, then I can focus on some plugins for a bit. I still need to:
    1. Add a global preferences interface that the plugins can use so each doesn't have to do it's own thing.
    2. Add a remote control interface.
    3. Add custom NSTextField, NSTableView, NSButton (checkbox), NSButton (radio button), and scrolling NSView objects to facilitate more than just a button based interface.
    4. Add a "config" button to the Menu screen and move the driver side swap button there as well as other configuration (app, not plugin) options I want to add.

    And any little tweaks and bugs that come along

    Thanks,
    -dave
    My pathetic worklog.
    CarFrontEnd (now it's own sub-forum!!!!)

Page 2 of 2 FirstFirst 12

Similar Threads

  1. FS more car pc parts - complete laptop athlon XP-M 4 parts
    By fuctup in forum Classified Archive
    Replies: 4
    Last Post: 02-02-2006, 12:19 PM
  2. Replies: 11
    Last Post: 01-30-2006, 08:47 PM
  3. Complete LCD Comparison Chart
    By ddn in forum LCD/Display
    Replies: 7
    Last Post: 10-12-2005, 06:09 PM
  4. FS: Complete Mini-ITX CarPC w/Xenarc Monitor + More
    By DLe in forum Classified Archive
    Replies: 23
    Last Post: 10-19-2004, 08:15 PM
  5. For Sale Complete carputer
    By rb8720 in forum Classified Archive
    Replies: 6
    Last Post: 03-08-2004, 12:21 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •