Page 3 of 3 FirstFirst 123
Results 21 to 25 of 25

Thread: MappPoint 2006 "not available" error

  1. #21
    VENDOR - Centrafuse veetid's Avatar
    Join Date
    Apr 2004
    Posts
    5,040
    It is in C#

    david
    __________________
    CENTRAFUSE http://www.centrafuse.com
    01 Jeep Cherokee Sport 4x4 Installed
    M10000/512Mb/20GB, Lilliput 7", Holux GM-210

  2. #22
    Maximum Bitrate
    Join Date
    May 2006
    Location
    Seattleish, WA
    Posts
    823
    'k... I'm in the code and have some questions. Would you rather I ask them on the Flux forum?

    The first one's pretty basic - the project doesn't build right out of the box.
    :: Mark

  3. #23
    VENDOR - Centrafuse veetid's Avatar
    Join Date
    Apr 2004
    Posts
    5,040
    Quote Originally Posted by midiwall View Post
    'k... I'm in the code and have some questions. Would you rather I ask them on the Flux forum?

    The first one's pretty basic - the project doesn't build right out of the box.
    this has to be a simple reference issue and possibly a build location...

    the code does compile, I opened it yesterday to fix the map detection issue...

    you might wait until I get this update finished and post the new code that works without having both NA and Europe installed...

    david
    __________________
    CENTRAFUSE http://www.centrafuse.com
    01 Jeep Cherokee Sport 4x4 Installed
    M10000/512Mb/20GB, Lilliput 7", Holux GM-210

  4. #24
    Maximum Bitrate
    Join Date
    May 2006
    Location
    Seattleish, WA
    Posts
    823
    Cool.. I'm sure it's a reference issue of somesort. VisStud is complaining about not being able to find the namespaces:
    Code:
    C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\Microsoft.Common.targets : warning MSB3287: Cannot load type library for reference "AxMapPoint". Library not registered. (Exception from HRESULT: 0x8002801D (TYPE_E_LIBNOTREGISTERED))
    C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\Microsoft.Common.targets : warning MSB3287: Cannot load type library for reference "MapPoint". Library not registered. (Exception from HRESULT: 0x8002801D (TYPE_E_LIBNOTREGISTERED))
    c:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\Csc.exe /noconfig /unsafe- /checked- /nowarn:1701,1702 /nostdlib- /errorreport:prompt /warn:4 /baseaddress:285212672 /define:TRACE /reference:"C:\projects\Centrafuse SDK 1.12\Examples\Plugins\MapPoint\GPSUtilities\bin\Release\GPSUtilities.dll" /reference:c:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\System.Data.dll /reference:c:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\System.dll /reference:c:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\System.Drawing.dll /reference:c:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\System.Web.dll /reference:c:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\System.Windows.Forms.dll /reference:c:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\System.Xml.dll /debug- /filealign:4096 /optimize+ /out:obj\Release\MapPoint.dll /resource:obj\Release\CFMapPoint.CFMapPoint.resources /target:library /warnaserror- AsyncWebDownload\Download.cs AsyncWebDownload\Progress.cs MapPoint.cs MapPointUtils.cs menudialog.cs viewdialog.cs
    C:\projects\Centrafuse SDK 1.12\Examples\Plugins\MapPoint\viewdialog.cs(5,7): error CS0246: The type or namespace name 'centrafuse' could not be found (are you missing a using directive or an assembly reference?)
    C:\projects\Centrafuse SDK 1.12\Examples\Plugins\MapPoint\viewdialog.cs(9,28): error CS0246: The type or namespace name 'CFDialog' could not be found (are you missing a using directive or an assembly reference?)
    C:\projects\Centrafuse SDK 1.12\Examples\Plugins\MapPoint\AsyncWebDownload\Download.cs(6,7): error CS0246: The type or namespace name 'centrafuse' could not be found (are you missing a using directive or an assembly reference?)
    C:\projects\Centrafuse SDK 1.12\Examples\Plugins\MapPoint\menudialog.cs(8,7): error CS0246: The type or namespace name 'centrafuse' could not be found (are you missing a using directive or an assembly reference?)
    C:\projects\Centrafuse SDK 1.12\Examples\Plugins\MapPoint\menudialog.cs(9,7): error CS0246: The type or namespace name 'centrafuse' could not be found (are you missing a using directive or an assembly reference?)
    C:\projects\Centrafuse SDK 1.12\Examples\Plugins\MapPoint\menudialog.cs(13,28): error CS0246: The type or namespace name 'CFDialog' could not be found (are you missing a using directive or an assembly reference?)
    C:\projects\Centrafuse SDK 1.12\Examples\Plugins\MapPoint\MapPointUtils.cs(13,7): error CS0246: The type or namespace name 'centrafuse' could not be found (are you missing a using directive or an assembly reference?)
    C:\projects\Centrafuse SDK 1.12\Examples\Plugins\MapPoint\MapPoint.cs(13,7): error CS0246: The type or namespace name 'MapPoint' could not be found (are you missing a using directive or an assembly reference?)
    
    ... There's a total of 55 of 'em...
    I'll wait for the update. Thanks David.
    :: Mark

  5. #25
    VENDOR - Centrafuse veetid's Avatar
    Join Date
    Apr 2004
    Posts
    5,040
    You just have to add a reference to the MapPoint 2006 object, also possibly remove and re-add the cfplugin reference...

    You should expand the references and you will see some exclamation points where the reference is bad... Remove each one and right-click and add reference to add them back...

    to add MapPoint 2006 you will see it in the reference list if it is installed... For cfplugin just browse to the location of cfplugin.dll from the SDK...

    david
    __________________
    CENTRAFUSE http://www.centrafuse.com
    01 Jeep Cherokee Sport 4x4 Installed
    M10000/512Mb/20GB, Lilliput 7", Holux GM-210

Page 3 of 3 FirstFirst 123

Similar Threads

  1. Headunit (Linux/Windows CarPC frontend) + initial screenshots
    By NoPistonPC in forum Other Cool Front Ends
    Replies: 321
    Last Post: 08-24-2007, 03:57 PM
  2. Replies: 7
    Last Post: 07-01-2005, 04:29 PM
  3. ME 2.0 Official Bug Reports
    By phat_bastard in forum ME Archive
    Replies: 67
    Last Post: 01-31-2004, 07:27 PM
  4. Error #91
    By SiGmA_X in forum ME Archive
    Replies: 18
    Last Post: 01-08-2004, 10:40 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •