Page 3 of 26 FirstFirst 12345678910111213 ... LastLast
Results 21 to 30 of 252

Thread: XM / Sirius Worklog

  1. #21
    Constant Bitrate jwlionking's Avatar
    Join Date
    Apr 2005
    Location
    Saxton, PA - Central/Western PA
    Posts
    117
    Same issue as midiwall - no signal - verified xml had correct configs - also tried the xmpcr but did not work like it did for midiwall

    I have xmdirect also

    here is the error

    PHP Code:
    5/9/2007 11:30:37 AM
    Input string was not in a correct format
    .
       
    at System.Number.StringToNumber(String strNumberStyles optionsNumberBuffernumberNumberFormatInfo infoBoolean parseDecimal)
       
    at System.Number.ParseInt32(String sNumberStyles styleNumberFormatInfo info)
       
    at centrafuse.main.loadEQ()
    ----------------------------------------------------------------------------------------------------------
    5/9/2007 11:31:47 AM
    Index was out of range
    Must be non-negative and less than the size of the collection.
    Parameter nameindex
       at System
    .Collections.ArrayList.get_Item(Int32 index)
       
    at SatRadio.satradio.tuneChannel(Int32 channel)
    ----------------------------------------------------------------------------------------------------------
    9/5/2007 11:34:51 AM
    Could not find a part of the path 
    'C:\Documents and Settings\Administrator\Application Data\CFBluetoothControl\Temp'.
       
    at System.IO.__Error.WinIOError(Int32 errorCodeString maybeFullPath)
       
    at System.IO.Directory.InternalGetFileDirectoryNames(String pathString userPathOriginalString searchPatternBoolean includeFilesBoolean includeDirsSearchOption searchOption)
       
    at System.IO.Directory.GetFiles(String pathString searchPatternSearchOption searchOption)
       
    at System.IO.Directory.GetFiles(String path)
       
    at CFBluetoothControl.BluetoothControl.UninitBluetooth()
    ----------------------------------------------------------------------------------------------------------
    5/9/2007 12:02:14 PM
    Could not find file 
    'C:\Documents and Settings\Administrator\Local Settings\Application Data\Centrafuse\Presets\custom.xml'.
       
    at System.IO.__Error.WinIOError(Int32 errorCodeString maybeFullPath)
       
    at System.IO.FileStream.Init(String pathFileMode modeFileAccess accessInt32 rightsBoolean useRightsFileShare shareInt32 bufferSizeFileOptions optionsSECURITY_ATTRIBUTES secAttrsString msgPathBoolean bFromProxy)
       
    at System.IO.FileStream..ctor(String pathFileMode modeFileAccess accessFileShare shareInt32 bufferSize)
       
    at System.Xml.XmlDownloadManager.GetStream(Uri uriICredentials credentials)
       
    at System.Xml.XmlUrlResolver.GetEntity(Uri absoluteUriString roleType ofObjectToReturn)
       
    at System.Xml.XmlTextReaderImpl.OpenUrlDelegate(Object xmlResolver)
       
    at System.Threading.CompressedStack.runTryCode(Object userData)
       
    at System.Runtime.CompilerServices.RuntimeHelpers.ExecuteCodeWithGuaranteedCleanup(TryCode codeCleanupCode backoutCodeObject userData)
       
    at System.Threading.CompressedStack.Run(CompressedStack compressedStackContextCallback callbackObject state)
       
    at System.Xml.XmlTextReaderImpl.OpenUrl()
       
    at System.Xml.XmlTextReaderImpl.Read()
       
    at System.Xml.XmlLoader.Load(XmlDocument docXmlReader readerBoolean preserveWhitespace)
       
    at System.Xml.XmlDocument.Load(XmlReader reader)
       
    at System.Xml.XmlDocument.Load(String filename)
       
    at centrafuse.playlistManager.loadEQPreset()
       
    at centrafuse.playlistManager.loadXML()
    ----------------------------------------------------------------------------------------------------------
    5/9/2007 12:02:25 PM
    Input string was not in a correct format
    .
       
    at System.Number.StringToNumber(String strNumberStyles optionsNumberBuffernumberNumberFormatInfo infoBoolean parseDecimal)
       
    at System.Number.ParseInt32(String sNumberStyles styleNumberFormatInfo info)
       
    at centrafuse.main.loadEQ()
    ----------------------------------------------------------------------------------------------------------
    5/9/2007 12:02:30 PM
    Index was out of range
    Must be non-negative and less than the size of the collection.
    Parameter nameindex
       at System
    .Collections.ArrayList.get_Item(Int32 index)
       
    at SatRadio.satradio.tuneChannel(Int32 channel)
    ----------------------------------------------------------------------------------------------------------
    5/9/2007 12:03:53 PM
    Could not find a part of the path 
    'C:\Documents and Settings\Administrator\Application Data\CFBluetoothControl\Temp'.
       
    at System.IO.__Error.WinIOError(Int32 errorCodeString maybeFullPath)
       
    at System.IO.Directory.InternalGetFileDirectoryNames(String pathString userPathOriginalString searchPatternBoolean includeFilesBoolean includeDirsSearchOption searchOption)
       
    at System.IO.Directory.GetFiles(String pathString searchPatternSearchOption searchOption)
       
    at System.IO.Directory.GetFiles(String path)
       
    at CFBluetoothControl.BluetoothControl.UninitBluetooth()
    ----------------------------------------------------------------------------------------------------------
    5/9/2007 12:04:15 PM
    Could not find file 
    'C:\Documents and Settings\Administrator\Local Settings\Application Data\Centrafuse\Presets\custom.xml'.
       
    at System.IO.__Error.WinIOError(Int32 errorCodeString maybeFullPath)
       
    at System.IO.FileStream.Init(String pathFileMode modeFileAccess accessInt32 rightsBoolean useRightsFileShare shareInt32 bufferSizeFileOptions optionsSECURITY_ATTRIBUTES secAttrsString msgPathBoolean bFromProxy)
       
    at System.IO.FileStream..ctor(String pathFileMode modeFileAccess accessFileShare shareInt32 bufferSize)
       
    at System.Xml.XmlDownloadManager.GetStream(Uri uriICredentials credentials)
       
    at System.Xml.XmlUrlResolver.GetEntity(Uri absoluteUriString roleType ofObjectToReturn)
       
    at System.Xml.XmlTextReaderImpl.OpenUrlDelegate(Object xmlResolver)
       
    at System.Threading.CompressedStack.runTryCode(Object userData)
       
    at System.Runtime.CompilerServices.RuntimeHelpers.ExecuteCodeWithGuaranteedCleanup(TryCode codeCleanupCode backoutCodeObject userData)
       
    at System.Threading.CompressedStack.Run(CompressedStack compressedStackContextCallback callbackObject state)
       
    at System.Xml.XmlTextReaderImpl.OpenUrl()
       
    at System.Xml.XmlTextReaderImpl.Read()
       
    at System.Xml.XmlLoader.Load(XmlDocument docXmlReader readerBoolean preserveWhitespace)
       
    at System.Xml.XmlDocument.Load(XmlReader reader)
       
    at System.Xml.XmlDocument.Load(String filename)
       
    at centrafuse.playlistManager.loadEQPreset()
       
    at centrafuse.playlistManager.loadXML()
    ----------------------------------------------------------------------------------------------------------
    5/9/2007 12:04:26 PM
    Input string was not in a correct format
    .
       
    at System.Number.StringToNumber(String strNumberStyles optionsNumberBuffernumberNumberFormatInfo infoBoolean parseDecimal)
       
    at System.Number.ParseInt32(String sNumberStyles styleNumberFormatInfo info)
       
    at centrafuse.main.loadEQ()
    ----------------------------------------------------------------------------------------------------------
    5/9/2007 12:04:31 PM
    Index was out of range
    Must be non-negative and less than the size of the collection.
    Parameter nameindex
       at System
    .Collections.ArrayList.get_Item(Int32 index)
       
    at SatRadio.satradio.tuneChannel(Int32 channel)
    ----------------------------------------------------------------------------------------------------------
    5/9/2007 12:19:23 PM
    Index was out of range
    Must be non-negative and less than the size of the collection.
    Parameter nameindex
       at System
    .Collections.ArrayList.get_Item(Int32 index)
       
    at SatRadio.satradio.tuneChannel(Int32 channel)
    ----------------------------------------------------------------------------------------------------------
    5/9/2007 12:21:18 PM
    Index was out of range
    Must be non-negative and less than the size of the collection.
    Parameter nameindex
       at System
    .Collections.ArrayList.get_Item(Int32 index)
       
    at SatRadio.satradio.tuneChannel(Int32 channel)
    ---------------------------------------------------------------------------------------------------------- 
    DigitalFX4.0 Skin by JohnWPB

    Road Runner RR's Myspace

    My Ride - Car Domain Page -JWLionKing's MySpace Page

    Project 98% Complete -FREE DOMAIN & WEBSPACE / FILE HOST FOR DEVELOPERS - PM ME

  2. #22
    Maximum Bitrate
    Join Date
    May 2006
    Location
    Seattleish, WA
    Posts
    823
    Quote Originally Posted by smeesseman View Post
    Just to make sure, the log file is being created?
    Actually, no...

    I don't even have a "Local Settings" directory under "Docs and Settings". I searched for all *.log and there was nothing relating to CF 'cept the old one in my 1.14 backup directory.


    {rant}
    Add a vote that I think it's VERY wrong to have the logs away from the app. It's one of my common gripes about Windows in that AppCrap (technical term!) is laid all over the place. Logs should be in something like:

    {application directory}\logs

    Makes them very easy to find and helps in not having to chase all over the place looking to clean up an app.

    Oh well.
    {/rant}


    EDIT:
    Also, do you keep power to the XMDirect? It is possible that being set to XMPCR will work if the XMDirect had been set in PCR mode beforehand, only a poweroff to the XMDirect would reset that... Play with that a bit more if you can, see if setting it back to XMDirect in the Settings causes it to not work again...
    Interesting point about power... No, it's toggled from a relay with the ACC line as a trigger.

    I do have new info for you about this and other things...
    • XM didn't survive an overnight hibernate. When CF came back up, XM was there and would react to clicks, but there was no content information (station names were displayed). I bounced settings a couple of times from XMPCR to XMDirect and back again, but nada. Exiting CF and reloading brought XM up.

      I just checked after a short hibernate (about 10 minutes) and it _did_ come back up just fine.

      NOTE: This means that XM is now running with the device option set to "XMDirect". If I set it BACK to XMPCR, it doesn't work. Now, given that when hibernate kicked in last night CF "thought" it was talking XMPCR, then I would suspect that when the module reloaded, it really DID set XMPCR and thus it didn't work. But then, I would have thought that flipping back and forth from XMDirect to XMPCR would have joggled it back to life. Hmmm...

    • XM keeps playing after exiting CF

    • Setting "Buffer enable" doesn't do anything, but I'll bet you know that and it's 'cause that as a plugin you no longer have access to CF's buffering?

    • Single click is _DEFINITELY_ fixed. WELL DONE!
    :: Mark

  3. #23
    VENDOR - Centrafuse smeesseman's Avatar
    Join Date
    Mar 2007
    Location
    Detroit, MI
    Posts
    392
    Quote Originally Posted by jwlionking View Post
    Same issue as midiwall - no signal - verified xml had correct configs - also tried the xmpcr but did not work like it did for midiwall
    I have xmdirect also
    Quote Originally Posted by midiwall View Post
    Actually, no...
    I don't even have a "Local Settings" directory under "Docs and Settings". I searched for all *.log and there was nothing relating to CF 'cept the old one in my 1.14 backup directory.
    OK yeah that is a problem if you are going to run 1.20. To be compatible with Windows Vista, David had to move all of the writeable files to that directory.

    So, do you have "Show Hidden Files and Folders" set in Windows Explorer? Make sure, 'cause the Locall Settings folder is a "hidden" folder. If you do, and it's still not there, then we have to go from there.

  4. #24
    VENDOR - Centrafuse smeesseman's Avatar
    Join Date
    Mar 2007
    Location
    Detroit, MI
    Posts
    392
    Quote Originally Posted by midiwall View Post
    Actually, no...

    I don't even have a "Local Settings" directory under "Docs and Settings". I searched for all *.log and there was nothing relating to CF 'cept the old one in my 1.14 backup directory.
    See my previous post...

    Quote Originally Posted by midiwall View Post
    {rant}
    Add a vote that I think it's VERY wrong to have the logs away from the app. It's one of my common gripes about Windows in that AppCrap (technical term!) is laid all over the place. Logs should be in something like:

    {application directory}\logs

    Makes them very easy to find and helps in not having to chase all over the place looking to clean up an app.

    Oh well.
    {/rant}
    I completely agree, but Vista requires it now...

    Quote Originally Posted by midiwall View Post
    XM didn't survive an overnight hibernate. When CF came back up, XM was there and would react to clicks, but there was no content information (station names were displayed). I bounced settings a couple of times from XMPCR to XMDirect and back again, but nada. Exiting CF and reloading brought XM up.

    I just checked after a short hibernate (about 10 minutes) and it _did_ come back up just fine.

    NOTE: This means that XM is now running with the device option set to "XMDirect". If I set it BACK to XMPCR, it doesn't work. Now, given that when hibernate kicked in last night CF "thought" it was talking XMPCR, then I would suspect that when the module reloaded, it really DID set XMPCR and thus it didn't work. But then, I would have thought that flipping back and forth from XMDirect to XMPCR would have joggled it back to life. Hmmm...
    I'll look into this...
    Quote Originally Posted by midiwall View Post
    XM keeps playing after exiting CF
    I'll look into this...
    Quote Originally Posted by midiwall View Post
    Setting "Buffer enable" doesn't do anything, but I'll bet you know that and it's 'cause that as a plugin you no longer have access to CF's buffering?
    Yep, but David will put access to it in the next SDK, so it (buffering) will be there eventually...
    Quote Originally Posted by midiwall View Post
    Single click is _DEFINITELY_ fixed. WELL DONE!
    Good to hear, one down still many to go :-)

  5. #25
    VENDOR - Centrafuse veetid's Avatar
    Join Date
    Apr 2004
    Posts
    5,040
    As soon as the base code for XM and Sirius is working the buffer code will be added back into the plugin before it is finished...

    it is just easier to have it not mess with the buffer until we are sure the code is all working, then the buffer will be added...

    As for LocalAppData, I also agree but you HAVE to move it to this location for Vista compatibility... Only admin with lots of rigs can properly write inside Program Files folder in Vista, and it makes your app not be able to be certified or signed properly...

    david
    __________________
    CENTRAFUSE http://www.centrafuse.com
    01 Jeep Cherokee Sport 4x4 Installed
    M10000/512Mb/20GB, Lilliput 7", Holux GM-210

  6. #26
    Maximum Bitrate
    Join Date
    May 2006
    Location
    Seattleish, WA
    Posts
    823
    Quote Originally Posted by smeesseman View Post
    OK yeah that is a problem if you are going to run 1.20. To be compatible with Windows Vista, David had to move all of the writeable files to that directory.
    I HATE microsloth. Always have, even when I spent 3 years under their umbrella. argh.


    So, do you have "Show Hidden Files and Folders" set in Windows Explorer? Make sure, 'cause the Locall Settings folder is a "hidden" folder. If you do, and it's still not there, then we have to go from there.
    Oh yeah, I ALWAYS turn that on ("Dear Windows; Please don't hide stuff from me, let me shoot myself in the foot if I want to, this is MY machine, not yours."). Local Settings shows up in other folders, like the user folders.

    I'll create it and see if CF gets happier about writing logs.
    :: Mark

  7. #27
    Maximum Bitrate
    Join Date
    May 2006
    Location
    Seattleish, WA
    Posts
    823
    Ummm, so you mention:

    c:\Documents and Settings\Local Settings\Application Data\Centrafuse\Plugins\SatRadio

    And I've said that i don't see a "Local Settings" under "Doc and Settings", but then... I don't have a "Local Settings" at that spot on my work machine either. Are you sure we're not talking about:

    c:\Documents and Settings\{user name}\Local Settings\Application Data\Centrafuse\Plugins\SatRadio

    ? I'm gonna run out to the car and look...
    :: Mark

  8. #28
    VENDOR - Centrafuse smeesseman's Avatar
    Join Date
    Mar 2007
    Location
    Detroit, MI
    Posts
    392
    Quote Originally Posted by midiwall View Post
    Ummm, so you mention:

    c:\Documents and Settings\Local Settings\Application Data\Centrafuse\Plugins\SatRadio

    And I've said that i don't see a "Local Settings" under "Doc and Settings", but then... I don't have a "Local Settings" at that spot on my work machine either. Are you sure we're not talking about:

    c:\Documents and Settings\{user name}\Local Settings\Application Data\Centrafuse\Plugins\SatRadio

    ? I'm gonna run out to the car and look...
    oh crap yeah that is what I mean, forgot to stick in the /username/ portion of that path... apologies for that...

  9. #29
    VENDOR - Centrafuse smeesseman's Avatar
    Join Date
    Mar 2007
    Location
    Detroit, MI
    Posts
    392
    Quote Originally Posted by midiwall View Post
    "Dear Windows; Please don't hide stuff from me, let me shoot myself in the foot if I want to, this is MY machine, not yours."
    Funniest thing I've heard this week

  10. #30
    VENDOR - Centrafuse smeesseman's Avatar
    Join Date
    Mar 2007
    Location
    Detroit, MI
    Posts
    392
    Quote Originally Posted by jwlionking View Post
    Same issue as midiwall - no signal - verified xml had correct configs - also tried the xmpcr but did not work like it did for midiwall
    I have xmdirect also
    Look to see if you have the log file:
    c:\Documents and Settings\{USERNAME}\Local Settings\Application Data\Centrafuse\Plugins\SatRadio\log.txt

    That's the one I need to see....

    - Scott

Similar Threads

  1. Replies: 42
    Last Post: 12-11-2009, 03:36 PM
  2. XM = Sirius! Merger Reported
    By lostreception in forum General MP3Car Discussion
    Replies: 6
    Last Post: 02-20-2007, 10:53 AM
  3. Got XM to work, then it took a dump
    By DuDs in forum StreetDeck
    Replies: 3
    Last Post: 05-06-2006, 06:42 PM
  4. XM Satellite Radio to Unveil XM Advanced Services at 2006 Consumer
    By Will Albers in forum General MP3Car Discussion
    Replies: 2
    Last Post: 03-27-2006, 09:49 PM
  5. Sirius vs. XM...? what up Gee?
    By mindscream in forum Car Audio
    Replies: 12
    Last Post: 10-24-2004, 04:31 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •