Results 1 to 10 of 10

Thread: UI Softlock

  1. #1
    Newbie
    Join Date
    Dec 2007
    Location
    Orlando, FL
    Posts
    22

    UI Softlock

    Howdy Y'all,

    I am seeing a problem with CF 1.46 and 1.47 which is causing considerable pain.

    I recently installed the 1.47 update, and I have noticed that the Centrafuse UI will sometimes lock on resume from hibernate. I installed the 1.46 update, and the problem went away for a few days, but is now worse than ever.

    I think it may be related to the Satellite radio plugin. At first, the UI would freeze when I selected the XM radio button from the main menu. The button would stay in the pressed/highlighted state, and the entire UI would become unresponsive. No click sounds, no nothing. I turned the ignition off on the car, and the PC went to hibernation correctly. This particular lock never happens when i press any other button. In fact, I can go between media, settings, dvd, and other features, but as soon as I press the Xm button, the UI freezes.

    When i restarted the car, Centrafuse came back up on the XM radio screen. I also heard a centrafuse button click sound when the pc came all the way back from hibernation. It was as though the CF UI had queued the button up event and processed it correctly after the resume.

    Since then, things have gotten worse. Sometimes when I resume from hibernation, the CF UI comes up and is immediately locked. If i power off, it goes to hibernation correctly. When I powered back up, the UI would be responsive.

    Here's where it gets interesting -- When the UI becomes softlocked, if i attempted to press any of the buttons on the screen, nothing would happen. no button highlighting or anything... it was just locked. i would press the back/exit button several times, and got no response. After hibernating and then resuming, centrafuse would become responsive and processed all the button events! i would hear several click sounds, and the exit menu would be on screen (i have my settings such that the exit menu pops up on exit). It seems like windows processed the click events, and that centrafuse was just sorta *stuck*. After the resume, it would go about its business, processing the events like nothing happened.

    Occasionally, the CF UI does not come back up from hibernation, and I am stuck with a black screen. If i turn the ignition off, the PC goes into hibernation again, correctly (i see the windows desktop for a moment, and then the "preparing to hibernate" screen). when i turned the ignition back on, the CF UI would come back up and would be functional.

    Today, the problem was at its worst. I got the black screen on startup this morning. I turned the car off, and the pc went right to hibernation. I powered up again, and the black screen reappeared. This happened several times, and I eventually just had to do a hard reset.

    Is anyone seeing this issue. I looked and searched for these symptoms, but didn't find anything. It's really frustrating.

    Thanks!

  2. #2
    Maximum Bitrate
    Join Date
    May 2006
    Location
    Seattleish, WA
    Posts
    823
    Your problems are worse than others, but there are definitely issues with RESUME, some are specific to the XM module. I reported what I'm seeing here:

    Centrafuse 1.47 Update
    :: Mark

  3. #3
    VENDOR - Centrafuse veetid's Avatar
    Join Date
    Apr 2004
    Posts
    5,040
    is this only with the SatRadio plugin installed? anyway to remove this plugin and see if this issue goes away to verify?

    david
    __________________
    CENTRAFUSE http://www.centrafuse.com
    01 Jeep Cherokee Sport 4x4 Installed
    M10000/512Mb/20GB, Lilliput 7", Holux GM-210

  4. #4
    Maximum Bitrate
    Join Date
    May 2006
    Location
    Seattleish, WA
    Posts
    823
    Quote Originally Posted by veetid View Post
    is this only with the SatRadio plugin installed? anyway to remove this plugin and see if this issue goes away to verify?
    I've done that... But like I mentioned in the main thread, it's not because of the SatRadio plugin:

    ref: Centrafuse 1.47 Update
    :: Mark

  5. #5
    Newbie
    Join Date
    Dec 2007
    Location
    Orlando, FL
    Posts
    22
    i failed to mention that the ui softlock often occurred when I was not using the satellite feature. Once this starts happening, it doesn't matter what I am doing with CF. A lot of the time, it would occur when I was listening to media instead of sat. It's happened when playing a DVD, and even when I have stopped all playback.

    It got so bad that I just decided to cold-boot my carPC every time now. It's annoying, but it only costs a few more seconds than returning from hibernate, and it's reliable -- i haven't had an incident since.

    "The most likely way for the world to be destroyed, most experts agree, is by accident. That's where we come in; we're computer professionals. We cause accidents." - Nathaniel Borenstein

  6. #6
    VENDOR - Centrafuse veetid's Avatar
    Join Date
    Apr 2004
    Posts
    5,040
    is there any chance this is the touchscreen stopping to work and Centraufse not locking up?

    does the elapsed time still show moving?

    david
    __________________
    CENTRAFUSE http://www.centrafuse.com
    01 Jeep Cherokee Sport 4x4 Installed
    M10000/512Mb/20GB, Lilliput 7", Holux GM-210

  7. #7
    Maximum Bitrate
    Join Date
    May 2006
    Location
    Seattleish, WA
    Posts
    823
    Hi David; I think I have a couple of things that may help with this...

    • When I have the issue with "CF hangs on resume after email app has connected", (this post and the one after it) the issue is NOT with the USB connection to the screen going flaky. When this happens to me, I can power the screen up down, disconnect/reconnect and can't get any touch response at all.

    • I tripped over this one this morning...Try this:
      • Given that CF is running
      • Minimize CF, leave the PC showing the desktop
      • Power off, let the PC hibernate
      • Power on, let the PC resume
      • Click on START/SHUTDOWN and select Restart
      • Windows will chug away for a bit, then show an error that CF isn't responding and give an option to "End Now" or "Cancel".


      I think that could be a clue... I would have expected CF to be running after resume and respond to a shutdown request from Windows.

    Also, what does the "Power off action" setting do in General Settings? It definitely changes the behavior of CF, and the PC on resume, but I didn't think it was hooked up?
    :: Mark

  8. #8
    VENDOR - Centrafuse veetid's Avatar
    Join Date
    Apr 2004
    Posts
    5,040
    I will look into this for sure...

    the power ignition action simply changes the power button action in windows power mode settings...

    david
    __________________
    CENTRAFUSE http://www.centrafuse.com
    01 Jeep Cherokee Sport 4x4 Installed
    M10000/512Mb/20GB, Lilliput 7", Holux GM-210

  9. #9
    Maximum Bitrate
    Join Date
    May 2006
    Location
    Seattleish, WA
    Posts
    823
    Quote Originally Posted by veetid View Post
    the power ignition action simply changes the power button action in windows power mode settings...
    Ahh.. okay, that makes sense.

    I had it in my head that CF was doing something within itself and that couldn't explain things I was seeing. (i.e., "brain fart" )


    Thanks for looking at the other stuff!
    :: Mark

  10. #10
    Newbie
    Join Date
    Dec 2007
    Location
    Orlando, FL
    Posts
    22
    Quote Originally Posted by veetid View Post
    is there any chance this is the touchscreen stopping to work and Centraufse not locking up?

    does the elapsed time still show moving?

    david
    nope. the clock does not update; no audio plays either. it's completely locked.

    I know it's not the touchscreen either because the mouse pointer re-appears when the desktop is displayed right before hibernating, and it's always located right where i last touched the screen. If i try to press the back/close button, the mouse pointer will be in the lower right corner. if i touch the volume controls, the pointer is in the lower left.

    sometimes if i am quick enough, i can actually drag the mouse pointer around a little bit right before the hibernating screen appears.

    Thanks for all the hard work, by the way. I tried out several front ends, and centrafuse is far and away the best product out there.

    "The most likely way for the world to be destroyed, most experts agree, is by accident. That's where we come in; we're computer professionals. We cause accidents." - Nathaniel Borenstein

Similar Threads

  1. Zune UI Skin
    By rigg419 in forum RR Skins
    Replies: 5
    Last Post: 04-09-2007, 01:33 AM
  2. UI Elements
    By dwhite in forum DigitalMods (Scripts / API)
    Replies: 3
    Last Post: 08-06-2006, 06:30 PM
  3. Different UI components
    By dwhite in forum DigitalMods (Scripts / API)
    Replies: 2
    Last Post: 06-05-2006, 03:00 AM
  4. Replies: 2
    Last Post: 08-15-2005, 10:43 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •