Page 1 of 5 12345 LastLast
Results 1 to 10 of 43

Thread: CF 2.0 RC3: Bugs / issues / suggestions

  1. #1
    Maximum Bitrate
    Join Date
    Apr 2007
    Location
    USA
    Posts
    496

    CF 2.0 RC3: Bugs / issues / suggestions

    I'm new to CF, and I wasn't able to use RC2 much due to some bugs, so I don't know how new these issues are.

    I'm using an Infill G4 with a Turtle Beach Audio Advantage USB sound card. My normal front end is Streetdeck.

    Here are the issues I'm seeing in CF 2.0 RC3:

    1. When I first started using RC3, I couldn't get the volume all the way down (not even close) with the volume buttons (either the hard buttons on the G4, or the soft volume buttons at the bottom-left of the CF screen). I would get a message such as "volume at minimum". Mute also did nothing. Eventually later after visiting the Mixer a couple of times, the problem went away (I didn't make any real changes in the Mixer, but I did see that the volume controls there would get it to zero).
    2. While I can actually make calls with my phone (Nokia 6133), CF doesn't import or show my contacts.
    3. After disconnecting my phone (even turning it off), the battery/reception icons stayed on the screen. They were eventually gone after I restarted CF.
    4. It is confusing that you get a message similar to "Cannot make call" when you press the green phone button without a contact in the list. I would expect to get an explanation that I need to add a contact, or give me a wizard to add a contact, or just give me a dialpad.
    5. Gestures don't seem to work on all screens. Very frustrating if you rely on gestures and need to pause a song while you're buried in a settings submenu.
    6. Would be nice to have a more opaque/thicker trail on the screen to show your gestures. It is hard to see sometimes.
    7. In the Settings, the Infill item just gives a message that there are no settings. I expected to get the same options that I get when clicking the Infill button from the main menu (Tilt and Brightness).
    8. Would be nice to automatically add the Infill button to the main menu for Infill users. Especially due to the next item.
    9. Pressing the top/bottom of the Infill G4 screen does not tilt it. I had to add the Infill button to the main menu. That does let me tilt it, but that is a lot more tedious than just pressing on the screen (and not at all safe while driving).
    10. The Brightness controls in the Infill settings window don't do anything.
    11. There is no apparent way to know how to activate Shuffle/Random without someone telling you. I got lucky and happened to press on the area of the screen that made the word "Random" appear; before that I had looked for about 10 minutes. I think it's posted here on the message board somewhere, but I was in my car with no Internet access.
    12. I don't think the Shuffle/Random mode works correctly. When I'm listening to Song B and go Back to the previous Song A, it is impossible to get back Song B. Instead, it randomly picks some other song in the queue. That is unlike all other media players I've used before, and it is especially annoying due to my next item.
    13. The "Skip Back" feature will actually keep going backward into the previous song. I really think that just the Previous Track button should be used for that. And due to the previous Shuffle issue, once you go even a second into the Previous Track, you can't get back to the original song (instead it goes to a random track).
    14. I haven't been able to get any Radio audio (I'll post on that separately), but the Scan button doesn't work. It just tunes up at the same interval as the Tune + button (so if I am tuned to station 101.5, the Scan button will just tune to 102.5).
    15. At least twice over a couple of hours, CF locked up on me. The audio continued to play, and the CPU was not maxed (though CF regularly uses 85% CPU playing audio - more than Winamp). On the second of those, I could End Task and restart CF but it would just be frozen at the main menu (no audio playing). I could End Task it (and it was gone from memory), but I had to reboot to make CF work again.

    16. Would be nice to see the times for each track listed in the Playlist/Music screens.
    17. Would be nice to get a more clear visual indication when you are in speech-recognition mode. The tiny icon isn't really enough while driving.
    18. Would be nice to greatly reduce the time allotted for each speech recognition event.
    19. It is confusing that on some settings screens, you have to double-click a list item to access it, while on others you just click an item once.
    20. It would be nice if there was a way to suppress the confirmation prompt that appears when saving many of the settings. I wouldn't click Save unless I meant it.

    21. And a question: What does the headset-like icon at the top-right of the window stand for? When my cell phone is not connected, the icon flashes on/off at irregular intervals. Here's a screenshot:

  2. #2
    VENDOR - Centrafuse veetid's Avatar
    Join Date
    Apr 2004
    Posts
    5,040
    1. We will look into it...

    2. We do not support reading contacts or sending SMS yet, these features will be added... You can import with vCards, or enter your contacts into Centrafuse with the interface...

    3. We will look into it..

    4. Not a bad idea, we can make it just launch the dial pad in this case possibly, will look into it..

    5. Gestures do not work in navigation due to panning on the map, as well as on top of list views because of throw scrolling on the listviews, we are looking into solutions...

    6. we can look into this, but there is a file gestures.xml were you can edit the color, this will be in your LocalAppData\Centrafuse\System\ folder...

    7. Infill from the main menu is the plugin, there are no settings for the Infill, it actually should have not showed up in the list, were you in advanced settings or basic?

    8. Could look into it, installer would have to detect or ask if Infill user... It's better, before the base installer didn't even include all the Infill code so it's a step forward

    9. we could look to add this in the future, will put it on a list, but very specific Infill code, but will still make a note of it...

    10. Will look into it...

    11. You click anywhere on top of the list you want to random and it will make that playlist random, you click it again to turn it off... It is related to making the current list random... We have an updated manual coming soon...

    12. When in random mode going forward is always a random song...

    13. not sure what you mean, you mean holding rewind down?

    14. Go to settings and disable buffer mode, believe there are issues with Infill and buffer mode we are working on... Go to Settings, AM/FM, make sure you are in advanced mode, make sure the radio is set to Infill and both Recording and Playback are set to Line-In, then turn buffer OFF...

    15. Are you using phone?

    16. you can click and toggle to show play time and remaining time..

    17. Speech is PTT, you click the speech button and you have a few seconds to say your command, there is no mode really, you just push to talk...

    18. not sure what you mean...

    19. can you give an example?

    20. this is a safe guard, and once your system is setup you most likely will not be changing settings all the time...

    21. That means it has a HFP or Headset connection to your phone, when blinking it it searching for your phone because it doesn't have a connection...



    Now seeing the phone icon I know you are running phone, we have a report that phone does not run great on the Infill... Try to disable phone and run Centrafuse for a day and see if it runs faster, stops locking up, and the CPU usage goes down...

    david
    __________________
    CENTRAFUSE http://www.centrafuse.com
    01 Jeep Cherokee Sport 4x4 Installed
    M10000/512Mb/20GB, Lilliput 7", Holux GM-210

  3. #3
    Maximum Bitrate
    Join Date
    Apr 2007
    Location
    USA
    Posts
    496
    Quote Originally Posted by veetid View Post
    1. We will look into it...

    7. Infill from the main menu is the plugin, there are no settings for the Infill, it actually should have not showed up in the list, were you in advanced settings or basic?
    Advanced.

    11. You click anywhere on top of the list you want to random and it will make that playlist random, you click it again to turn it off... It is related to making the current list random... We have an updated manual coming soon...
    Well... for something as important as how to get into shuffle mode I really think there should be some visual indication on the screen. A lot of people are going to be frustrated if they have to read the manual for something as basic as that.

    12. When in random mode going forward is always a random song...
    Any chance you can change that? It really is extremely frustrating not to be able to get back to the song that was playing.

    13. not sure what you mean, you mean holding rewind down?
    Either holding down Rewind or just pressing it repeatedly one too many times.

    16. you can click and toggle to show play time and remaining time..
    I'm asking for the track length to show next to each track in the list, like in Streetdeck. (Though in SD it's broken for FLAC songs, just showing "0:00" for each.)

    17. Speech is PTT, you click the speech button and you have a few seconds to say your command, there is no mode really, you just push to talk...
    Unless you had some audio playing so that you know PTT is activated by the audio being stopped, you have no clear visual indication that it is in PTT mode. Streetdeck shows a large message on the screen that you have no problem seeing while driving.

    18. not sure what you mean...
    I think that PTT is active for too long (which is annoying because your music is disabled for all that time). It seems like it was around 10 seconds before the music resumed.

    19. can you give an example?
    I think on the options screen for choosing the main menu buttons, you just press each option once. I was so used to having to double-click the buttons that I sometimes accidentally wiped out a button's assignment by "double-clicking" it, with the second click acting on the second screen where the assignment was selected.

    Now seeing the phone icon I know you are running phone, we have a report that phone does not run great on the Infill... Try to disable phone and run Centrafuse for a day and see if it runs faster, stops locking up, and the CPU usage goes down...
    Okay.



    Thanks,
    John

  4. #4
    VENDOR - Centrafuse smeesseman's Avatar
    Join Date
    Mar 2007
    Location
    Detroit, MI
    Posts
    392
    Quote Originally Posted by johnk View Post
    When I first started using RC3, I couldn't get the volume all the way down (not even close) with the volume buttons (either the hard buttons on the G4, or the soft volume buttons at the bottom-left of the CF screen). I would get a message such as "volume at minimum". Mute also did nothing. Eventually later after visiting the Mixer a couple of times, the problem went away (I didn't make any real changes in the Mixer, but I did see that the volume controls there would get it to zero).
    Added to bug database BUG-000186

    Quote Originally Posted by johnk View Post
    While I can actually make calls with my phone (Nokia 6133), CF doesn't import or show my contacts.
    No support for contact importing yet.

    Quote Originally Posted by johnk View Post
    After disconnecting my phone (even turning it off), the battery/reception icons stayed on the screen. They were eventually gone after I restarted CF.
    Added to bug database BUG-000187

    Quote Originally Posted by johnk View Post
    It is confusing that you get a message similar to "Cannot make call" when you press the green phone button without a contact in the list. I would expect to get an explanation that I need to add a contact, or give me a wizard to add a contact, or just give me a dialpad.
    Added to bug database BUG-000188

    Quote Originally Posted by johnk View Post
    in the Settings, the Infill item just gives a message that there are no settings. I expected to get the same options that I get when clicking the Infill button from the main menu (Tilt and Brightness).
    Added to bug database BUG-000189

    Quote Originally Posted by johnk View Post
    Would be nice to automatically add the Infill button to the main menu for Infill users. Especially due to the next item. Pressing the top/bottom of the Infill G4 screen does not tilt it. I had to add the Infill button to the main menu. That does let me tilt it, but that is a lot more tedious than just pressing on the screen (and not at all safe while driving). The Brightness controls in the Infill settings window don't do anything.
    Added to bug database BUG-000190

    Quote Originally Posted by johnk View Post
    At least twice over a couple of hours, CF locked up on me. The audio continued to play, and the CPU was not maxed (though CF regularly uses 85% CPU playing audio - more than Winamp). On the second of those, I could End Task and restart CF but it would just be frozen at the main menu (no audio playing). I could End Task it (and it was gone from memory), but I had to reboot to make CF work again.
    Added to bug databse, BUG-000191
    After a lockup, when you kill Centrafuse process, can you collect the log files manually and post them?
    [localappdata]/Centrafuse/error.log
    [localappdata]/Centrafuse/centrafuse.log
    [localappdata]/Centrafuse/bluetooth/bluetooth.log
    [localappdata]/Centrafuse/system/config.xml
    [localappdata]/Centrafuse/system/settings.xml

    Quote Originally Posted by johnk View Post
    And a question: What does the headset-like icon at the top-right of the window stand for? When my cell phone is not connected, the icon flashes on/off at irregular intervals.
    It means its trying to connect to the phone, the "Auto Connect" feature in settings...

  5. #5
    Maximum Bitrate
    Join Date
    Apr 2007
    Location
    USA
    Posts
    496
    Quote Originally Posted by smeesseman View Post
    Added to bug database BUG-000186
    I found out what causes the volume breakage:

    If I have the Radio set to use the onboard (Realtek) soundcard, then as soon as I go to the Radio module I lose all control over the volume until CF is restarted (or until I set the Radio to use my USB soundcard and then go back to Radio).

    Even the Mixer controls in CF stop working. I guess that they are instead acting on the Realtek audio.

    For now since Radio isn't working anyway, I just configured Radio to use my USB soundcard so that I don't kill my volume controls by accidentally going to the Radio module.


    Added to bug database BUG-000187
    So far I have NOT seen this problem again with the reception/battery icons getting stuck after the phone is disconnected.


    Added to bug database BUG-000188
    FYI, I'm almost always getting the Cannot Make Call message, even when trying to make a call from the Contact list (though I did *once* today get to make a call from the Contact list). Maybe this is the Bluesoleil grace period expiring? I'm really interested in trying out the Bluetooth functionality.


    Added to bug databse, BUG-000191
    After a lockup, when you kill Centrafuse process, can you collect the log files manually and post them?
    [localappdata]/Centrafuse/error.log
    [localappdata]/Centrafuse/centrafuse.log
    [localappdata]/Centrafuse/bluetooth/bluetooth.log
    [localappdata]/Centrafuse/system/config.xml
    [localappdata]/Centrafuse/system/settings.xml
    Yup, I will get them next time. I did have another one earlier today, and I had to reboot again to make CF useable.



    One other thing I saw today was that somehow my WAVE output got muted. I don't see any control for that in CF, so I'm not sure what happened (I don't think I did it in the Windows volume control, but maybe I did). So just FYI for now.

    I assume you guys prefer that bugs get posted in the official CF Bug Reports sub-forum, so I'll use that for the next bug I find.


    Overall, I'd like to compliment you guys on CF. While I definitely need the radio working for me to purchase it, it is a good program and I'll hopefully be replacing SD with it (just the ability to see the time remaining for a track, which the SD guys refused to do, is a big deal for me).

  6. #6
    Constant Bitrate
    Join Date
    Oct 2004
    Posts
    121
    i am gettin one bug with the phone when i get or make a call and the music stops to start using the phone. it works ok but once i come back out all music will go to eaither the right channel only or the left channel only. and wont go to full stereo again until i go to the mixer and move the balance level to get it to work correctly again.

  7. #7
    Maximum Bitrate
    Join Date
    Apr 2007
    Location
    USA
    Posts
    496
    Added to bug databse, BUG-000191
    After a lockup, when you kill Centrafuse process, can you collect the log files manually and post them?
    [localappdata]/Centrafuse/error.log
    [localappdata]/Centrafuse/centrafuse.log
    [localappdata]/Centrafuse/bluetooth/bluetooth.log
    [localappdata]/Centrafuse/system/config.xml
    [localappdata]/Centrafuse/system/settings.xml

    I got the freeze again. When it happened, I had just resumed from standby. CF came up but the UI would not respond, though it was only using about 35% CPU. I End Tasked and relaunched it, and still froze at the main screen (just like all other past times - have to reboot to get it working). I made a copy of the (attached) log files, rebooted, and relaunched CF, at which point it worked again.

    John
    Attached Files Attached Files

  8. #8
    Newbie
    Join Date
    Oct 2007
    Posts
    15
    I've just upgraded from RC1 to RC3 and trial licence expiry date has not changed so I only have 4 of 30 days remaining. It's a bit hard to test the updates in such a short period of time.

    In the past every time I have done an update it has reset the 30 day licence. Is there a reason why that is no longer happening?

  9. #9
    VENDOR - Centrafuse smeesseman's Avatar
    Join Date
    Mar 2007
    Location
    Detroit, MI
    Posts
    392
    Quote Originally Posted by nadforever View Post
    i am gettin one bug with the phone when i get or make a call and the music stops to start using the phone. it works ok but once i come back out all music will go to eaither the right channel only or the left channel only. and wont go to full stereo again until i go to the mixer and move the balance level to get it to work correctly again.
    When you go into the mixer, is the balance slider still in the middle and you just have to toggle it a bit? Or is the balance slider representative of the speakers being off balance?

  10. #10
    Constant Bitrate
    Join Date
    Oct 2004
    Posts
    121
    the slide is still in the middle and i jstu have to mov it a litle for it to go back to normal.

Page 1 of 5 12345 LastLast

Similar Threads

  1. V1 Virtual Display v0.9 bugs / suggestions / ideas
    By zPilott in forum Software & Software Development
    Replies: 88
    Last Post: 04-12-2009, 10:41 AM
  2. Centrafuse 2.0 RC1
    By veetid in forum Centrafuse
    Replies: 0
    Last Post: 04-21-2008, 10:08 PM
  3. EU version, some bugs, some suggestions :)
    By Artificial in forum StreetDeck
    Replies: 3
    Last Post: 05-25-2007, 07:41 AM
  4. Replies: 5
    Last Post: 05-21-2007, 10:53 AM
  5. RC 3.1 findings / suggestions
    By holybob in forum Centrafuse
    Replies: 10
    Last Post: 09-27-2006, 12:06 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •