Page 1 of 6 123456 LastLast
Results 1 to 10 of 54

Thread: Current Visualizations in 1.6

  1. #1
    VENDOR - Centrafuse veetid's Avatar
    Join Date
    Apr 2004
    Posts
    5,040

    Current Visualizations in 1.6

    The current new visuals in 1.6 use sonique visuals. I wanted to use an existing format that woudl give users the ability to add new visuals. The visuals run fine on just about any machine with a video card that doesn't use shared memory and lack of a GPU.

    I plan to search for potentially some different sonique visuals that use less CPU and optimize my code to always respond to the close, but has anyone used sonique visuals on machines like M10000 before? Do the run within the sonique app just as slow as they do in Centrafuse?

    1.5 used visuals that I wrote myself, very basic eq/meter based graphs... I know visuals are mainly eye candy, and mainly for showing off and rear screens, but I still wanted to try and implement a standard visual format and not create a new one.

    Do winamp visuals run better on M10000 machines with onboard video cards or is that going to cause the same problems? I ask because of the so many potential setups, user feedback would help. If sonique visuals are too CPU intensive, then I will try winamp visual support, but if they already perform as bad on an M10000 then I will take a different path.

    Do most users consider visuals very important? Were the basic visuals in 1.5 unacceptable? I could potentially make the visuals I wrote in 1.5 load like the current visualizations and create an SDK for creating new visualizations, but again this is moving away from standards that already exist, but not necessarily a bad thing.

    I will have to disable full screen visuals on the main screen when the car is in motion once I go commercial to comply with most state laws. In my testing most all visuals run poor on M10000 machines, but again there are many other setups that you guys can give me feedback on.

    Are they working for some peoples CarPC's? I have 4 test machines, one of which is an M10000, and the M10000 is the only one they did not work on. One is even an old 600mhz Dell and they worked on that machine, but the video was not onboard, but nothing fancy, a basic 2D 16 meg card.

    I went with sonique in 1.6 because it was easier to code around than winamp, but I feel winamp will have the same problems. I cannot currently access the WMP visuals because there is little to no documentation on them. They are 3rd pary just like the EQ is in WMP and not exposed by any SDK.

    Just again looking for some feedback....

    I also want to give props to all the mp3car users that have helped me Beta test Centrafuse over the past year... It has come a long way and changed in many ways from our original project we started and in many ways thanks to everyone here, so Flux Media thanks you all for testing out Centrafuse and for all your feedback...

    We know it's impossible to please everyone, but we are doing are best to make a powerful car application that has all features fully integrated, easy to use for the non technical user, yet power enough for power users... This is a hard thing to accomplish and we are working diligently to find that happy medium....

    david
    __________________
    CENTRAFUSE http://www.centrafuse.com
    01 Jeep Cherokee Sport 4x4 Installed
    M10000/512Mb/20GB, Lilliput 7", Holux GM-210

  2. #2
    Low Bitrate dvwjettaiii's Avatar
    Join Date
    Jun 2005
    Location
    Neenah, WI
    Posts
    93
    I don't have an M10000 but I've used Sonique before and definately prefer them (visually) over any others that I've seen. I'd agree that the visuals in 1.5 we're pretty boring and would like to see sonique visuals in the latest version of Centrafuse. I'm assuming that it would be possible to download other sonique visuals and use them in centrafuse also? I'm curious to how well they work on slower machines, but I think they offer the best eye candy available.

  3. #3
    Constant Bitrate djchicago's Avatar
    Join Date
    Sep 2004
    Location
    Chicago Ill
    Posts
    141
    aaaahhh thats the problem with them. For some reason when i use the 'vis" they work but I can't get back to the Manager with out doing a Ctrl+alt+del to close the software. I running a 1g celaron with 327m ram and onboard video. Maybe that is part of the same problem. I do like the winamp "vis" and would like to have the ablilty to add more.

  4. #4
    VENDOR - Centrafuse veetid's Avatar
    Join Date
    Apr 2004
    Posts
    5,040
    Quote Originally Posted by dvwjettaiii
    I don't have an M10000 but I've used Sonique before and definately prefer them (visually) over any others that I've seen. I'd agree that the visuals in 1.5 we're pretty boring and would like to see sonique visuals in the latest version of Centrafuse. I'm assuming that it would be possible to download other sonique visuals and use them in centrafuse also? I'm curious to how well they work on slower machines, but I think they offer the best eye candy available.
    you should be able to download any sonique visual and place it in the visuals folder and have it work in 1.6 as is now... I just downloaded a few to put in this Beta that I found and thought used the least amount of CPU...

    If anyone knows of some sonique visuals that use less CPU that will work on an M10000 please send me a PM or let me know where to get it or who the author is...

    My problem is they perform very poorly, if not crash, with cheap onboard video cards, or I assume that is the case based on my testing with an M10000 and another MB I have with an onboad video card, shared memory and CPU...

    If you have any video card at all they work fine, or any MB with a real onboard video card and GPU...

    david
    __________________
    CENTRAFUSE http://www.centrafuse.com
    01 Jeep Cherokee Sport 4x4 Installed
    M10000/512Mb/20GB, Lilliput 7", Holux GM-210

  5. #5
    VENDOR - Centrafuse veetid's Avatar
    Join Date
    Apr 2004
    Posts
    5,040
    Quote Originally Posted by djchicago
    aaaahhh thats the problem with them. For some reason when i use the 'vis" they work but I can't get back to the Manager with out doing a Ctrl+alt+del to close the software. I running a 1g celaron with 327m ram and onboard video. Maybe that is part of the same problem. I do like the winamp "vis" and would like to have the ablilty to add more.
    have you tried running any winamp visuals on your current setup? Do they work without any problems and if so which ones?

    david
    __________________
    CENTRAFUSE http://www.centrafuse.com
    01 Jeep Cherokee Sport 4x4 Installed
    M10000/512Mb/20GB, Lilliput 7", Holux GM-210

  6. #6
    Constant Bitrate djchicago's Avatar
    Join Date
    Sep 2004
    Location
    Chicago Ill
    Posts
    141
    yes they work fine no problems, Media Engine uses winamp and it works fine, I have not been able to figure it out.

  7. #7
    Newbie
    Join Date
    Oct 2005
    Location
    Switzerland
    Posts
    12
    I also have the M10000 and got stuck within full screen visuals -> had to reboot. Visuals aren't important to me, in fact I find them very distracting while driving, even in the small version. But for showing off, I like them

    This version is great! My carpc is mostly used for music, because I have a factory nav on board. I tried a lot of carpc software and in my opinion, CF has the best concept for playing music. I like your work, David.


    Sachmet.

  8. #8
    Low Bitrate
    Join Date
    Jan 2005
    Location
    San Diego, CA
    Posts
    71
    Pent 2.4 Celeron... Visuals work fine, sometimes when I click to close it pauses for about 2-5 seconds before going back to the media screen.... But i will definitily deal with this because IMO visuals are a MUST =)

  9. #9
    Low Bitrate Linde's Avatar
    Join Date
    Jan 2006
    Location
    Sweden
    Posts
    88
    I will have to disable full screen visuals on the main screen when the car is in motion once I go commercial to comply with most state laws
    Don´t like that. Here in Sweden there is no sutch law, I think. And if there are, isint this the users choice if he wants it running and get a fine?

    I love visuals therefore I just must say it. On my SP13000 the visuals not work and when in fullscreen I must reboot.

    // Daniel

  10. #10
    Maximum Bitrate Frankino's Avatar
    Join Date
    Nov 2004
    Location
    Italy
    Posts
    659
    but.. it seems to me or the vis does not follow the music? by the way I liked the old freq meter...
    Peugeot 206 1.4 HDi

    Intel Mini-ITX Mainboard
    Celeron 1.2ghz
    256mb DDR-2 533
    80gig 3.5" SATA HDD
    Sb Live 5.1 w/ KXProject Drivers
    M2-ATX
    8" Lilliput TS LCD

    100% installed and working :D

Page 1 of 6 123456 LastLast

Similar Threads

  1. Amps, watts, volts and ohms
    By dagnasty in forum The FAQ Emporium
    Replies: 1
    Last Post: 12-30-2005, 11:35 AM
  2. GPS / Map Point current position
    By skippy76 in forum RR Bug Tracker
    Replies: 1
    Last Post: 10-09-2005, 11:42 PM
  3. Current through a relay between two batteries
    By RFMan in forum Power Supplies
    Replies: 14
    Last Post: 07-25-2005, 02:13 PM
  4. 0.02 amp current draw?
    By Zebelkhan in forum Power Supplies
    Replies: 5
    Last Post: 06-13-2005, 08:13 PM
  5. 4am MUSIC Console 1.6 (HDD Jukebox Software)
    By OvernightTech in forum Software & Software Development
    Replies: 2
    Last Post: 01-03-2004, 12:02 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •