Results 1 to 10 of 10

Thread: Phonecontrol gets stuck at scaning ports...

  1. #1
    Constant Bitrate
    Join Date
    Apr 2006
    Posts
    223

    Question Phonecontrol gets stuck at scaning ports...

    When running the setup.. everything works fine untill it says the "start to scan the ports" It just get stuck there. I ran phonecontrol test and tested port 4 which is my bluetooth and everything worked fine. I tried to manuallu set the port to 4. That works but when I tried to use the phone in centrafuse it says it still has to be configed.. but when i config it it just gets stuck on scaning for ports. I am using MS BT drivers. Everything is already paired. The services are already enabled. Any ideas?

  2. #2
    Constant Bitrate 2 STanGeR's Avatar
    Join Date
    Aug 2005
    Location
    Terre Haute, IN
    Posts
    158
    Same problem with me. It tells me that it can't find my port, but it sees my device. The PhonecontrolTest sees my Com 4 as well. I am using the WidComm drivers.

  3. #3
    Phone Control Moderator zorro's Avatar
    Join Date
    Mar 2004
    Location
    Munich, Germany
    Posts
    1,902
    I've put version 1.7.4 online today. This mainly shold have ironed out the bug with not copying the WM5 driver but I also changed a portion of the port search.
    You may download the patch and extract it into the PhoneControl.NET folder within the CF folder.
    Skinning to go... VisualDesigner2!

  4. #4
    Constant Bitrate
    Join Date
    Jun 2006
    Posts
    116
    Hi zorro,

    I'm facing a similar problem.
    Everything was working properly on CF1.6

    Now, everytime that include the phonecontrol feature, my computer freezes and hardly responds. I uninstalled RC3 and reinstalled CF1.6 to see if it gets back to normal, but faced a license problem.

    I then went to Phonecontrol folder and ran PhonecontrolTest using the same old "port", it worked properly and here is what i got.

    Code:
    [~~~~~~~~~~~~~~~~~~~~~~START~~~~~~~~~~~~~~~~~~~~~~~~~]
    ATE0
    ATE0
    
    OK
     ------------------------------------------------------------------ 
    ATI0
    
    Sony Ericsson K750
    
    OK
    ATI1
    
    CXC125952
    
    OK
    ATI2
    
    OK
    ATI3
    
    Sony Ericsson 750 Bluetooth Modem
    
    OK
    ATI4
    
    OK
    ATI5
    
    Configuration Settings on Channel 0
    &C: 1
    &D: 0
    *EIAC: 1,1,"MMS"
    *EIAC: 1,2,"Idm"
    *ELIN: 1
    +CBST: 0,0,1
    +CDIP: 0,0
    +CGACT: 1, 0
    +CGATT: 1
    CGCLASS: "B"
    +CGDCONT: 1,"IP","mms.m.com.","0.0.0.0",0,0
    +CGEQMIN: 1,3,0,0,0,0,0,0,"0E0","0E0",2,0,0
    +CGEQREQ: 1,4,0,0,0,0,2,0,"1E4","1E5",0,0,0
    +CGEREP: 0,0
    +CGQMIN: 1,0,0,0,0,0
    +CGQREQ: 1,0,0,3,0,0
    +CGREG: 0,1
    +CHSN: 0,1,0,12
    +CHSR: 0
    +CHSU: 0
    +CMEE: 0
    +CMUX: 0,0,1,31,10,3,30,10,2
    +CR: 0
    +CRC: 0
    +CRLP: 61,61,48,6,0
    +CRLP: 120,120,48,6,2,3
    +CSCS: "GSM"
    +CV120: 1,1,1,0,0,0
    +CVHU: 2
    +DR: 0
    +DS: 3,0,1024,32
    +ICF: 3,3
    +IFC: 2,2
    +ILRR: 0
    +IPR: 0
    E: 0
    M: 0
    Q: 0
    S0: 000
    S10: 002
    S2: 043
    S3: 013
    S4: 010
    S5: 008
    S6: 002
    S7: 050
    S8: 002
    V: 1
    X: 4
    
    OK
    ATI6
    
    OK
    ATI7
    
     Modem Configuration Profile
    
    Product Type       Terminal Adapter
    Interfaces         Bluetooth, IrDA, RS-232, USB
    Options            OBEX, PPP, RLP, V42bis
    
    OK
     ------------------------------------------------------------------ 
    AT+GMM
    
    Sony Ericsson K750
    
    OK
     ------------------------------------------------------------------ 
    AT+GMR
    
    R1BC002
    
    OK
     ------------------------------------------------------------------ 
    AT+CHUP=?
    
    OK
     ------------------------------------------------------------------ 
    AT+CSCS=?
    
    +CSCS: ("GSM","IRA","8859-1","UTF-8","UCS2")
    
    OK
    AT+CSCS?
    
    +CSCS: "GSM"
    
    OK
     ------------------------------------------------------------------ 
    AT+CRC=?
    
    +CRC: (0-1)
    
    OK
    AT+CRC?
    
    +CRC: 0
    
    OK
     ------------------------------------------------------------------ 
    AT+CLIP=?
    
    +CLIP: (0-1)
    
    OK
    AT+CLIP?
    
    +CLIP: 0,1
    
    OK
     ------------------------------------------------------------------ 
    AT+CNMI=?
    
    +CNMI: (2),(0,1,3),(0,2),(0,1),(0)
    
    OK
    AT+CNMI?
    
    +CNMI: 2,0,0,0,0
    
    OK
     ------------------------------------------------------------------ 
    AT+CMER=?
    
    +CMER: (0,3),(0,2),0,(0-1),0
    
    OK
    AT+CMER?
    
    +CMER: 0,0,0,0,0
    
    OK
    AT+CMER=3,2
    
    OK
     ------------------------------------------------------------------ 
    AT+CGMI=?
    
    OK
    AT+CGMI
    
    Sony Ericsson
    
    OK
     ------------------------------------------------------------------ 
    AT+CGMM=?
    
    OK
    AT+CGMM
    
    AAB-1022011-BV
    
    OK
     ------------------------------------------------------------------ 
    AT+CBC=?
    
    +CBC: (0-2),(0-100)
    
    OK
    AT+CBC
    
    +CBC: 0, 80
    
    OK
     ------------------------------------------------------------------ 
    AT+CSQ=?
    
    +CSQ: (0-31,99),(0-7,99)
    
    OK
    AT+CSQ
    
    +CSQ: 8,99
    
    OK
     ------------------------------------------------------------------ 
    AT+CPBS=?
    
    +CPBS: ("ME","SM","DC","LD","FD","MC","MV","RC","HP","BC")
    
    OK
    AT+CPBS?
    
    +CPBS: "ME"
    
    OK
    AT+CPBS="SM"
    
    OK
    AT+CPBS="ME"
    
    OK
    AT+CPBS="MC"
    
    OK
    AT+CPBS="RC"
    
    OK
    AT+CPBS="DC"
    
    OK
    AT+CPBS="MT"
    
    ERROR
    AT+CPBS="EN"
    
    ERROR
    AT+CPBS="ON"
    
    ERROR
    AT+CPBS="AD"
    
    ERROR
     ------------------------------------------------------------------ 
    AT+CPBR=?
    
    +CPBR: (1-30),80,180
    
    OK
    AT+CPBR=1,1
    
    +CPBR: 1,"03704205",129,"","2006/09/21,17:43"
    
    OK
     ------------------------------------------------------------------ 
    AT+CKPD=?
    
    OK
    AT+CKPD?
    
    ERROR
     ------------------------------------------------------------------ 
    AT+CLCC=?
    
    OK
    AT+CLCC?
    
    ERROR
     ------------------------------------------------------------------ 
    AT+CPAS=?
    
    +CPAS: (0,3,4)
    
    OK
    AT+CPAS
    
    +CPAS: 0
    
    OK
     ------------------------------------------------------------------ 
    AT+CPMS=?
    
    +CPMS: ("ME","SM"),("ME","SM"),("ME","SM")
    
    OK
    AT+CPMS?
    
    +CPMS: "SM",10,10,"SM",10,10,"ME",183,187
    
    OK
     ------------------------------------------------------------------ 
    AT+CMGR=?
    
    OK
     ------------------------------------------------------------------ 
    AT+CMGL=?
    
    +CMGL: (0-4)
    
    OK
     ------------------------------------------------------------------ 
    AT+CMGF=?
    
    +CMGF: (0)
    
    OK
    AT+CMGF?
    
    +CMGF: 0
    
    OK
     ------------------------------------------------------------------ 
    AT+CPIN=?
    
    +CPIN: (READY,SIM PIN,SIM PUK,SIM PIN2,SIM PUK2,PH-SIM PIN,PH-NET PIN,PH-NETSUB PIN,PH-SP PIN,PH-CORP PIN,PH-ESL PIN,PH-SIMLOCK PIN,BLOCKED)
    
    OK
    AT+CPIN?
    
    +CPIN: READY
    
    OK
     ------------------------------------------------------------------ 
    AT+CUSD=?
    
    +CUSD: (0-2)
    
    OK
    AT+CUSD?
    
    +CUSD: 0
    
    OK
     ------------------------------------------------------------------ 
    AT+CLCK=?
    
    +CLCK: ("CS","PS","SC","P2","AO","OI","OX","AI","IR","AB","AG","AC","FD","PN","PU","PP","PC")
    
    OK
    AT+CLCK?
    
    ERROR
     ------------------------------------------------------------------ 
    AT+CIND=?
    
    +CIND: ("battchg",(0-5)),("signal",(0-5)),("batterywarning",(0-1)),("chargerconnected",(0-1)),("service",(0-1)),("sounder",(0-1)),("message",(0-1)),("call",(0-1)),("roam",(0-1)),("callsetup",(0-3))
    
    OK
    AT+CIND?
    
    +CIND: 4,3,0,0,1,0,0,0,0,0
    
    OK
     ------------------------------------------------------------------ 
    AT+COPS=?
    
    *** Timeout ***
    AT+COPS?
    
    OK
     ------------------------------------------------------------------ 
    
    [~~~~~~~~~~~~~~~~~~~~~~~END~~~~~~~~~~~~~~~~~~~~~~~~~~]
    When I run the same test on RC1 and RC3, the response is always "Timeout", the computer freezes and I can only turn it off with a hard shutdown.
    I'm using a Edimax Class 1 adapter V2.0 with Toshiba drivers with a SE k750i


    Thank you

  5. #5
    Phone Control Moderator zorro's Avatar
    Join Date
    Mar 2004
    Location
    Munich, Germany
    Posts
    1,902
    Quote Originally Posted by SUVputer View Post
    Hi zorro,

    I'm facing a similar problem.
    Everything was working properly on CF1.6

    Now, everytime that include the phonecontrol feature, my computer freezes and hardly responds. I uninstalled RC3 and reinstalled CF1.6 to see if it gets back to normal, but faced a license problem.

    I then went to Phonecontrol folder and ran PhonecontrolTest using the same old "port", it worked properly and here is what i got.


    When I run the same test on RC1 and RC3, the response is always "Timeout", the computer freezes and I can only turn it off with a hard shutdown.
    I'm using a Edimax Class 1 adapter V2.0 with Toshiba drivers with a SE k750i


    Thank you
    Well, in some way it makes sense: 1.6 has used another communication control but that one was the reason for many problems. Since 1.7 I've replaced it there were no such problems at all.
    I've heard once that the Toshiba drivers can cause such behaviour but I'm not sure this is for real.
    Do you have the option of testing it on another computer/BT stack?
    Skinning to go... VisualDesigner2!

  6. #6
    Constant Bitrate
    Join Date
    Apr 2006
    Posts
    223
    yea.. 1.6 is the only version that has ever worked for me for CF also..

  7. #7
    Constant Bitrate
    Join Date
    Jun 2006
    Posts
    116
    Quote Originally Posted by zorro View Post
    Well, in some way it makes sense: 1.6 has used another communication control but that one was the reason for many problems. Since 1.7 I've replaced it there were no such problems at all.
    I've heard once that the Toshiba drivers can cause such behaviour but I'm not sure this is for real.
    Do you have the option of testing it on another computer/BT stack?
    I will check that and let you know..

  8. #8
    Constant Bitrate
    Join Date
    Aug 2005
    Location
    Plano/College Station, TX
    Posts
    183
    I had this problem that it wouldn't scan the proper port through phone control. This happened when I already had a bluetooth connection open with my phone. If I disconnected whatever connection was open then phonecontrol could find my phone and the proper com port just fine.

  9. #9
    Constant Bitrate
    Join Date
    Apr 2006
    Posts
    223
    nope new patch dosent work

  10. #10
    Phone Control Moderator zorro's Avatar
    Join Date
    Mar 2004
    Location
    Munich, Germany
    Posts
    1,902
    Ok, you have two options to get a workaround:

    1. Skip the BT scan and pick any one of the COM ports listed in the next page. Then, after the Wizard has finished use the Extended Configurator to correct the port number.
    2. If you applied the changes with the Extended Configurator already, create a new file named "wizard" (w/o extension, file size doesn't matter) within the PhoneControl.NET folder.
    Skinning to go... VisualDesigner2!

Similar Threads

  1. Mini-ITX boards
    By RedGTiVR6 in forum General Hardware Discussion
    Replies: 126
    Last Post: 04-22-2012, 07:03 PM
  2. Phonecontrol and Motorola v3
    By kyrenia in forum PhoneControl
    Replies: 22
    Last Post: 06-07-2007, 10:49 AM
  3. unhidding PhoneControl from FrodoPlayer
    By larios in forum FrodoPlayer
    Replies: 2
    Last Post: 03-17-2007, 08:52 AM
  4. Usb ports on Morex Case problem
    By volum3rider in forum General Hardware Discussion
    Replies: 5
    Last Post: 11-14-2005, 07:25 PM
  5. PhoneControl embedded in Mediacar?
    By _wd in forum MediaCar
    Replies: 1
    Last Post: 11-18-2004, 05:57 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •