Page 1 of 5 12345 LastLast
Results 1 to 10 of 43

Thread: Is XM Working?

  1. #1
    VENDOR - Centrafuse veetid's Avatar
    Join Date
    Apr 2004
    Posts
    5,040

    Is XM Working?

    One of my main focuses since we came to an agreement with XM was all the XM code being fixed in RC5.

    Can anyone give some feedback as to how it's working?

    I completly rewrote most of the sections of XM and it should be working good...

    Please some users let me know how it's working for them. I tested with both the XMDirect and XMPCR and tested both with hibernation...

    Just wanted some feedback if it was working for users...

    david
    __________________
    CENTRAFUSE http://www.centrafuse.com
    01 Jeep Cherokee Sport 4x4 Installed
    M10000/512Mb/20GB, Lilliput 7", Holux GM-210

  2. #2
    VENDOR - Centrafuse veetid's Avatar
    Join Date
    Apr 2004
    Posts
    5,040
    All the requests for working XM and no feedback after the last release?

    david
    __________________
    CENTRAFUSE http://www.centrafuse.com
    01 Jeep Cherokee Sport 4x4 Installed
    M10000/512Mb/20GB, Lilliput 7", Holux GM-210

  3. #3
    Maximum Bitrate
    Join Date
    May 2006
    Location
    Seattleish, WA
    Posts
    823
    Quote Originally Posted by veetid View Post
    All the requests for working XM and no feedback after the last release?
    Maybe I was the only one complaining?

    My truck's still down.... I can't really get access to it, and my XM gear is mounted under the driver's seat.
    :: Mark

  4. #4
    Newbie bowtie4532's Avatar
    Join Date
    Sep 2005
    Location
    Little Rock, AR
    Posts
    12
    David mine seems to working better than ever. It still has a few problems. When it comes out of hibernation like the 3rd or 4th time. I just have to close centrafuse and open it back up and it works perfect again. I don't remember any other problems with it.
    97 Firebird 7" Lilliput Touch Screen
    AMD Athlon 3800+ DSATX
    Centrafuse RC5
    PPC 6700 Sprint Phone w/Bluetooth
    Bluetooth GPS

  5. #5
    Variable Bitrate Redian's Avatar
    Join Date
    Apr 2006
    Location
    Connecticut, USA
    Posts
    399
    ditto what bowtie said
    2004 Impreza WRX CarPC Install

    I am willing to host any legal downloads that may benefit the CarPC community - PM for info

    "When you go 0-60 in 4.5 seconds, you don't need a made up character called fast. Thats what makes a Subaru, a Subaru."

    DG4L

  6. #6
    VENDOR - Centrafuse veetid's Avatar
    Join Date
    Apr 2004
    Posts
    5,040
    So you can reproduce the problem coming out of hibernation every time? When you come out of hibernation does the loading screen just stay up?

    What happens after that if you try to change channels, nothing? Does it create an error.log file, if so please post it...

    david
    __________________
    CENTRAFUSE http://www.centrafuse.com
    01 Jeep Cherokee Sport 4x4 Installed
    M10000/512Mb/20GB, Lilliput 7", Holux GM-210

  7. #7
    Maximum Bitrate
    Join Date
    May 2006
    Location
    Seattleish, WA
    Posts
    823
    I FINALLY have my truck back and am back online with CF. Lotso drama the last couple of weeks. The short form is a wiring harness issue in the truck caused my M10000 to fry, so a new board, then Windows didn't like the original key with the new board, so new copy of XP, then it wouldn't "upgrade", so a complete re-install... argh.

    Anyway.. I have some prelim XM comments. I only have about 30 minutes usage, so figure on more coming.

    Good stuff:
    • First off, David, you did an INCREDIBLE amount of work. XM is running well enough that I can remove AIMEE from the system. THANK YOU very much.

    • The channel switching is MUCH faster, I see changes happening in about 3 seconds. I still don't understand why you have to prime the buffer before it starts playing, but it's fast enough that I'll stop complaining.



    Other stuff:
    1. The list item display is still screwy. I will often see things like "41 ROCK - The 60's - Wolfman Jack" or "82 DANCE -Boneyard - Black Label Society". It seems to happen most often right after a channel change. It will fix itself as CF refreshs the list...

    2. There are still channel change issues. In single click mode, I get about a 50% hit rate of a click actually invoking a channel change. I get a 100% hit rate on the top line _showing_ the change, but the channel doesn't actually change. e.g., I'm on 41 and going to 44. I click on 44, the top line shows the current info for 44, but the audio is still 41. This is "Live", I'm not playing from the buffer. If I click again, or if I double-tap to begin with, the hit rate increases to about 80%.

    3. Something is screwy with the "first few times" that the plugin loads. When I FIRST loaded up CF and XM, the channel list filled, I could scroll through it, I could set favorites, but none of the big buttons on the left worked, and only the first channel change worked.

      I exited CF and reloaded... CF remembered that XM was the most recent audio source, so it played it, but it reset to the preview channel. After going into the plugin, all of my favorites were gone, only the first channel change worked, and the buttons on the left did NOT work. I reset my favorites.

      I exited CF and reloaded... CF NOW remembered the last station I was on and started playing. I went into the plugin, it remembered my favorites, and the buttons on the left worked.

      I couple of more exits and reloads show that now things are "okay", though see above for the weird channel change responses and display hiccups.

    4. Recovering from hibernation is still sick. I have the symptoms that Bowtie reported above. More information below.



    That's it for now... More later.

    Again, thank you.
    :: Mark

  8. #8
    Newbie bowtie4532's Avatar
    Join Date
    Sep 2005
    Location
    Little Rock, AR
    Posts
    12
    David it isn't something that happens all the time. There really isn't a pattern to when it hangs. I haven't checked the error logs. What it does on mine is it just garbled text on the screen, nothing is readable, it is squares and symbols, and I get no sound.
    97 Firebird 7" Lilliput Touch Screen
    AMD Athlon 3800+ DSATX
    Centrafuse RC5
    PPC 6700 Sprint Phone w/Bluetooth
    Bluetooth GPS

  9. #9
    Maximum Bitrate
    Join Date
    May 2006
    Location
    Seattleish, WA
    Posts
    823
    I have more info...

    I just got back from being out and about. I made a total of 8 stops, so 8 chances for the hibernate cycle. The music source was always XM.

    CF came back clean (i.e., XM comes back playing and the screen is "live") just once. All the other times things were not healthy.

    The first sign of trouble is that there's no audio playing. If you click to change a station, that would bring audio back, but after that one click, CF goes unresponsive. If you leave it alone, then after about 1 1/2 minutes, you'll get a modal dialog box that says:
    Setup Error
    Failed to load resources from resource file. Please check your setup.
    Of course, there was NO setup running. There's an OK box in the dialog, clicking on it closes the box and CF terminates hard.


    The error log from today is below, but there's nothing in it about XM. Just the Font errors (which you may remember from a while ago, and this is a VERY fresh install of XP SP2). Note that I've trimmed the log to show just one instance of the font errors. They come in a batch of 5 or 6.
    Code:
    ----------------------------------------------------------------------------------------------------------
    2/24/2007 10:53:04 AM
    The underlying connection was closed: The remote name could not be resolved.
       at System.Net.HttpWebRequest.CheckFinalStatus()
       at System.Net.HttpWebRequest.EndGetRequestStream(IAsyncResult asyncResult)
       at System.Net.HttpWebRequest.GetRequestStream()
       at centrafuse.CFUpdateLib.issueUpdateRequest(String updateurl, String requesttext)
    ----------------------------------------------------------------------------------------------------------
    2/24/2007 10:53:09 AM
    Font 'Century Gothic' doesn't support style 'Regular'.
       at System.Drawing.Font.Initialize(FontFamily family, Single emSize, FontStyle style, GraphicsUnit unit, Byte gdiCharSet, Boolean gdiVerticalFont)
       at System.Drawing.Font..ctor(String familyName, Single emSize, FontStyle style, GraphicsUnit unit, Byte gdiCharSet)
       at centrafuse.Plugins.CFPlugin.setlabelskin(String whichlbl, MouseEventHandler clickEvent, MouseEventHandler downEvent)
    ----------------------------------------------------------------------------------------------------------
    2/24/2007 11:21:28 AM
    Font 'Century Gothic' doesn't support style 'Regular'.
       at System.Drawing.Font.Initialize(FontFamily family, Single emSize, FontStyle style, GraphicsUnit unit, Byte gdiCharSet, Boolean gdiVerticalFont)
       at System.Drawing.Font..ctor(String familyName, Single emSize, FontStyle style, GraphicsUnit unit, Byte gdiCharSet)
       at centrafuse.Plugins.CFPlugin.setlabelskin(String whichlbl, MouseEventHandler clickEvent, MouseEventHandler downEvent)
    ----------------------------------------------------------------------------------------------------------
    2/24/2007 12:30:56 PM
    Font 'Century Gothic' doesn't support style 'Regular'.
       at System.Drawing.Font.Initialize(FontFamily family, Single emSize, FontStyle style, GraphicsUnit unit, Byte gdiCharSet, Boolean gdiVerticalFont)
       at System.Drawing.Font..ctor(String familyName, Single emSize, FontStyle style, GraphicsUnit unit, Byte gdiCharSet)
       at centrafuse.Plugins.CFPlugin.setlabelskin(String whichlbl, MouseEventHandler clickEvent, MouseEventHandler downEvent)
    ----------------------------------------------------------------------------------------------------------
    2/24/2007 1:26:09 PM
    Font 'Century Gothic' doesn't support style 'Regular'.
       at System.Drawing.Font.Initialize(FontFamily family, Single emSize, FontStyle style, GraphicsUnit unit, Byte gdiCharSet, Boolean gdiVerticalFont)
       at System.Drawing.Font..ctor(String familyName, Single emSize, FontStyle style, GraphicsUnit unit, Byte gdiCharSet)
       at centrafuse.Plugins.CFPlugin.setlabelskin(String whichlbl, MouseEventHandler clickEvent, MouseEventHandler downEvent)
    ----------------------------------------------------------------------------------------------------------
    :: Mark

  10. #10
    Maximum Bitrate
    Join Date
    May 2006
    Location
    Seattleish, WA
    Posts
    823
    More driving, more time to watch this behavior.

    I THINK I can reliably stop the dialog box and the resulting crash from happening if...

    As soon as CF comes back from hibernation (it ends up in the XM screen), I hit a button. (I've been using the BACK button, because it effects an easy-to-see change) So, I hit a button, see it immediately turn BLUE, and then I wait for it to be acted on. It will usually take 3-4 MINUTES for this to happen, but once it does, it seems that CF is fine. I can go back into XM, change channels, pause, FF, RWD, etc and all is well.

    If I DON'T hit a button, then I will get the dialog box and the resulting crash.
    :: Mark

Page 1 of 5 12345 LastLast

Similar Threads

  1. XM Equipment CHEAP! XM Direct $29!!!!
    By hevnsnt in forum General Hardware Discussion
    Replies: 55
    Last Post: 04-11-2006, 10:18 PM
  2. working with xm direct and macxm
    By lovedamacmini in forum MacCar
    Replies: 9
    Last Post: 11-02-2005, 03:29 PM
  3. Pre-Release Thread: Frodo XM Service
    By frodobaggins in forum Software & Software Development
    Replies: 10
    Last Post: 08-04-2005, 05:10 PM
  4. XM Direct digital adapter or XM PC cable with SkyFi2???
    By LATEOTT in forum Hardware Development
    Replies: 0
    Last Post: 01-19-2005, 03:18 PM
  5. Direct Xm working as a XMPCR!!
    By KMorphosis in forum General Hardware Discussion
    Replies: 45
    Last Post: 10-07-2004, 11:37 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •