Results 1 to 4 of 4

Thread: Port splitting for navigation

  1. #1
    Maximum Bitrate
    Join Date
    Jul 2006
    Posts
    725

    Port splitting for navigation

    I am using xport to split my incoming GPS (from port 2) into ports 11 and 12. I can use port 11 or 12 for iguidance, which works perfectly fine, but neither port seems to work with destinator (including the original port 2). Obviously, I select 12 in destinator if I choose 11 in iguidance, and vice versa. Destinator just shows zero satellites. Any ideas?

  2. #2
    Maximum Bitrate
    Join Date
    Jul 2006
    Posts
    725
    Seems like hte port number has to be <10. Problem solved. But this is still a strange issue. Is this a bug in CF or destinator? I'm guessing the latter.

  3. #3
    Maximum Bitrate
    Join Date
    May 2006
    Location
    Seattleish, WA
    Posts
    823
    It's come up here many times - it's a Windows issue. Windows has never been able to deal with COM ports numbered above 9.

    fwiw, I think the problem is even still in Vista.
    :: Mark

  4. #4
    VENDOR - Centrafuse veetid's Avatar
    Join Date
    Apr 2004
    Posts
    5,040
    Quote Originally Posted by midiwall View Post
    It's come up here many times - it's a Windows issue. Windows has never been able to deal with COM ports numbered above 9.

    fwiw, I think the problem is even still in Vista.
    this has been fixed in the upcoming release... The navigation will work with COM ports up to 64...

    it's a matter of how you call CreateFile that most companies/software do not do, or forget...

    it's something along the lines of most users put

    CreateFile("\.\COM1", ...)

    When to make it work for all COM ports you put

    CreateFile("\\\\.\\COM1", ...)

    I had Destinator make the update and I tested it, it appears to be working just fine...

    Seems like companies would know these things by now...

    david
    __________________
    CENTRAFUSE http://www.centrafuse.com
    01 Jeep Cherokee Sport 4x4 Installed
    M10000/512Mb/20GB, Lilliput 7", Holux GM-210

Similar Threads

  1. USB port power dies?!
    By pixelflash in forum General Hardware Discussion
    Replies: 1
    Last Post: 10-22-2007, 09:26 AM
  2. Com port splitting..
    By Kamakazie2 in forum Road Runner
    Replies: 1
    Last Post: 10-17-2006, 03:47 PM
  3. SDK commands over the serial port ????
    By tolisn in forum Road Runner
    Replies: 4
    Last Post: 12-14-2005, 12:03 PM
  4. Replies: 4
    Last Post: 07-04-2005, 04:38 AM
  5. Via Mini-ITX Epia 5000 serial port not working
    By vash in forum General Hardware Discussion
    Replies: 2
    Last Post: 08-13-2002, 08:48 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •