Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: Genre metadata for some MP3s not importing correctly

  1. #1
    Low Bitrate
    Join Date
    Feb 2007
    Posts
    63

    Genre metadata for some MP3s not importing correctly

    I have some MP3s that are being found as genre "ClassicRock" when they should be "Classic Rock". This is happening for several genres. I have duplicate genres (i.e. "Classic Rock" and "ClassicRock")

    Windows explorer and Windows Media Player both see the metadata as "Classic Rock" (with a space) which is what it should be.

    This is not happening for WMAs. Only MP3. This is only happening with genre data.

    I can provide examples if needed.

    thanks,
    dan

  2. #2
    VENDOR - Centrafuse veetid's Avatar
    Join Date
    Apr 2004
    Posts
    5,040
    There have been some Genre reading updates, but not really related to this...

    Sure none of the files have ClassicRock as the Genre without a space? If you go into it, it will tell you which files and then open them in something like the program GodFather and see what the exact Genre was...

    I had this issue and had to fix a few of my files, using the GodFather which is a great tag editing software...

    david
    __________________
    CENTRAFUSE http://www.centrafuse.com
    01 Jeep Cherokee Sport 4x4 Installed
    M10000/512Mb/20GB, Lilliput 7", Holux GM-210

  3. #3
    Low Bitrate
    Join Date
    Feb 2007
    Posts
    63
    I'm very sure my Metadata is correct. I'm a metadata freak. I've spent the last 5 years of my life building a script that goes through all my music and normalizes the metadata based on folder structure.

    I see the correct genre listed in windows explorer (file properties) as well as Windows Media Player and most other apps.

  4. #4
    VENDOR - Centrafuse veetid's Avatar
    Join Date
    Apr 2004
    Posts
    5,040
    That's weird it would take a space out of the middle like you describe... just with Genre?

    I do no extra parsing of the string from the tag I get back, they should all be the same...

    this happening for anyone else?

    david
    __________________
    CENTRAFUSE http://www.centrafuse.com
    01 Jeep Cherokee Sport 4x4 Installed
    M10000/512Mb/20GB, Lilliput 7", Holux GM-210

  5. #5
    Maximum Bitrate Frankino's Avatar
    Join Date
    Nov 2004
    Location
    Italy
    Posts
    659
    yea I read somewhere else that problem.. can't find the thread
    Peugeot 206 1.4 HDi

    Intel Mini-ITX Mainboard
    Celeron 1.2ghz
    256mb DDR-2 533
    80gig 3.5" SATA HDD
    Sb Live 5.1 w/ KXProject Drivers
    M2-ATX
    8" Lilliput TS LCD

    100% installed and working :D

  6. #6
    Low Bitrate
    Join Date
    Feb 2007
    Posts
    63
    I wish I could be more help but I can't find the genre tag in the MP3 that is showing up incorrectly in centrafuse.

    I opened it up in textpad and I can see album, artist, title and all other metadata but genre is nowhere to be found (at least in clear text) maybe it's encoded but I dont know why everything else is visible in the header but not genre.

    I'll keep digging around. Let me know if you want some sample files to repro and I'll put them on my FTP server.

  7. #7
    Low Bitrate
    Join Date
    Feb 2007
    Posts
    63
    also - just confirmed with Godfather that the genre is showing up correctly. No spaces. Cool software BTW.

  8. #8
    Variable Bitrate mercury7's Avatar
    Join Date
    Jul 2005
    Location
    Dallas
    Posts
    412
    It happened to me, but that was when I was using old tag headers. I edited my entire collection to use ID3v2.3 tags using the program, Mp3tag. Now all is well.

    It could be that Centrafuse can't read the legacy headers.
    2002 Grand Am progress :
    [] - 80%
    ...complete setup, but still need to make the install cleaner

  9. #9
    Variable Bitrate m2x0p9x's Avatar
    Join Date
    May 2002
    Location
    Modesto, CA
    Posts
    332
    I know this isnt the same topic but is there a way to just remove the Genre item from the list....Genre is the only tag is screwed up on my mp3s and i never use Genre...instead of retagging all my mp3s i would rather just remove the Genre entry from the media library list...

  10. #10
    Low Bitrate
    Join Date
    Feb 2007
    Posts
    63
    Any update on this? It seems like its a bug and it's not reasonable to expect all users to go through their music collection and update their ID3 tags to ID3v.2.3

    thanks,
    dan

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •