Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: Out of Memory Error

  1. #1
    FLAC
    Join Date
    Jun 2002
    Location
    Virginia
    Posts
    1,788

    Out of Memory Error

    I have loaded a playlist of about 14,000 songs and six hundred album covers. The album covers only total about 3 meg. When I scroll through the album covers I get the attached error (Out of Memory) after about the second click of the down arrow. I have 512k of RAM. Am I really out of memory or is this a bug?
    Attached Images Attached Images  

  2. #2
    VENDOR - Centrafuse veetid's Avatar
    Join Date
    Apr 2004
    Posts
    5,040
    Quote Originally Posted by kbreeden
    I have loaded a playlist of about 14,000 songs and six hundred album covers. The album covers only total about 3 meg. When I scroll through the album covers I get the attached error (Out of Memory) after about the second click of the down arrow. I have 512k of RAM. Am I really out of memory or is this a bug?
    that would most likely be a bug somewhere... When you say scroll where exactly do you mean? In the media manager or on the main media screen? If in the media manager I assume in the album view? If on the music screen then I assume it's when you scroll through the list? When you scroll on the main media page the album art doesn't change unless you play them right?

    Might just be the 14,000 song playlist... my listview might not be handling that well... the largest playlist I tested with was about 5,000 songs... which is all my music... guess I need more music to test

    david
    __________________
    CENTRAFUSE http://www.centrafuse.com
    01 Jeep Cherokee Sport 4x4 Installed
    M10000/512Mb/20GB, Lilliput 7", Holux GM-210

  3. #3
    FLAC
    Join Date
    Jun 2002
    Location
    Virginia
    Posts
    1,788
    It's in Media Manager. If I go to Media Manager, then click Albums, then hit the scroll down button, then hit the scroll down button again, I get the error message. It is always on the second click of the scroll down button in album view that I get the error message.

    I have utilized a 14k playlist in Winamp for years now and never had a problem. I can't imagine the 3 meg of additional album art pushes it over the edge.

  4. #4
    VENDOR - Centrafuse veetid's Avatar
    Join Date
    Apr 2004
    Posts
    5,040
    Quote Originally Posted by kbreeden
    It's in Media Manager. If I go to Media Manager, then click Albums, then hit the scroll down button, then hit the scroll down button again, I get the error message. It is always on the second click of the scroll down button in album view that I get the error message.

    I have utilized a 14k playlist in Winamp for years now and never had a problem. I can't imagine the 3 meg of additional album art pushes it over the edge.
    when the error occurs can you tell me how much memory centrafuse.exe is using in taskmanager?

    david
    __________________
    CENTRAFUSE http://www.centrafuse.com
    01 Jeep Cherokee Sport 4x4 Installed
    M10000/512Mb/20GB, Lilliput 7", Holux GM-210

  5. #5
    VENDOR - Centrafuse veetid's Avatar
    Join Date
    Apr 2004
    Posts
    5,040
    I added some code to collect all the free memory while paging through the covert art view in media manager... it is in 1.4... we will see if that fixes it... I have about 300 album images in my collection and I can page through them really fast and the memory doesn't even really go up at all....

    david
    __________________
    CENTRAFUSE http://www.centrafuse.com
    01 Jeep Cherokee Sport 4x4 Installed
    M10000/512Mb/20GB, Lilliput 7", Holux GM-210

  6. #6
    FLAC
    Join Date
    Jun 2002
    Location
    Virginia
    Posts
    1,788
    When I load albums - 62,432
    When I hit scroll button first time - 62,852
    When I hit scroll button second time (error message appears) - 62,016

    I have attached the details of the error message
    Attached Images Attached Images

  7. #7
    VENDOR - Centrafuse veetid's Avatar
    Join Date
    Apr 2004
    Posts
    5,040
    Quote Originally Posted by kbreeden
    When I load albums - 62,432
    When I hit scroll button first time - 62,852
    When I hit scroll button second time (error message appears) - 62,016

    I have attached the details of the error message
    can you right click your taskbar and load task manager... Then run centrafuse and generate the error... then look in task manager and tell me what Mem Usage centrafuse.exe is using...

    This will let me know if this really is an out of memory error, or some other error reading one of your images...

    note: I found out this error will get thrown if "the pixel format
    of the image specified by the filename parameter is not supported"

    So if the Mem Usage is low when the error occurs the above is the problem... That being the case if you find the image causing the problem on page two of your albums and remove it, the problem should go away... if this is the case can you send me that image so I can account for this?

    david
    __________________
    CENTRAFUSE http://www.centrafuse.com
    01 Jeep Cherokee Sport 4x4 Installed
    M10000/512Mb/20GB, Lilliput 7", Holux GM-210

  8. #8
    VENDOR - Centrafuse veetid's Avatar
    Join Date
    Apr 2004
    Posts
    5,040
    I put something in place in 1.4 that should fix this problem...

    david
    __________________
    CENTRAFUSE http://www.centrafuse.com
    01 Jeep Cherokee Sport 4x4 Installed
    M10000/512Mb/20GB, Lilliput 7", Holux GM-210

  9. #9
    Constant Bitrate superbowl's Avatar
    Join Date
    Jan 2005
    Location
    Germany
    Posts
    211
    any idea when the fixed release will be online ?
    ---
    i never drink water cos fish ***** in it. (w.c. fields)

  10. #10
    FLAC
    Join Date
    Jun 2002
    Location
    Virginia
    Posts
    1,788
    Sorry about the slow response, David.

    The numbers in my post #6 are the memory numbers. It appears that it's not a real memory error.

    I'll see if I can I can determine if there is a specific jpg causing the problem.

    Kevin

Page 1 of 2 12 LastLast

Similar Threads

  1. Replies: 7
    Last Post: 07-01-2005, 03:29 PM
  2. Error No.: -2147221187
    By cdevelasco in forum MM Bugs
    Replies: 15
    Last Post: 06-28-2005, 07:03 AM
  3. Database error when installing ME2
    By Sparhawk in forum Media Engine
    Replies: 1
    Last Post: 06-08-2004, 10:14 AM
  4. ME 2.0 Official Bug Reports
    By phat_bastard in forum ME Archive
    Replies: 67
    Last Post: 01-31-2004, 06:27 PM
  5. Error #91
    By SiGmA_X in forum ME Archive
    Replies: 18
    Last Post: 01-08-2004, 09:40 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •