Page 1 of 28 1234567891011 ... LastLast
Results 1 to 10 of 280
Like Tree1Likes

Thread: Yay New Version

  1. #1
    Mod - Driveline forum
    Auto Apps:loading...
    ClockWorK's Avatar
    Join Date
    Oct 2003
    Location
    Michigan
    Posts
    752

    Yay New Version

    Download for app and source-code is here:
    http://www.mp3car.com/driveline/1311...1-02-16-a.html

    ScreenShots are here:
    http://www.mp3car.com/driveline/1311...ce-images.html



    Most of this program has been rewritten now. What's new?

    Supports skinning now. Skin XML files control the entire interface.
    Supports multiple monitors now.
    Supports 16:9 / 4:3 compensation.
    Downloads lyrics.
    Downloads traffic and weather alerts.
    Downloads maps, and marks alerts on the map.
    Supports Pandora (through a browser interface).
    Volume Control.
    Shuffle, Repeat, Pause, Play.
    Status Icons.
    CPU Usage bar.
    Transparency.
    OSK.
    Search for files.
    WebCam control is better.
    Eject media.
    Separate browsers for audio files, video files, audio CDs, and video DVDs.
    Smarter album art display.
    Multi-threading.
    Supports Emulators.
    Better code.
    Saving of playlists.
    Text to speech can read alerts and lyrics out loud.
    Full unicode support.
    Uses .Net Framework 3.0 instead of 4.0.


    What's old but still good?

    Play media, view GPS info, GPS trail, OBD info, driving stats, image slideshows, embedded apps, visualizations, album art, import files/folders, and other basic stuff.



    All old versions are garbage. If updating, please do a complete manual re-install.


    There are probably some things I've overlooked. But after nearly 6 months, this should be a decent update.

  2. #2
    FLAC SNOtwistR's Avatar
    Join Date
    Nov 2009
    Location
    Keswick,On Canada
    Posts
    1,644
    Awesome works very good on my new viliv x70 3g 32ssd very fast loading and and running. all plugins work great so far, co-pilot works fine embedded. now i just need to add tpms. fantastik work clockwork! Keep it up SNO

  3. #3
    Mod - Driveline forum
    Auto Apps:loading...
    ClockWorK's Avatar
    Join Date
    Oct 2003
    Location
    Michigan
    Posts
    752
    That's some good feedback! Honestly, I was expecting either no response at all, or maybe a "duzint werk phail". I appreciate you checking it out. I'm still not satisfied with all of the program, but I'm at a point where it's stable and useful, and I want input from other users (though I still have no idea how many people beside myself use this program regularly).

    I've never used co-pilot, so I'm glad to hear that it embeds correctly.

    I'm hoping to get some more feedback from anyone that tries the program.

  4. #4
    Newbie DuvyDude's Avatar
    Join Date
    Sep 2009
    Location
    Hawaii
    Posts
    2
    Just wanted to pop in and say I'm enjoying playing around with Driveline. I'm still toying with it and openMobile to figure out which I like better and would work better for me.

    None of my stuff is installed yet so I'm just playing around with it on my computer.
    I do like where this is heading and you have some great ideas.
    Thanks for the hard work you're putting in to this.

  5. #5
    Mod - Driveline forum
    Auto Apps:loading...
    ClockWorK's Avatar
    Join Date
    Oct 2003
    Location
    Michigan
    Posts
    752
    Quote Originally Posted by DuvyDude View Post
    Just wanted to pop in and say I'm enjoying playing around with Driveline. I'm still toying with it and openMobile to figure out which I like better and would work better for me.

    None of my stuff is installed yet so I'm just playing around with it on my computer.
    I do like where this is heading and you have some great ideas.
    Thanks for the hard work you're putting in to this.

    Thanks for the feedback. Are you playing with the source-code, or the compiled EXE version? If you're using the EXE, you may want to change the skin (Skin_Form_Main.xml) so that the program only displays at 800x600 or 800x480 while you're playing with it on a large monitor. That way you can get a better feel for how it will look when it's in the car. By default, the width and height are set to 100%, so the program takes up then entire screen.

    Anyway, thanks for taking a look at my program! Let me know if you encounter any issues.

  6. #6
    Newbie
    Join Date
    Mar 2010
    Posts
    6
    ClockWork,

    I first would like to thank you for this frontend. It has potential. I have been using it for about 2 weeks and I really like the speed. I have run into problems though that I can't resolve. I tried to load about 65 .wav files to the playlist that I created but I can only add about 20 of them. I even tried modding the .XML playlist file and WMP playlist with no luck. I also tried to add 3 movies that were AVIs and I could only add 2 of them to the playlist. The second problem that I have run into concerns the slideshow. When I tried to add pictures I get an exception error and a debug screen pops up.

    I downloaded the source code but I am not a coder so it was not much help. Do you have any suggestions that I could try?

  7. #7
    Mod - Driveline forum
    Auto Apps:loading...
    ClockWorK's Avatar
    Join Date
    Oct 2003
    Location
    Michigan
    Posts
    752
    Thanks for the feedback! And thanks for trying out my program. As for the slideshow, make sure you have the latest version. I posted a new version on Feb 23, which fixed a bug in the slideshow which caused the program to crash if a second monitor wasn't attached. If this does not fix the problem could you PM me the debug message?

    Your other issue, I'm not sure. I haven't encountered any issues with files not showing up in the playlist. I usually have a couple hundred files in the playlist, and I add whole directories (with subdirectories) at a time without any issue. But I'm usually just playing MP3 files. I'll do some testing with .WAV and .AVI files to see if I can reproduce the problem. It sounds like the program is [perhaps] encountering an error with one of the files, and then nothing after that is getting added to the playlist. Have you encountered this problem when playing MP3 files?

    Also, I plan on making some more changes in the next week, which will be reducing memory use, increasing performance, and decreasing the load-time. These changes will effect the playlist management behind the scenes, and may help shed some light on (or even resolve) your issues as well.

    Any other info you can share will be helpful. I would like to address and resolve any issues that anyone stumbles upon.

  8. #8
    Newbie
    Join Date
    Mar 2010
    Posts
    6
    The version that I have now was downloaded on 2-16-11 so I will download the updated version tonight. I tried to add mp3 files to the playlist just now and had zero problems. I also deleted all the playlists just to try and see if I could add wav files only now I can't add any wav files to the playlist. Out of curiosity I modified the settings file to include .flac files since the majority of my music library is stored using this format. I can access the .flac files in the add media screen but I can't add those to the playlist either.

    I loaded DriveLine to my carpc this afternoon which is also running XP. It is doing the same thing as this desktop. All the files that I tried to add to the playlist in DriveLine play fine in WMP.

  9. #9
    Mod - Driveline forum
    Auto Apps:loading...
    ClockWorK's Avatar
    Join Date
    Oct 2003
    Location
    Michigan
    Posts
    752
    I think I found the problem. I wasn't able to reproduce it with a WAV or AVI, but I did reproduce the problem with a FLAC file. When the program adds an item to the playlist, it checks the 'duration' of the file, as reported by WMP. It looks like WMP doesn't always calculate the duration of the media immediately (perhaps on large files, or depending on the codec), so my program thinks the media file is 0.0 seconds long, and does not add it to the list.

    I have attached an updated EXE for you. If it resolves the problem for you, I will make it a permanent change.
    Last edited by ClockWorK; 03-16-2011 at 09:54 AM. Reason: Removed test-version of EXE

  10. #10
    Newbie
    Join Date
    Mar 2010
    Posts
    6
    You are awesome. I can add Flac, Wav, and AVI files to the playlist now with no problems. Slideshow works great too. Thanks for all your help. My search for a new frontend is complete.

Page 1 of 28 1234567891011 ... LastLast

Similar Threads

  1. New version is out!!!
    By urosbe in forum Centrafuse
    Replies: 8
    Last Post: 07-19-2006, 09:38 AM
  2. Replies: 5
    Last Post: 05-25-2004, 12:33 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •