Page 1 of 2 12 LastLast
Results 1 to 10 of 20

Thread: Noob with ELM327 needs help!

  1. #1
    Newbie
    Join Date
    Nov 2008
    Posts
    16

    Noob with ELM327 needs help!

    Hi all!!

    im new to all this and have recently bought an ELM327 off Ebay to try and connect to my car and read error codes etc.

    BUT, im having trubble getting the thing to connect to ANY car...

    Im not sure weather its driver problems or what, but i simple cant get it to connect at all, i tried differant software (DigiMoto 4.03, ScanTool and Pro scan5.1) and none no matter what i have tried will connect...

    On ProScan i managed to get it to Open Serial Port, Detect Interface, Initialize interface. BUT when it came to Initialize OBD-II it failes.

    Can anyone point me in the rite direction from driver or anything else they think may be the problem?

    Im using a Laptop running XP.

    Cheers
    Keith

  2. #2
    North of the land of Hey Huns
    Auto Apps:loading...

    Join Date
    Jun 2004
    Location
    Westminster, MD
    Posts
    2,144
    Buying a knock-off ELM from ebay is a crapshoot as to if it will work or not. Chances are you got a bad one... but try opening the interface with a serial terminal (like putty or CRT) and send it commands, see if it responds correctly. perhaps try ATZ, ATI, or 010C just to see if you get responses.
    "stop with the REINSTALLS, what do you think we got some lame-o installer!!!" - mitchjs
    RevFE
    My Shop

  3. #3
    Raw Wave
    Auto Apps:loading...
    justchat_1's Avatar
    Join Date
    Jul 2008
    Location
    Boston, Ma or NY,NY
    Posts
    2,359
    Connecting to what car?

  4. #4
    Newbie
    Join Date
    Nov 2008
    Posts
    16
    Quote Originally Posted by malcom2073 View Post
    Buying a knock-off ELM from ebay is a crapshoot as to if it will work or not. Chances are you got a bad one... but try opening the interface with a serial terminal (like putty or CRT) and send it commands, see if it responds correctly. perhaps try ATZ, ATI, or 010C just to see if you get responses.


    i have no idea what you just said... haha

    But yeah, i wasnt expecting much from it as i wasnt going to fork out crap loads for something ill probobly bearly use.

    and the cars i have tried to connect to are a Rover 25, new Honda Civic, New Landrover Disco, and a Corsa C.

  5. #5
    Raw Wave
    Auto Apps:loading...
    justchat_1's Avatar
    Join Date
    Jul 2008
    Location
    Boston, Ma or NY,NY
    Posts
    2,359
    should work fine with any of those cars...make sure the device is correctly detected as a serial port and that that serial port is correctly selected in the software you're using.

    I use a $4 ELM off ebay and it works flawlessly.

  6. #6
    Newbie
    Join Date
    Nov 2008
    Posts
    16
    Thats whats anoying me :-s

    all seems fine from what i can tell...

    I payed 20 for this thing... lol

  7. #7
    Raw Wave
    Auto Apps:loading...
    justchat_1's Avatar
    Join Date
    Jul 2008
    Location
    Boston, Ma or NY,NY
    Posts
    2,359
    Did you double check both of those things?

  8. #8
    What can I say? I like serial. Curiosity's Avatar
    Join Date
    Mar 2004
    Location
    Florence Yall, BFKY
    Posts
    2,684
    What error does it give? Like BUSY, UNABLE TO CONNECT, DATA ERROR, BUS ERROR, CAN ERROR?

  9. #9
    Newbie
    Join Date
    Nov 2008
    Posts
    16
    If i check my device manager its setup at Com3 and the software is also looking to that port so i belive it is setup right...

    And as for errors, on Digimoto i get Unable To Connect.

    And i think on Scan Tool it said Bus error...

    What would be best to do to give you a better error report?

  10. #10
    What can I say? I like serial. Curiosity's Avatar
    Join Date
    Mar 2004
    Location
    Florence Yall, BFKY
    Posts
    2,684
    The ScanTool guys have a nice simple app called STNTerm
    http://www.scantool.net/scantool/downloads/utilities/

    That can give a little more raw info.

Page 1 of 2 12 LastLast

Similar Threads

  1. elm 5 has the elm327 chip so whats different....
    By b_kennedy in forum Engine Management, OBD-II, Engine Diagnostics, etc.
    Replies: 8
    Last Post: 07-17-2009, 12:10 PM
  2. ELM327 ver 1.2a didn't connect Lancer 1999 CK1A
    By nbctcp in forum Engine Management, OBD-II, Engine Diagnostics, etc.
    Replies: 14
    Last Post: 09-24-2008, 07:21 PM
  3. noob intruducing myself
    By Shott8283 in forum Newbie
    Replies: 7
    Last Post: 12-25-2005, 09:32 AM
  4. Are there any ebay traders to watch out for?
    By jeeplaw in forum Off Topic
    Replies: 21
    Last Post: 06-15-2005, 11:10 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •