Page 1 of 2 12 LastLast
Results 1 to 10 of 17

Thread: Problems with the ELM-327

  1. #1
    Newbie
    Join Date
    Jan 2009
    Posts
    41

    Problems with the ELM-327

    I recently purchased the ELM-327 to use it on my 2007 Honda Odyssey, but can't figure out how make it work. The computer I'm using already has the drivers for the ELM-323, so when I plug the 327, the "new hardware found" wizzard does not come on. I believe it's trying to use the drivers for the 323. As a result, I can't figure out a way to install the drivers for the 327. When I plug the 327 to the OBD port using Dashcommand, I get the error message "Error detecting OBD II protocol." Another thing, when it's plugged to the OBD port, only the red (solid red) light comes on. The other lights such as TX, RX, etc. don't come on. They flash when Dashcommand attemps to establish communication.

    Any help is appreciated.

    Thanks,

    DominicanJB

  2. #2
    VENDOR - ScanTool Vitaliy's Avatar
    Join Date
    Dec 2006
    Location
    Phoenix, AZ
    Posts
    624
    ELM323 and ELM327 USB clones use the same FTDI drivers. The error you get means that DashCommand was able to connect to the scan tool, but could not detect the OBDII protocol.

    Where was your Odyssey originally sold (which country)?
    OBDLink MX: world's smallest, fastest, most advanced OBD/Bluetooth adapter with SW and MS CAN support. Read the review to learn more.
    Need to look up a diagnostic trouble code? Try the most up-to-date, free DTCsearch.com!

    You cannot send me a private message using this forum. Use my email instead: vitaliy[@]scantool.net.

  3. #3
    Newbie
    Join Date
    Jan 2009
    Posts
    41
    I bought my Odyssey brand new in Maryland, USA. Based on internet searches, I think this model uses the CAN protocol. This is the reason why I bought the 327. Doesn't the ELM327 use VCP drivers apart from the FTDI driver? According to instructions that came with the product, you need both set of drivers, and I can't figure out a way to install the VCP drivers without the "New Hardware Found" wizzard.

  4. #4
    Low Bitrate
    Join Date
    Sep 2008
    Posts
    99
    Last time I had to install a VCP, I went to my device manager and found the comport for my device. I right clicked and went to properties. Under one of the tabs in the properties was a check box to install VCP drivers.

  5. #5
    VENDOR - ScanTool Vitaliy's Avatar
    Join Date
    Dec 2006
    Location
    Phoenix, AZ
    Posts
    624
    Alex, if he already had drivers for the ELM323, he doesn't need to install a new set for the ELM327: they both use the same IC (FT232R). Also, "Error detecting OBDII protocol" means that DashCommand can talk to the device, but can't connect over OBDII.

    Worst case, use FTClean to uninstall the drivers, and install them again.
    OBDLink MX: world's smallest, fastest, most advanced OBD/Bluetooth adapter with SW and MS CAN support. Read the review to learn more.
    Need to look up a diagnostic trouble code? Try the most up-to-date, free DTCsearch.com!

    You cannot send me a private message using this forum. Use my email instead: vitaliy[@]scantool.net.

  6. #6
    VENDOR - ScanTool Vitaliy's Avatar
    Join Date
    Dec 2006
    Location
    Phoenix, AZ
    Posts
    624
    P.S. A 2007 Odyssey bought in Maryland should definitely be compatible. There must be something wrong with the tool.
    OBDLink MX: world's smallest, fastest, most advanced OBD/Bluetooth adapter with SW and MS CAN support. Read the review to learn more.
    Need to look up a diagnostic trouble code? Try the most up-to-date, free DTCsearch.com!

    You cannot send me a private message using this forum. Use my email instead: vitaliy[@]scantool.net.

  7. #7
    North of the land of Hey Huns
    Auto Apps:loading...

    Join Date
    Jun 2004
    Location
    Westminster, MD
    Posts
    2,144
    Where did you purchase the ELM device from? A reputable dealer, or is it a cheap ebay clone? (How much did you pay for it?)
    "stop with the REINSTALLS, what do you think we got some lame-o installer!!!" - mitchjs
    RevFE
    My Shop

  8. #8
    Newbie
    Join Date
    Jan 2009
    Posts
    41
    I want to thanks everybody for their support. I bought my unit from http://www.mo-co-so.com. They are a good company dedicated to the carputer market with excellent support. I understand that the this unit should work with the same drivers as the 323. Can someone help me with the following:

    1)Do you need the VCP drivers, and if so, how do you install it? I'll try Aberk's advice above and report back.

    2) When the device is connected to the OBD port and the computer, how many LEDs are supposed lit on?

    3) Vitality, what do you mean "something wrong with the tool?" do you mean Dashcommand or the unit?

    Thanks,

    DominicanJB

  9. #9
    Newbie
    Join Date
    Jan 2009
    Posts
    41
    I tried Aberk's method above and could not find any option to install the VCP drivers. Here are some screenshots I took while checking the device properties:
    Attached Images Attached Images     

  10. #10
    Admin. Linux loser.
    Auto Apps:loading...
    Bugbyte's Avatar
    Join Date
    Sep 2004
    Location
    Corning, NY
    Posts
    7,364
    Blog Entries
    2
    What model device did you buy? Give us a link to it.
    Quote Originally Posted by ghettocruzer View Post
    I was gung ho on building a PC [until] just recently. However, between my new phone having internet and GPS and all...and this kit...Im starting to have trouble justfiying it haha.
    Want to:
    -Find out about the new iBug iPad install?
    -Find out about carPC's in just 5 minutes? View the Car PC 101 video

Page 1 of 2 12 LastLast

Similar Threads

  1. elm 327 interface with laptop problem
    By gowing238 in forum Engine Management, OBD-II, Engine Diagnostics, etc.
    Replies: 15
    Last Post: 08-31-2010, 05:58 PM
  2. ELM 327 in windows 7?
    By bigbuffs in forum Engine Management, OBD-II, Engine Diagnostics, etc.
    Replies: 4
    Last Post: 12-16-2009, 09:06 PM
  3. Replies: 33
    Last Post: 03-28-2008, 02:18 PM
  4. Harddrive problems (booting)
    By Axxess in forum General Hardware Discussion
    Replies: 1
    Last Post: 05-15-2007, 04:13 PM
  5. Dell Inspiron 8200 & Lilliput TS problems?
    By bkpsu in forum LCD/Display
    Replies: 1
    Last Post: 08-15-2004, 01:55 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •