Results 1 to 3 of 3

Thread: Honda OBD to LCD project - hints and tips

  1. #1
    Newbie
    Join Date
    Oct 2011
    Posts
    2

    Honda OBD to LCD project - hints and tips

    Hello everyone! Some time ago I started with a project, reading data from the ECU and displayed on LCD. To establish a connection between the ECU and Pic controller / 16F886 / use Si9241 / K-line interface /. My Car - Honda Accord 2001 engine D16B6, which has a 5 pin diagnostic connector. I read that communication using ISO 9141 interface, but can not establish a connection between the ECU and Pic controller. Use the 5 boud initialization / 1 start; 8 data; no parity; a stop /, then switch to 10,400 baud rate, but I get no response from the ECU. Do not know if I'm wrong in initialization / maybe not the right protocol - ISO9141, or not using the correct baud rate / or have an error in the wiring diagram.
    I would be grateful for any assistance.
    Last edited by mars79; 01-05-2012 at 04:22 PM.

  2. #2
    North of the land of Hey Huns
    Auto Apps:loading...

    Join Date
    Jun 2004
    Location
    Westminster, MD
    Posts
    2,127
    I highly recommend either http://www.scantool.net/scan-tools/ics/stn1110.html or http://www.scantool.net/scan-tools/m...roobd-200.html depending on the maturity of your design, and how much design work you want to have to do yourself. That would eliminate a lot of unneccesary coding that has already been done. With either option, you can have your PIC talk directly to the STN chip, and it would handle all the protocol stuff. You just have to give it standard ELM style commands to retrieve data. Much easier.
    "stop with the REINSTALLS, what do you think we got some lame-o installer!!!" - mitchjs
    RevFE
    My Shop

  3. #3
    Newbie
    Join Date
    Oct 2011
    Posts
    2
    Thanks for the information, you should seek other than chip Si9241. Initially I stopped in the MC33290, but unfortunately in Bulgaria can not find it, also STN1110. Probably wrong in initialization. At the beginning of initialization send 0x33, but no response from the ECU. It is possible that Honda Where is different, although using the same protocol.

Similar Threads

  1. Replies: 6
    Last Post: 04-15-2007, 07:33 PM
  2. save$$$$Tips on buying new car(Honda CRV
    By steve2007 in forum Off Topic
    Replies: 24
    Last Post: 03-10-2007, 12:55 AM
  3. Replies: 4
    Last Post: 10-20-2006, 11:18 AM
  4. Replies: 5
    Last Post: 06-02-2004, 11:39 AM
  5. Hints and Tips
    By SkinnyBoy in forum Off Topic
    Replies: 15
    Last Post: 08-22-2001, 04:15 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •