Results 1 to 2 of 2

Thread: Help reading canbus with ELM327

  1. #1
    Newbie
    Join Date
    Jul 2014
    Posts
    2

    Help reading canbus with ELM327

    Hi Guys,

    Got a problem that I can't figure out for the life of me. my trade is in software, but I know which end of multimeter to hold

    Anyway I've had an USB ELM327 adapter hooked up to my 2008 BMW 3 series and got it all working connected to the K-CAN bus. This was working for a good 6 months or so, then it stopped working

    Since it's broken I've re-wired it (a new, better location) and got a new ELM327 adapter as as the old one had stopped responding on the USB side.

    Here is a list of everything I've tried to get it to work. I'm sure I'm missing something, hopefully someone here can spot it

    1) connected the ELM327 adapter to the OBDII port and it can read engine speed/temp so I think the adapter is working.
    2) Disconnected the CAN H and CAN L internally in the ELM327 and connected back to the OBDII port and it didn't work. (this was to prove the test above was valid. for CANBUS)
    3) Re-connected the CAN leads and repeated test 1) to proved I'd not broken it !
    4) With the ELM327 connected to the K-BUS (hooks in behind heating controls), measured with a scope the CAN-H and CAN-L leads inside the ELM327 with respect to ground. As expected you can see the data on both H and L and it's around 2 V which appears correct after a quick google.
    5) ELM327 is set to canbus 11 bits / 100kbps and the monitor all command (ATMA) returns nothing.
    6) If I set the protocol to auto (ATSP0) and then run ATMA I get SEARHING.... then a fail message.
    7) Sometimes (seen it twice out of say 50 times) I get something like a response of "RTR" from the ATMA command.
    8) Measured the ground connection on the ELM327 to chassis - 2 ohms resistance.
    9) Swapped over the CAN-H and CAN-L connectitons - still no response on the ATMA command.

    I have been mucking around with the EEPROM settings on the ELM327 so I could have fubared something there, not sure.

    My original but now dead ELM327 was version 1.4 (from the ATI command) and my new/current ELM327 is version 1.5.

    TIA, all comments welcome.

    sal

  2. #2
    Variable Bitrate
    Join Date
    Oct 2008
    Posts
    377
    Elm Electronics never produced version 1.5 of the ELM327.
    That is a counterfeit interface with probably an old version 1.2 ELM327 chip inside.
    That could be the reason for your problems.

Similar Threads

  1. CANBUS Anyone?
    By catnamedog in forum General MP3Car Discussion
    Replies: 3
    Last Post: 08-19-2011, 11:34 AM
  2. GPS and CANBUS
    By freddy2000 in forum GPS
    Replies: 0
    Last Post: 08-25-2010, 10:38 AM
  3. reading from canbus
    By naaas in forum Newbie
    Replies: 0
    Last Post: 05-28-2010, 02:16 AM
  4. Reading VIN using ELM327-based Tool
    By ms402 in forum Engine Management, OBD-II, Engine Diagnostics, etc.
    Replies: 8
    Last Post: 03-10-2010, 10:49 PM
  5. canbus and BMW most...
    By Siscobmw in forum Car Audio
    Replies: 6
    Last Post: 11-11-2009, 12:17 PM

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •