Results 1 to 4 of 4

Thread: different cables different sensor readings?

  1. #1
    Newbie
    Join Date
    May 2006
    Posts
    2

    different cables different sensor readings?

    My buddy has an ELM327 cable that he uses with digimoto 4.03 and Proscan 4.0. When hooking it up to my 1997 Chevy K2500HD 6.5 Turbo Diesel L65 Vin F, it only reads 6 sensors in any program we try. It reads IAT, VSS, RPM, LOAD, ECT and MAF(even though it has no MAF sensor). The reading I want is MAP (for boost). I have a boost gauge so I know what I'm getting, but I use a boost fooler on the boost sensor so I can run higher boost.

    Anyway, will different interfaces acquire different sensor readouts? I'd love to find one for boost.

  2. #2
    Neither darque nor pervert DarquePervert's Avatar
    Join Date
    Apr 2004
    Location
    Elsewhere
    Posts
    13,950
    If I understand correctly, it's all dependent on the protocol the auto manufacturer uses for OBD and whether they implement any custom codes in that protocol.

    I'm not the expert, mind you. I hope someone who knows more than I chimes in and corrects me if I'm wrong.
    Have you looked in the FAQ yet?
    How about the Wiki?



    Under normal circumstances, a signature would go here.

  3. #3
    Constant Bitrate joeyoravec's Avatar
    Join Date
    Oct 2005
    Location
    Livonia, MI
    Posts
    205
    The intelligence is really in the software. Although a different cable might read faster or slower, there will be no difference in the data. Although I don't have information on the 97 K2500, I can provide a few ideas for you to consider.

    OBD-II reports a a list of supported parameters. Some vehicles lie -- they might claim to support a parameter (but it's not available) and vice versa. If your scantool software relies upon this report, you might try to override and ask for MAP anyway.

    DP has a great point about the manufacturer-specific data. OBD-II has a standard parameter (0x0B) available for Intake Manifold Absolute Pressure with a range 0-255kPa and resolution of 1kPa, but Chevy might only report MAP with a manufacturer specific request. As far as I know, Digimoto and Proscan only request generic parameters. See if you can find GM specific software that has a more complete parameter database.

    Also it's possible that your engine controller has buggy software or does something unusual. Is your engine calibration up-to-date? Are they reporting MAP in place of MAF? Is the value a reasonable estimate or conversion?

    Finally, 1997 is only the second year that OBD-II was required. Your model year might provide a very limited number of parameters. You might simply be stuck!

  4. #4
    Newbie
    Join Date
    May 2006
    Posts
    2
    its a factory computer, so i have no idea if its been changed or messed with. Although there is a MAF reading available it always reads 0. With PCMSCAN I have had it do an 'aggressive' search for 'hidden' parameters and it only found there reported ones.

    I'll try again and see if I can force the 0x0B.

    thx

Similar Threads

  1. FS: Xm Cables, XM Home Cable, USB-Serial Adapters
    By Legarcondemerde in forum Classified Archive
    Replies: 9
    Last Post: 07-08-2006, 07:15 PM
  2. 25 wire data cables
    By peecee in forum General MP3Car Discussion
    Replies: 0
    Last Post: 04-03-2006, 09:59 AM
  3. 5x XMDirect Cables $25/ea shipped.
    By hevnsnt in forum Classified Archive
    Replies: 34
    Last Post: 04-12-2005, 01:57 AM
  4. Replies: 3
    Last Post: 09-03-2004, 08:07 PM
  5. Running cables
    By skippy76 in forum General Hardware Discussion
    Replies: 6
    Last Post: 04-15-2004, 03:32 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •