Results 1 to 4 of 4

Thread: Upload Sync Issue???

  1. #1
    Maximum Bitrate
    Join Date
    Apr 2004
    Location
    New York
    Posts
    482

    Upload Sync Issue???

    Hey,

    Been doing a backup upload of the car the past couple of days and have noticed that whenever I interrupt the transmission, the file that was partially uploaded gets shown on the home machine half done. Then, when I continue the upload sync, it'll go to the next file and not finish the file that has been partially syncing. Thats the problem.

    When mirroring the home computer this problem does not appear, atleast i have not experienced this same scenario under mirroring.
    Mark

    Website: http://www.greenpowerenthusiast.com/

    Car'Puter Project
    - Xenarc 700TSV
    - MSI RS482M-IL Mobo + AMD Turion MT-32 (25W)
    - 1x 256MB Corsair XMMS DDR400
    - M2-ATX
    - Belkin 802.11G W-Nic
    - Garmin 15H GPS
    - WinXP SP2 (NLited)

  2. #2
    Variable Bitrate
    Join Date
    Jan 2005
    Location
    UK
    Posts
    265
    Quote Originally Posted by DaRacerz
    Hey,

    Been doing a backup upload of the car the past couple of days and have noticed that whenever I interrupt the transmission, the file that was partially uploaded gets shown on the home machine half done. Then, when I continue the upload sync, it'll go to the next file and not finish the file that has been partially syncing. Thats the problem.

    When mirroring the home computer this problem does not appear, atleast i have not experienced this same scenario under mirroring.
    Thanks for this - I can see the cause of the problem.

    When you interrupt the sync, this results in the TCP connection getting broken. The code on the home PC side that executes when an individual file is completed also executes when the sync of an individual file is stopped half way through. This code renames the temporary file to be the actual filename. Hence you end up with a partially synced file in place.

    As I'm sure you've already found out, workaround is to delete the last file synced so that next time it will be sent again as the first file in the sync.

    I'll work on a fix.

    Ric.

  3. #3
    Variable Bitrate
    Join Date
    Jan 2005
    Location
    UK
    Posts
    265
    This one is now fixed, and will be in the next release.

  4. #4
    Maximum Bitrate
    Join Date
    Apr 2004
    Location
    New York
    Posts
    482
    nice, thx for the fix.
    Mark

    Website: http://www.greenpowerenthusiast.com/

    Car'Puter Project
    - Xenarc 700TSV
    - MSI RS482M-IL Mobo + AMD Turion MT-32 (25W)
    - 1x 256MB Corsair XMMS DDR400
    - M2-ATX
    - Belkin 802.11G W-Nic
    - Garmin 15H GPS
    - WinXP SP2 (NLited)

Similar Threads

  1. Xenarc touchscreen issue
    By b0arderxc79 in forum LCD/Display
    Replies: 7
    Last Post: 10-08-2006, 04:24 AM
  2. iGuidance Hibernation - Interesting Issue
    By Troy McClure in forum GPS
    Replies: 9
    Last Post: 06-11-2005, 02:16 AM
  3. Issue with the radio?
    By l0gic in forum Road Runner
    Replies: 9
    Last Post: 05-07-2005, 04:44 AM
  4. Lilliput Over Range Issue
    By bluesteel1969 in forum Newbie
    Replies: 5
    Last Post: 03-09-2005, 01:22 PM
  5. sync files
    By psuter in forum Road Runner
    Replies: 5
    Last Post: 02-25-2005, 03:11 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •