Results 1 to 6 of 6

Thread: paint problem. please help

  1. #1
    Newbie
    Join Date
    May 2004
    Posts
    28

    paint problem. please help

    ok well im painting my radio bezel and for some reason the paint is drying two different colors. and sometimes it's really pimply. any suggestions? here are some pics. please help

    http://www.angelfire.com/extreme4/jd...3/CIMG0838.JPG

    http://www.angelfire.com/extreme4/jd...3/CIMG0839.JPG

  2. #2
    MySQL Error Scouse Monkey's Avatar
    Join Date
    Mar 2004
    Location
    Bristol
    Posts
    9,727
    probably moisture or a reaction with the material below. Did you use a decent coat of primer?

  3. #3
    Newbie
    Join Date
    May 2004
    Posts
    28
    i used fusion which aco empolyees said i could use to make it bond to plastic

  4. #4
    FLAC -zip-'s Avatar
    Join Date
    Sep 2004
    Location
    Ontario/Canada
    Posts
    1,293
    I use fusion as well is it Krylon Fusion?.

    Make sure to use primer and don't use heavy coats, very light coats.

    The people at the hardware store told me the same thing, that you dont need primer well that's BS.

    Without primer I found that the paint can chip off easily if hit by something. The paint has been on my accessory parts for over a year now. Being in Canada it has seen from -30 to +30 temperature variances and holds up well.

    I had to sand, primer and repaint everything so far no chips after that process.

    Also, had some pitting but that was because I was rushing it a bit and the paint got too thick on one small area. Let dry, sand and re-paint that area.
    2008 350z GT Installed since April 22nd 2011 - Worklog
    2000 Protege Installed Since April 2, 2005 - Intel D201GLY|Fusion Brain|ODBPros ODBII|Engenius|GPS Rikaline|Powermate|Motorized Lilli
    Sound Stage
    Eclipse|MTX|Infinity

  5. #5
    Variable Bitrate SickVette's Avatar
    Join Date
    May 2005
    Location
    Wesley Chapel, Fl
    Posts
    325
    zip is correct. Primer should be applied. Also you need to make sure the parts are extremely clean and free of any past Armor All or other dressings. Wipe the parts throughly with denatured alchol or rubbing alchol. All that to dry then appply paint and try not to touch any of the surface to be painted with your bare hands after you clean it. Oils from your skin can cause fish eyes also.

    Thin light coats and make sure the paint flashes inbetween coats. Do not rush it and you will have a very nice finish.

  6. #6
    Maximum Bitrate Altimat's Avatar
    Join Date
    Oct 2003
    Location
    WI
    Posts
    764
    You must have dissimilar materials underneath. If it was painted and you sanded the paint off in one area and not another that can happen. Let it dry for a few days, sand it very lightly with 500-600 (without sanding through!!), and respray. That should take care of it. What you will be doing is using this coat of paint as the primer.
    Fabricator

Similar Threads

  1. Lilliput TouchKit problem solved!
    By AAVfReaK in forum LCD/Display
    Replies: 4
    Last Post: 11-07-2010, 09:29 AM
  2. A little problem with my car... Maybe...
    By BoyNextDoor in forum Power Supplies
    Replies: 30
    Last Post: 11-13-2004, 09:58 PM
  3. Media Car not responding... Lilliput problem?
    By carpcnoobie in forum MediaCar
    Replies: 3
    Last Post: 09-01-2004, 02:38 PM
  4. color matching paint
    By [H]Bugster in forum Fabrication
    Replies: 3
    Last Post: 07-19-2004, 05:29 PM
  5. cordless phone problem
    By jstrain in forum Off Topic
    Replies: 2
    Last Post: 06-24-2003, 12:09 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •