Page 9 of 35 FirstFirst 12345678910111213141516171819 ... LastLast
Results 81 to 90 of 345

Thread: Uber MDX Configurator Beta Testing...

  1. #81
    Constant Bitrate
    Join Date
    Jan 2008
    Location
    Texas
    Posts
    151
    Quote Originally Posted by 2k1Toaster View Post
    Can you describe what buttons you are pressing and what you are trying to do in a sequence so I can recreate it or something? I have no idea what is happening on your computer because I have checked and checked an there is no way for this to happen.
    All right, I have narrowed it down to this, it has nothing to do with a background image. I downloaded the latest version with the same results, so i downloaded the latest version to a different XP machine and set it up there with the exact same results. then I opened an old test xml on the original computer and it was working right, the thing I noticed was that on opening this file it showed a " no preview available" image in the window before I opened the graphic editor, and on the others this window was just a blank white page. next I tried once again to start a fresh skin, when I open the configurator, I am faced with the blank white screen and if I go on from there it will inevitable not let me edit the buttons. then out of dumb luck I clicked on the change page icon, even tho I only have 1 page. this seems to turn on the preview and allows the editing and the "no smoking" button/icon to start working (changes through lock unlock and no smoking)

    I don't know why but all it takes to get this acting right is to click on the next page Icon in the tool bar.

    ok when I open the program I see this
    Name:  test1.jpg
Views: 118
Size:  76.8 KB
    once I click the green plus to add a page I see this
    Name:  test2.jpg
Views: 128
Size:  78.3 KB
    I can click on the edit icon now and it lets me do my thing, but if I ever want to edit a button I can't, but If I click the next page Icon to change it from 0/1 to 1/1 then I get this
    Name:  test3.jpg
Views: 115
Size:  87.2 KB
    and with this it all works, maybe it makes sense in a weird way because I am trying to work on page 0 of 1 but then maybe the program should only have a zero page if I haven't added one an then automatically start at 1 of 1?

    any way I have it figured out how to do it now but this may cause others to bother you with the same questions of it not working.

    P.S. you did say you were trying to make this "idiot proof" well leave it to me to be the perfect guinea pig as I make a good idiot!!!!

  2. #82
    Fusion Brain Creator 2k1Toaster's Avatar
    Join Date
    Mar 2006
    Location
    Colorado, but Canadian!
    Posts
    10,053
    Ok, that makes more sense. It is 0 indexed. But I have 1 added to it in some places for display. If it says 0/1, then I am missing changing it to 0 since the default is -1. So you are getting (-1 + 1 = 0) and it should be (0 + 1 = 1) which are different pages to it.

    This is something I should be able to find.
    Fusion Brain Version 6 Released!
    1.9in x 2.9in -- 47mm x 73mm
    30 Digital Outputs -- Directly drive a relay
    15 Analogue Inputs -- Read sensors like temperature, light, distance, acceleration, and more
    Buy now in the MP3Car.com Store

  3. #83
    Fusion Brain Creator 2k1Toaster's Avatar
    Join Date
    Mar 2006
    Location
    Colorado, but Canadian!
    Posts
    10,053
    Ok, well I just found a sorting algorithm bug and fixed that. I know for sure this fixes h3rk's problem.

    jimp, do you have static images covering your display image?

    Basically I was sorting by z-order, but accidentally only swapping z-orders not the full items! So the order that you added things to was kept (which is bad), but the z orders were updated. This is fixed. I am uploading a new one, it should be ready in a few minutes.
    Fusion Brain Version 6 Released!
    1.9in x 2.9in -- 47mm x 73mm
    30 Digital Outputs -- Directly drive a relay
    15 Analogue Inputs -- Read sensors like temperature, light, distance, acceleration, and more
    Buy now in the MP3Car.com Store

  4. #84
    Fusion Brain Creator 2k1Toaster's Avatar
    Join Date
    Mar 2006
    Location
    Colorado, but Canadian!
    Posts
    10,053
    New upload available for download.
    Fusion Brain Version 6 Released!
    1.9in x 2.9in -- 47mm x 73mm
    30 Digital Outputs -- Directly drive a relay
    15 Analogue Inputs -- Read sensors like temperature, light, distance, acceleration, and more
    Buy now in the MP3Car.com Store

  5. #85
    Fusion Brain Creator 2k1Toaster's Avatar
    Join Date
    Mar 2006
    Location
    Colorado, but Canadian!
    Posts
    10,053
    Ok jimp, please download the latest version. I just uploaded a new version with a folder with an example skin folder. Try to open and edit this file.

    This has a background image, static images, and a display button. See if editing or creating works in that skin.
    Fusion Brain Version 6 Released!
    1.9in x 2.9in -- 47mm x 73mm
    30 Digital Outputs -- Directly drive a relay
    15 Analogue Inputs -- Read sensors like temperature, light, distance, acceleration, and more
    Buy now in the MP3Car.com Store

  6. #86
    Constant Bitrate
    Join Date
    Jan 2008
    Location
    Texas
    Posts
    151
    Quote Originally Posted by 2k1Toaster View Post
    jimp, do you have static images covering your display image?
    no, simply 1 single button on a blank page with no background image and no static image.

  7. #87
    Constant Bitrate
    Join Date
    Jan 2008
    Location
    Texas
    Posts
    151
    Quote Originally Posted by 2k1Toaster View Post
    Ok jimp, please download the latest version. I just uploaded a new version with a folder with an example skin folder. Try to open and edit this file.

    This has a background image, static images, and a display button. See if editing or creating works in that skin.
    Ok that works great, I see on this one as soon as I click to add a page it changes to 1/1 and is editable.

  8. #88
    Fusion Brain Creator 2k1Toaster's Avatar
    Join Date
    Mar 2006
    Location
    Colorado, but Canadian!
    Posts
    10,053
    Quote Originally Posted by jimp View Post
    Ok that works great, I see on this one as soon as I click to add a page it changes to 1/1 and is editable.
    So it works now?

    If you open that skin I included (well more like a test skin, it doesnt do anything lol) does it work or not? If you make your own, does it work or not? If you open a different does it work or not?

    From the sounds of it, it seems to work right?
    Fusion Brain Version 6 Released!
    1.9in x 2.9in -- 47mm x 73mm
    30 Digital Outputs -- Directly drive a relay
    15 Analogue Inputs -- Read sensors like temperature, light, distance, acceleration, and more
    Buy now in the MP3Car.com Store

  9. #89
    Constant Bitrate
    Join Date
    Jan 2008
    Location
    Texas
    Posts
    151
    I opened the skin just to see if I could edit and it worked but then I suspected that would be the case . then I opened it without opening a skin and as soon as I clicked on the add page button it switched to page 1/1 (the old one stayed at page 0/1) and I was able to edit buttons with no problem. I haven't tried opening any other skins yet but I see no reason why it wouldn't work, I have to run to town right now but will try that when I return and let you know if there are any problems.

    Once again thanks

  10. #90
    Fusion Brain Creator 2k1Toaster's Avatar
    Join Date
    Mar 2006
    Location
    Colorado, but Canadian!
    Posts
    10,053
    cool beans
    Fusion Brain Version 6 Released!
    1.9in x 2.9in -- 47mm x 73mm
    30 Digital Outputs -- Directly drive a relay
    15 Analogue Inputs -- Read sensors like temperature, light, distance, acceleration, and more
    Buy now in the MP3Car.com Store

Similar Threads

  1. programing in the Uber Edition.
    By customaudioman in forum Fusion Brain
    Replies: 34
    Last Post: 02-27-2008, 11:35 PM
  2. Simulating GPS data for testing
    By god_of_cpu in forum StreetDeck F.A.Q.
    Replies: 0
    Last Post: 08-08-2006, 01:16 PM
  3. Testing with standard AC supply
    By rockthevolvo in forum Power Supplies
    Replies: 5
    Last Post: 08-18-2004, 05:12 PM
  4. Problem testing VIA EPIA w/standard atx power supply
    By khufumen in forum Power Supplies
    Replies: 4
    Last Post: 11-15-2003, 02:22 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •