Page 6 of 7 FirstFirst 1234567 LastLast
Results 51 to 60 of 62

Thread: Creating fonts in Configurator

  1. #51
    Fusion Brain Creator 2k1Toaster's Avatar
    Join Date
    Mar 2006
    Location
    Colorado, but Canadian!
    Posts
    10,049
    no problem. I never used the program so I didnt even know if it was there or not, but it better be for an image editing program!
    Fusion Brain Version 6 Released!
    1.9in x 2.9in -- 47mm x 73mm
    30 Digital Outputs -- Directly drive a relay
    15 Analogue Inputs -- Read sensors like temperature, light, distance, acceleration, and more
    Buy now in the MP3Car.com Store

  2. #52
    Constant Bitrate
    Join Date
    Jun 2008
    Location
    Georgia, USA
    Posts
    188
    I will put together a short, step-by-step tutorial sometime today.

    Thanks again for the help.
    Thanks,

    Dan

  3. #53
    Constant Bitrate
    Join Date
    Jun 2008
    Location
    Georgia, USA
    Posts
    188
    Whew...I have a 15 page Word document with step-by-step instructions for defining a new Fusion Font.

    Would you like me to email it to you for proofing or should I just post it in the documentation forum?

    Dan
    Thanks,

    Dan

  4. #54
    _
    Join Date
    Mar 2004
    Location
    Little Elm, Texas
    Posts
    13,500
    Dan - if you can write up a tutorial, I'd appreciate it!
    Jan Bennett
    FS: VW MKIV Bezel for 8" Lilliput - 95% Finished

    Please post on the forums! Chances are, someone else has or will have the same questions as you!

  5. #55
    Constant Bitrate
    Join Date
    Jun 2008
    Location
    Georgia, USA
    Posts
    188
    One problem I am running into is saving the font configuration file after defining all of the characters.

    Every time I try to save the file I get en error dialog telling me the file is in use by another process. Using a utility to show open file handles, nothing has the file open.

    How do I get around this???
    Thanks,

    Dan

  6. #56
    Constant Bitrate
    Join Date
    Jun 2008
    Location
    Georgia, USA
    Posts
    188
    Quote Originally Posted by Dan2008 View Post
    One problem I am running into is saving the font configuration file after defining all of the characters.

    Every time I try to save the file I get en error dialog telling me the file is in use by another process. Using a utility to show open file handles, nothing has the file open.

    How do I get around this???
    Just to be sure nothing had the file open, I rebooted and started the Configurator. I opened the font image file, analyzed it and tried to save it. This still produced the same error and the Configurator was the only program executed after the reboot.

    Something about the way the file is opened is not allowing the file to be saved.

    Looking at the detailed output from the error, it is trying to save xxx.png. Shouldn't this be xxx.xml instead?
    Thanks,

    Dan

  7. #57
    Constant Bitrate
    Join Date
    Jun 2008
    Location
    Georgia, USA
    Posts
    188
    Okay, found the problem there. I initially placed the image file in the fonts directory. When saving the file, the program attempts to create a new image file with the same name in the fonts directory.

    Moving the image file to another directory allow the font file to be saved.

    I looked at the source for AddFontForm.cs and it creates the filestream with FileMode.OpenOrCreate and FileAccess.ReadWrite so I don't know what the issue is. That should allow overwriting the existing file.
    Thanks,

    Dan

  8. #58
    Constant Bitrate
    Join Date
    Jun 2008
    Location
    Georgia, USA
    Posts
    188
    I'm going to go ahead and post the tutorial here. Check for errors as you go through it and let me know if anything needs to be changed or if it is unclear.

    If everything is okay then Nick might want to move it to the documentation forum.
    Attached Files Attached Files
    Thanks,

    Dan

  9. #59
    Fusion Brain Creator
    Join Date
    Mar 2005
    Posts
    2,221
    Thanks Dan!

    If you guys want to upload your fonts, we can include them in future releases of the Configurator

  10. #60
    _
    Join Date
    Mar 2004
    Location
    Little Elm, Texas
    Posts
    13,500
    It would be cool to have some of the most commonly used fonts already loaded when you download the program. Or perhaps a repository of user created fonts on the site?

    Downloading the .doc file and will go over it this afternoon. Thanks!
    Jan Bennett
    FS: VW MKIV Bezel for 8" Lilliput - 95% Finished

    Please post on the forums! Chances are, someone else has or will have the same questions as you!

Page 6 of 7 FirstFirst 1234567 LastLast

Similar Threads

  1. Fresh Install on New PC, Rebooting
    By phc in forum StreetDeck
    Replies: 3
    Last Post: 12-23-2007, 10:33 AM
  2. Holux GPS Trouble
    By mangus580 in forum StreetDeck
    Replies: 34
    Last Post: 11-26-2007, 09:56 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •