Page 2 of 5 FirstFirst 12345 LastLast
Results 11 to 20 of 42

Thread: Fusion Control Centre MDX & Configurator -- Major Update 22/12/2008

  1. #11
    Fusion Brain Creator 2k1Toaster's Avatar
    Join Date
    Mar 2006
    Location
    Colorado, but Canadian!
    Posts
    10,049
    Quote Originally Posted by Alanh View Post
    Well, my attempt at updating has been a giant leap backward.

    I think I got the drivers loaded correctly since my v3 Brain doesn't show up under libUSB anymore. Its listed in Device Manager as The Fusion Brain Version 3 under Fusion Control Center.

    When I run the Configurator, the one Brain I have connected shows up in the config file as a v3 which it is. When I go through the process of identifying it using the blinking LEDs, it works until I try to exit that at which point the configurator dies and asks if I want to send an error report.

    When I start up FCC Uber MDX, it dies right away and asks if I want to send an error report.

    I've completely reinstalled the sw from the FCC site (except for the updater because the installer complains it can't replace it and I don't seem to be able to get rid of it completely either).

    Any suggestions?


    When did you last update? Meaning you came from vesion ??? to this new version?

    Please post a screenshot of the error.
    Fusion Brain Version 6 Released!
    1.9in x 2.9in -- 47mm x 73mm
    30 Digital Outputs -- Directly drive a relay
    15 Analogue Inputs -- Read sensors like temperature, light, distance, acceleration, and more
    Buy now in the MP3Car.com Store

  2. #12
    Constant Bitrate
    Join Date
    Apr 2004
    Location
    Philly
    Posts
    157
    is this update compatible with my code?? I've tired other updates and my FB stopped working.....

  3. #13
    Fusion Brain Creator 2k1Toaster's Avatar
    Join Date
    Mar 2006
    Location
    Colorado, but Canadian!
    Posts
    10,049
    Quote Originally Posted by dasaint80 View Post
    is this update compatible with my code?? I've tired other updates and my FB stopped working.....
    Well I dont know what your code is, so.... yes?

    But everything is backwards compatible in the configuration file except what I have explicitly said.

    If it didnt work, then it was probably a driver update that was needed and not followed through or something along those lines.
    Fusion Brain Version 6 Released!
    1.9in x 2.9in -- 47mm x 73mm
    30 Digital Outputs -- Directly drive a relay
    15 Analogue Inputs -- Read sensors like temperature, light, distance, acceleration, and more
    Buy now in the MP3Car.com Store

  4. #14
    Low Bitrate GadgetBandit's Avatar
    Join Date
    Oct 2008
    Posts
    100
    I updated my driver through device manager. I used Ninja Kitty to identify the brain,copied the new "brain id", pasted it into my xml file, works fine.

    My complaint is the auto update was yesterday and the notice, today. Last was spent trying figure out what was going on, but I went to sleep knowing the temp was in the greenhouse.

    Good Product!

    GadgetBandit

  5. #15
    Fusion Brain Creator 2k1Toaster's Avatar
    Join Date
    Mar 2006
    Location
    Colorado, but Canadian!
    Posts
    10,049
    Quote Originally Posted by GadgetBandit View Post
    I updated my driver through device manager. I used Ninja Kitty to identify the brain,copied the new "brain id", pasted it into my xml file, works fine.

    My complaint is the auto update was yesterday and the notice, today. Last was spent trying figure out what was going on, but I went to sleep knowing the temp was in the greenhouse.

    Good Product!

    GadgetBandit
    I am confused. The update went out about 3 hours after I sent an email to all customers.
    Fusion Brain Version 6 Released!
    1.9in x 2.9in -- 47mm x 73mm
    30 Digital Outputs -- Directly drive a relay
    15 Analogue Inputs -- Read sensors like temperature, light, distance, acceleration, and more
    Buy now in the MP3Car.com Store

  6. #16
    Super Moderator
    Auto Apps:loading...
    JohnWPB's Avatar
    Join Date
    Sep 2005
    Location
    West Palm Beach, Florida
    Posts
    4,723
    Blog Entries
    1
    Ok, running into issues, I used the Ninja Kitty, picked all my digital in's and outs (Selected brain 0 and it did not error out that it was not found, so it seems to have seen the brain).

    Running the MDX software, I am unable to control or read any inputs from the FB (Standard buttons do not mouse over or respond)

    In Device Manager I have:

    Driver Date: 12/21/2008
    Driver Version: 3.3.0.0

    Looking at the date seems correct, but no way to tell, as in the screen cap in the email and first post you just show "The Fusion Brain Version 4" in device manager, and no other driver details. Mine shows "The Fusion Brain Version 3" as that is the device I have.

    I uninstalled everything, rebooted, installed everything, rinsed and repeated a few times, with no luck. After installing with the full installer .exe, when it completes, it downloads some updates. This install is as if 12/27/2008 3:00 am EST. Just as a note, this FB was working correctly an hour ago before I did the update, aside from having to unplug and re-plug the USB to it each time the software is ran. (I did try that this time as well, with no luck).

    E D I T :

    I found the problem! Seems to be a possible bug with the Ninja Kitty. I was going through the XML that the NK created and came across this:

    PHP Code:
    <!-- Begin Fusion Brain Instances -->
          <
    brain id="My Fusion Brain 0" version="4">BRAIN ID 0</brain>
      <!-- 
    End Fusion Brain Instances --> 
    I changed the Version = "4" to "3" and it began working. All I have is the version 3, so it appears the NK is not determining what version of the board is connected when it saves out the XML file.



    And a bit of good news!

    I no longer have to unplug and replug the FB ever time I run the configurator or the MSX! WooHoo!
    Front End of Choice: Ride Runner (Is there anything else??? ) & Powered by the DFX5.1 Skin Available in the Mobile App Mart

    My Fiero Build Thread

  7. #17
    Fusion Brain Creator 2k1Toaster's Avatar
    Join Date
    Mar 2006
    Location
    Colorado, but Canadian!
    Posts
    10,049
    Quote Originally Posted by JohnWPB View Post
    Ok, running into issues, I used the Ninja Kitty, picked all my digital in's and outs (Selected brain 0 and it did not error out that it was not found, so it seems to have seen the brain).

    Running the MDX software, I am unable to control or read any inputs from the FB (Standard buttons do not mouse over or respond)

    In Device Manager I have:

    Driver Date: 12/21/2008
    Driver Version: 3.3.0.0

    Looking at the date seems correct, but no way to tell, as in the screen cap in the email and first post you just show "The Fusion Brain Version 4" in device manager, and no other driver details. Mine shows "The Fusion Brain Version 3" as that is the device I have.

    I uninstalled everything, rebooted, installed everything, rinsed and repeated a few times, with no luck. After installing with the full installer .exe, when it completes, it downloads some updates. This install is as if 12/27/2008 3:00 am EST. Just as a note, this FB was working correctly an hour ago before I did the update, aside from having to unplug and re-plug the USB to it each time the software is ran. (I did try that this time as well, with no luck).

    The "Version 3" and "Version 4" are Fusion Brain versions. I am pretty sure you have a version 3, and that is why it is showing up as "Fusion Brain V3".

    make sure your configuration file says version="3" in the brain IO section.

    ps. sorry about the family troubles
    Fusion Brain Version 6 Released!
    1.9in x 2.9in -- 47mm x 73mm
    30 Digital Outputs -- Directly drive a relay
    15 Analogue Inputs -- Read sensors like temperature, light, distance, acceleration, and more
    Buy now in the MP3Car.com Store

  8. #18
    Super Moderator
    Auto Apps:loading...
    JohnWPB's Avatar
    Join Date
    Sep 2005
    Location
    West Palm Beach, Florida
    Posts
    4,723
    Blog Entries
    1
    I should have known you would not be sleeping, and lurking here instead!

    Yea, thats what it was... (Above post edited) I thought it determined the version of the board connected. Thats what I get for thinking.

    Thank you, it's been tough, especially this time of year. I actually started to pick up the phone Christmas day to call my mom, just out of habit...
    Front End of Choice: Ride Runner (Is there anything else??? ) & Powered by the DFX5.1 Skin Available in the Mobile App Mart

    My Fiero Build Thread

  9. #19
    Super Moderator
    Auto Apps:loading...
    JohnWPB's Avatar
    Join Date
    Sep 2005
    Location
    West Palm Beach, Florida
    Posts
    4,723
    Blog Entries
    1
    Ok, sorry, something else I just ran into.....

    I started tweaking the label names, and when I change one, MDX crashes for some reason.

    For Analog in 1 I had a label of "Temperature 1". I loaded the XML in the configurator, double clicked the temp 1, and changed the label to "Computer Temp". I saved out the XML. When I run MDX, It errors out (Has caused a problem and needs to close, just a generic error). I opened the configurator, changed it back to "Temperature 1" and saved it, ran mdx and it ran correctly. I did this 3 times, just to verify that it was the changing of a label causing it. With the label as Temperature 1, I can open, close, open, close the MDX, soon as I change it with the configurator and save it, it crashes on loading.

    It's possibly changing the label in one location of the XML and not updating another part or something?

    If you need to remote into my machine again for testing, just let me know.
    Front End of Choice: Ride Runner (Is there anything else??? ) & Powered by the DFX5.1 Skin Available in the Mobile App Mart

    My Fiero Build Thread

  10. #20
    Fusion Brain Creator 2k1Toaster's Avatar
    Join Date
    Mar 2006
    Location
    Colorado, but Canadian!
    Posts
    10,049
    I should have known you would not be sleeping, and lurking here instead!

    Yea, thats what it was... (Above post edited) I thought it determined the version of the board connected. Thats what I get for thinking.

    Thank you, it's been tough, especially this time of year. I actually started to pick up the phone Christmas day to call my mom, just out of habit...
    It's not a bug. When you make your Fusion Brain instance, there is another box that says version. Did you change that to 3?

    So everything works and through multiple run times?
    Fusion Brain Version 6 Released!
    1.9in x 2.9in -- 47mm x 73mm
    30 Digital Outputs -- Directly drive a relay
    15 Analogue Inputs -- Read sensors like temperature, light, distance, acceleration, and more
    Buy now in the MP3Car.com Store

Page 2 of 5 FirstFirst 12345 LastLast

Similar Threads

  1. *NEW* USB Input/Output Board -- Fusion Brain
    By 2k1Toaster in forum Fusion Brain
    Replies: 1123
    Last Post: 02-22-2010, 03:33 AM
  2. Fusion Control Center skin
    By sxtnitehawk in forum Software & Software Development
    Replies: 1
    Last Post: 10-14-2007, 08:39 PM
  3. Need wiring help for 2005 Grand Prix.
    By derekmac in forum Car Audio
    Replies: 33
    Last Post: 09-21-2007, 10:42 PM
  4. Remote Control Fusion Brain.
    By alexgray104 in forum Fusion Brain
    Replies: 9
    Last Post: 09-06-2007, 04:16 AM
  5. Replies: 2
    Last Post: 07-24-2007, 10:11 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •