Announcement

Collapse
No announcement yet.

FS: Broken 7" Lilliput w/TS

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • FS: Broken 7" Lilliput w/TS


    My camera is awful so I couldn't really get a good image.

    This is a working lilliput aside from the fact that the connector for the large ribbon cable is not soldered on the board and the two plastic things that hold the cable in are missing. I broke the connector off trying to get the ribbon cable to stay in. Since I didn't have the little plastic clips I invented several ways to get that ribbon cable in, but after a few weeks it would work its way out again. The last time I tried to permanetly fix the problem, I broke the connector off.

    Those pins are really small and close together on the board so don't think you can just solder some wires on there. The pins are like .25mm apart. Also, it looks like the board is burned or something in the pic but it's not.

    I have no idea if anyone here has a way of repairing this, but I guess I'll part it out if no one's interested in the whole thing. PM me offers on that now if you want.

    Here's a picture from when it was working.


    $150

  • #2
    Does anyone know of a place that could fix this? Maybe I'll just send it somewhere for repair. ttt

    Comment


    • #3
      So is the soldering pads pulled of the bd ? I need to a close up were the connector hooks up to bd. I should be able to fix it for you. I have fix stuff for others on this forum

      pm me about this .
      www.sounddomain.com/id/2000mp3ranger

      Mp3 player - 10.4 Allbrite Gigabyte GA-71XEH , 700 mgz t-bird , coolmaster fan , 2x 128 ram + 1 512ram , ATI-RAEON RV100 ,on bd sound , Linksys Wireless-B usb network adapter , 20G IBM TRAVELSTAR

      Comment


      • #4
        The pads are intact.

        Comment


        • #5
          So would you like me to fix the screen for you ? Is their a part # or model # on the connector ?
          www.sounddomain.com/id/2000mp3ranger

          Mp3 player - 10.4 Allbrite Gigabyte GA-71XEH , 700 mgz t-bird , coolmaster fan , 2x 128 ram + 1 512ram , ATI-RAEON RV100 ,on bd sound , Linksys Wireless-B usb network adapter , 20G IBM TRAVELSTAR

          Comment


          • #6
            Well, do you really think you can? How are you planning on soldering those little pins? Do you have some special tools or something? Also, what about the missing plastic things that hold the ribbon cable in on both sides?

            And I'm assuming you've seen this connector up close before and know exactly how small those pins are.

            I'd have to open it up again to see if there any numbers on the board. It looks like something's written there as you can see in the picture. There is nothing on the connector that's broken off.

            Comment


            • #7
              I no that I can fix it . I have a soldering station with really small tips . I was going try a and find a new connector.
              www.sounddomain.com/id/2000mp3ranger

              Mp3 player - 10.4 Allbrite Gigabyte GA-71XEH , 700 mgz t-bird , coolmaster fan , 2x 128 ram + 1 512ram , ATI-RAEON RV100 ,on bd sound , Linksys Wireless-B usb network adapter , 20G IBM TRAVELSTAR

              Comment


              • #8
                Alright, that sounds good. I'll PM you.

                Comment

                Working...
                X