No announcement yet.

VMware issues

  • Filter
  • Time
  • Show
Clear All
new posts

  • VMware issues

    My co-worker installed VMware (Virtual Machine) on his PC. It's running fine but it WILL NOT detect his USB devices.

    Yes, the USB drivers are up todate and installed properly.
    Yes, the VM is set to auto detect them.
    No, I cannot manually select the items from the VM>Removeable Devices Settings.
    Yes, I can see the USB devices on the Host system.

    I ran through the help topic on VMware. VMware's online help is down currently...

  • #2
    What OS are you using with VMWare?

    If linux, do you have the proper USB modules built in or loaded?
    Audio Rockford Fosgate: 900 Watt 4-channel amp, 501bd Mono amp
    Computer AMD 2400+ XP, 1 GB DDR RAM, Orbit Micro 250W DC-DC PSU

    Head units are for cheaters!
    sure some girls fake orgasms.....but it's guys like me who fake the whole relationship


    • #3
      You have to unplug replug them. When VMWare is running with USB support enabled, the host system should no longer detect the USB device. Instead, the host should try to install a VMWare virtual USB device driver for each new device you plug in. The guest OS should then go through it's normal USB detection process -- depending on what Host/Guess OS you are running.

      I run XP/Linux guests on an XP host and the USB support works just fine in either case. I haven't tried this from a Linux host. I can't tell which combination you're running from your post.
      2004 4runner


      • #4
        bah, forgot to note, he's running Windows 2000 on both host and guest.


        • #5
          IIRC there is a setting somewhere in vmware that you have to choose weather to allow the usb device to be managed by the host or guest. Seems to me it would pop up and prompt when a new device was inserted but it been so long since I've ran windows as a host I can't remember for sure now.


          • #6
            ^^^ yeah, there is a check box. We've got that checked... shut down restarted everything. I dunno.


            • #7
              Vmware was one of the (many) reasons I quit running XP, wasn't stable/fast enough. I would recommend running vmware under linux, it runs a whole lot better, espically since linux doesn't have the virtual memory problems like XP.


              • #8
                Ok, still no solution. Only idea is I think VMware is set up to detect active USB devices rather than the Aladin Hasp and/or the USB Pen Drive.

                I'm going to bring in my DigiCam and usb stuff tomorrow to see if it will detect that.


                • #9
                  Well... if anyone is still following the issue... I plugged in my Canon A60 camera and the host detected it right away, but the guest still didn't see it. It's either an issue with VMware in general OR VMware with Windows 2000. We have the latest and greatest updates for both VMware and windows, along with my camera drivers.