No announcement yet.

2000 model suzuki carputer setup

  • Filter
  • Time
  • Show
Clear All
new posts

  • 2000 model suzuki carputer setup

    Hi all.

    Posting here my basic setup which has been a DIY all along.


    01. VM70 7'' lcd touch screen.
    02. Jetway mini-itx motherboard NC62K
    03. AMD Athlon X2 4850E 2.5Ghz.
    04. M3 automotive power supply.
    05. 250Gb hitachi 2.5 hard disk.
    06. 2Gb kingston ram
    07. ADS RDX-155-EF Instant FM Music.
    08. GlobalSat BU-353 USB GPS Receiver.
    09. Intex slim usb dvd writer.
    10. Enter mini keyboard.
    11. Blaupunkt THA555PNP 5-channel car amplifier 55 watts RMS x 4 + 200 watts RMS x 1
    12. Infinity reference 9623i 6x9 rear, split and installed.
    13. Boston acoustics S60 for the fronts.
    14. Rockford 12'' subwoofer 150wats in a sealed box.
    15. Rear view camera
    16.15amp anl fuse block with a voltmeter

    Installed tiny version of windows 7 and centerfuse trial version to see how it works out.
    Attached Files

  • #2
    Thanks buddy. Some pictures of carputer in operation.
    Attached Files


    • #3
      Holy crap! That's BY FAR the cleanest install I've seen!
      What kind of USB hub is that in your glovebox? It's tiny. I need something like that for my install.
      After a 2 year break, I'm back! There are so many new and familiar faces here!
      New vehicle, new ideas!

      Chryssi - The Changeling CarPC Project


      • #4
        Thanks. Usb hub is a unbranded Chinese make but not a high speed one. replacing it soon with a 4 port high speed belkin one.


        • #5
          Good job!

          You are using a setup very close to the one I have, good job!
          My jetway's audio has failed and I had to use a PCI sound card


          • #6
            Thanks. I liked your idea of using the optical signal to power up the radio receiver. i am planning to use fusion brain for the amplifier control since Realtek ALC883 7.1 Channel HD Audio with S/PDIF gives a small pop sound during startup of windows.


            • #7
              Two of my 5 channel amplifiers packed up after some days of operating in 5.1 mode. (center channel is not in use). Didn't have any issue with stereo operation. so my older amplifier kenwood KACX650D is back after repair in stereo mode as of now, till i get the blaupunkt back.
              Attached Files