Announcement

Collapse
No announcement yet.

2006 Scion tC Laptop Install

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • 2006 Scion tC Laptop Install

    Well this will begin the start of my adventure. I've learned a lot from the many users on this community and now armed with that knowledge we begin this crazy ride.

    The list thus far includes
    - Dell Insporon 5100 laptop (P4 2.2ghz, 256mb ram) (FREE)
    - Linksys Wireless N PCMCIA card ($108)
    - Eclipse CD4000 HeadUnit ($268)
    - Carnetix P1900 ($110)

    Still debating on either the Xenarz 700idt or DWW-700H

    Once all the parts finally arrive I'll be figuring out how exactly I'll be handeling startup/shutdown as the finer points of electronics I am a bit ignorant with.

    Pictures of all the goodies to come!

    Also, I'd like to thank those who have fielded questions thus far, and inevitably those to answer them as I progress....

    Here's to a new beginning....
    Current Rig
    ----------
    Inspiron 5100 Laptop
    *2.2 Ghz CPU
    *368 MB Ram
    *32meg OnBoard Vid
    Carnetix 1900 PSU
    BU-353 GPS Antenna
    iGuidence Nav Software / Mappoint for POI's
    Linksys USB WiFi
    D-Link USB Bluetooth 2.0
    Xenarc 700IDT
    Eclipse CD4000 HU

  • #2
    Just wanted to update everyone - Ended up going with the 700IDT because a forum member here sold it new for a great price. All in all, the install is going really well.

    The big problem right now it cramming the Eclipse CD4000 and the Xenarc 700IDT into the double din opening in my tC. I have filed my OEM brackets so the little mounting nubs are gon, thus allowing the TouchScreen to actually fit with minimal bowing to the OEM Din brackets (its a -tight- fit).

    While it fits in there, it pokes out far enough that I just can.t seem to get the plastic face of my dash to go back on. I believe the suspect is that whether mounted on top or bottom, it is still bumping somewhere. I also think that I may have to remove the door which closes over the DblDin hole (not a big deal)

    Anyone have any experiance with this especially if you have a tC? For now, I'm going to try and modify the very flimsey plastic din Crutchfield supplied with the HU and maybe give me more options.

    and a final thought, the 2 metal 'U' pieces sticking out the back of the Xenarch TS, do they do anything? Can they be removed so I can get more depth?
    Current Rig
    ----------
    Inspiron 5100 Laptop
    *2.2 Ghz CPU
    *368 MB Ram
    *32meg OnBoard Vid
    Carnetix 1900 PSU
    BU-353 GPS Antenna
    iGuidence Nav Software / Mappoint for POI's
    Linksys USB WiFi
    D-Link USB Bluetooth 2.0
    Xenarc 700IDT
    Eclipse CD4000 HU

    Comment


    • #3
      Well to answer a few of my own questions. The metal u shaped brackets at the rear of the 700IDT can be easily removed. This is done by remove the 5 screws (3 on one side, 2 on the other) at the back of the unit which basically holds on a rear face plate which acts as the brace for spring function of this touchscreen. So be prepared to catch it when the last screw comes out. At that point, the brackets have two simple nuts to unscrew.

      I also figured out how to get this to fit in the 2x din area. I simply removed the folding door from the HVAC plastic housing which invilved 2 screws. Then bam, instant room. To make this look nice I'll need to make a new bezel (fiberglass) to make it look nice and not have large gaps!

      My issue now is that with the monitor plugged into the back of the 700IDT pushes it out pretty damm far. I wonder if I can get a 'L' shaped adaptor and gain those 2" back or if it is just gonna have to stick out?

      Also, and here is a kicker, Crutchfield is worthless? I have not decided yet. The steering wheel control box I bought from them lists at least 10 different automakers that it is compatable with. None of them are Toyota or Scion! So, fortunately, we found a tech article on Scionlife which showed us what wires to tap into to get my SWC (Steering Wheel Controls) to work. Accept one glitch. The 'Mode' button on my SWC's works -sometimes-. As in, sometimes it works intermittantly, sometimes often, but mostly just not at all

      Final set of updates: We (my buddy the electrician) tapped into my laptop's power switch in prep to hook it up to the Carnetix Intelligent PSU. The connection works like a charm, the drivers for the 700IDT worked, and last night we watched a couple videos!!!!!

      So, what I now need to do is decide where I am gonna mount my Carnetix PSU and laptop. Under the drivers seat is too little room (I'm tall and have the height cranked down to fit). We considered under the passenger seat, but i fear the wrath of spilled drinks and snow turning to water from shoes. I also considered the trunk, but then we start getting into long USB cabling and that makes me nervous as well. So, I -think- what I may end up doing is this: mount it under a false floor on the passenger floor on the drivers side. That way its easily accessable for repair/removal, no need for lenghty cabling, and i -rarely- have someone in the back seat. its just too small for a adult to fit comfortabally for more than a 15-20 minute ride.

      Thats it for now. Any comments or ideas?
      Current Rig
      ----------
      Inspiron 5100 Laptop
      *2.2 Ghz CPU
      *368 MB Ram
      *32meg OnBoard Vid
      Carnetix 1900 PSU
      BU-353 GPS Antenna
      iGuidence Nav Software / Mappoint for POI's
      Linksys USB WiFi
      D-Link USB Bluetooth 2.0
      Xenarc 700IDT
      Eclipse CD4000 HU

      Comment


      • #4
        Another update: Pictures on the way!
        I got everything working (for the most part) and up and running. My main issue right now is getting RoadRunner config'd so my touch screen will let me 'get out' of movies. for some reason i can't get this to work, so when i start a movie i gotta screw with the laptop itself in order to get back tom the front end on my touchscreen. this might be a simple config problem but its all new to me so I am somewhat lost.

        Again, thanks to everyone who has paved the way before me.
        Current Rig
        ----------
        Inspiron 5100 Laptop
        *2.2 Ghz CPU
        *368 MB Ram
        *32meg OnBoard Vid
        Carnetix 1900 PSU
        BU-353 GPS Antenna
        iGuidence Nav Software / Mappoint for POI's
        Linksys USB WiFi
        D-Link USB Bluetooth 2.0
        Xenarc 700IDT
        Eclipse CD4000 HU

        Comment


        • #5
          can't wait for some pics!

          Comment


          • #6
            Well, tomorrow we finish the install and I'll post pics of the aftermath. I tweaked the Brushed Aluminum skin from the original RR install to add a little personal touch. Its my first attempt at changing a skin. Super excited.
            Current Rig
            ----------
            Inspiron 5100 Laptop
            *2.2 Ghz CPU
            *368 MB Ram
            *32meg OnBoard Vid
            Carnetix 1900 PSU
            BU-353 GPS Antenna
            iGuidence Nav Software / Mappoint for POI's
            Linksys USB WiFi
            D-Link USB Bluetooth 2.0
            Xenarc 700IDT
            Eclipse CD4000 HU

            Comment


            • #7
              So, we finished the PSU (Carnetix) wiring Friday. Works like a champ and is even better than i imagined. The Carnetix is just REALLY good for us laptop installs, or I would think anything needing the 18v,19v, or 20v primary rail.


              Here is the (slightly) modified Roadrunner front end. I love it, but it won't be a permanent skin.

              The problem, as you can see by the yellows arrows and squiggles, is can i get the display to fit the ENTIRE area of my touchscreen? (laptop is set to 800x600 which the touchscreen auto-recognizes)







              This, is my primary sticking point.....
              Current Rig
              ----------
              Inspiron 5100 Laptop
              *2.2 Ghz CPU
              *368 MB Ram
              *32meg OnBoard Vid
              Carnetix 1900 PSU
              BU-353 GPS Antenna
              iGuidence Nav Software / Mappoint for POI's
              Linksys USB WiFi
              D-Link USB Bluetooth 2.0
              Xenarc 700IDT
              Eclipse CD4000 HU

              Comment


              • #8
                Someone asked about my power setup so I figure this would be a good place to post it for everyone to see.....

                Originally posted by ephyouckay
                dude.. so u didnt open up your laptop to install the p1900? dont u have to solder to the power button so the pc can turn on and off? what do you mean u just hooked the brick up to the p1900? how does it turn the pc on ?
                okay, I got some pictures for you. Here is my setup exposed so you can see everything:



                Getting the "on/off" effect from the Power Button

                You can see that I have a relay involved, which is basically a electromechanical switch. When I turn the car on, the PSU gets power. A power spike for lack of a better term is sent via a wire to the relay causing it to trip. When it does, it simulates pressing the laptops power button. Same thing happens when I turn the car off. Relay trips, power button is pushed via the relay.

                The black and white wires running from the relay to the male/female connectors, then into the laptop connect to the + and - on the power button.

                Getting Power to the laptop without a direct solder

                You can also see from the pictures that I hacked the end of my power cord off and put on male/female connectors to the + and - wires. This allows me 2 things. No soldering power wires onto mobo. Easily removing laptop from car for normal use.

                I have another set of male/female connectors to the + and - power line coming from the PSU to the hacked-off end of my power cable. If this needs more explaining let me know but that part is pretty straight forward.

                Auto on/off
                Between the intelligent power supply's many different settings, and Windows XP power management settings, you should have no problems setting things up.

                NOTE: I ran into this little tricky dick. There is a magnet in the laptop lid that, when within range of a magnet in the laptop base, causes the laptop to turn off/hibernate. Removing this magnet will allow for you to close your laptop lid and keep the laptop on. Otherwise, you have to roll around town with your laptop open which defeats the whole purpose of a carputer install.

                Hope that helps.





                Current Rig
                ----------
                Inspiron 5100 Laptop
                *2.2 Ghz CPU
                *368 MB Ram
                *32meg OnBoard Vid
                Carnetix 1900 PSU
                BU-353 GPS Antenna
                iGuidence Nav Software / Mappoint for POI's
                Linksys USB WiFi
                D-Link USB Bluetooth 2.0
                Xenarc 700IDT
                Eclipse CD4000 HU

                Comment


                • #9
                  nice work. I'm about to get started on my tC project with a Acer AP1000 (desktop with laptop Mother board). I'd imagine the setup for the power will be somewhat similar.

                  Comment


                  • #10
                    Originally posted by Serialk1llr View Post
                    Someone asked about my power setup so I figure this would be a good place to post it for everyone to see.....



                    okay, I got some pictures for you. Here is my setup exposed so you can see everything:



                    Getting the "on/off" effect from the Power Button

                    You can see that I have a relay involved, which is basically a electromechanical switch. When I turn the car on, the PSU gets power. A power spike for lack of a better term is sent via a wire to the relay causing it to trip. When it does, it simulates pressing the laptops power button. Same thing happens when I turn the car off. Relay trips, power button is pushed via the relay.

                    The black and white wires running from the relay to the male/female connectors, then into the laptop connect to the + and - on the power button.

                    Getting Power to the laptop without a direct solder

                    You can also see from the pictures that I hacked the end of my power cord off and put on male/female connectors to the + and - wires. This allows me 2 things. No soldering power wires onto mobo. Easily removing laptop from car for normal use.

                    I have another set of male/female connectors to the + and - power line coming from the PSU to the hacked-off end of my power cable. If this needs more explaining let me know but that part is pretty straight forward.

                    Auto on/off
                    Between the intelligent power supply's many different settings, and Windows XP power management settings, you should have no problems setting things up.

                    NOTE: I ran into this little tricky dick. There is a magnet in the laptop lid that, when within range of a magnet in the laptop base, causes the laptop to turn off/hibernate. Removing this magnet will allow for you to close your laptop lid and keep the laptop on. Otherwise, you have to roll around town with your laptop open which defeats the whole purpose of a carputer install.

                    Hope that helps.






                    I kinda wonder if you went a little overboard on the power situation.

                    The magnetic switch issue could be fixed with a bios update and I think the leads to the power switch still had to be soldered on didn't they?

                    I have the same laptop in the accord and just used the 120w adapter from kensinton, plus w3bmstrs auto on and it works like butter. Just some thoughts for anyone else.
                    Mike M
                    2006 Accord VP Sedan

                    My worklog
                    http://www.mp3car.com/vbulletin/work...-dads-car.html

                    Comment


                    • #11
                      it is quite possible there was an easier way to approach this. Unfortunately, our collective know how (me and my buddy) did what we could knowing what we did. Do you have a work log I can spy? or maybe you can break down what you did in detail?

                      Are you able to easily remove your lappy to use it as normal?

                      -Serialk1llr
                      Current Rig
                      ----------
                      Inspiron 5100 Laptop
                      *2.2 Ghz CPU
                      *368 MB Ram
                      *32meg OnBoard Vid
                      Carnetix 1900 PSU
                      BU-353 GPS Antenna
                      iGuidence Nav Software / Mappoint for POI's
                      Linksys USB WiFi
                      D-Link USB Bluetooth 2.0
                      Xenarc 700IDT
                      Eclipse CD4000 HU

                      Comment


                      • #12
                        yeah, that was my main goal to be able to pull it out to work on it or make any changes needed too. My worklog is linked below, but it doest have what you are looking for. Ill try to get that up for you. I respect what you guys did. Its pretty impressive, so don't let me be a critic.

                        My setup requires a few connections to be connected too. There are
                        1 usb to a hub
                        1 monitor cable
                        1 audio 3.5mm jack
                        1 mono jack which connects the laptop to the auto power module.


                        I think that mono jack is one awesome idea that they had to allow quick and decent looking
                        Mike M
                        2006 Accord VP Sedan

                        My worklog
                        http://www.mp3car.com/vbulletin/work...-dads-car.html

                        Comment


                        • #13
                          question for ya, I'm about to start my install but wanted to talk with a tC installer first. I've never worked on car wiring before and am worride I'll screw somethign up completely. I was wondering if you have any pictures of how you wired the carnetic to the battery and ignition. I'm hoping to get started on the install this weekend. THanks for the help.

                          Comment


                          • #14
                            The carnetix psu is spliced into an 8g wire running from my battery to my amp/sub in my hatch area. I ran that wire along the drivers side and was thus easily accessible under the plastic door trim in the cabin (right next to the seat)

                            as far as wiring into the ignition, you'll have to get a wiring diagram for the stereo. I believe there is a wire in that cluster-plug that is specifically linked to the ignition can easily be spliced into behind the stereo (see scionlife.com on how to remove the plastic HVAC cover to get to the stereo, etc)

                            If you've never worked on cars, but more importantly electric stuff, you might want to get a friend who has done this. If you fux up the car electronics you may have a serious gremlin problem later on.

                            I happen to have a buddy who is an electrician who helped me with this part.

                            Best of luck, and post up some pics when you're done!
                            Current Rig
                            ----------
                            Inspiron 5100 Laptop
                            *2.2 Ghz CPU
                            *368 MB Ram
                            *32meg OnBoard Vid
                            Carnetix 1900 PSU
                            BU-353 GPS Antenna
                            iGuidence Nav Software / Mappoint for POI's
                            Linksys USB WiFi
                            D-Link USB Bluetooth 2.0
                            Xenarc 700IDT
                            Eclipse CD4000 HU

                            Comment


                            • #15
                              wow what perfect time to come upon this post as i install my carnetix 1900 and my dell 600m over this weekend. your power supply setup is interesting. im not exactly sure whats going on can you re-explain it in MUCH MUCH simpler terms so maybe i can mimic it? did that relay come with the psu?

                              Comment

                              Working...
                              X