No announcement yet.

USB Audio CODEC not listed in Recording Line In Devices

This topic is closed.
  • Filter
  • Time
  • Show
Clear All
new posts

  • USB Audio CODEC not listed in Recording Line In Devices

    I apologize up front for the length of this post.

    I need some assistance/guidance. I am currently working on getting my HDRadio to work with Centrafuse 2.x. I am running Win XP SP3 on a Intel DG45FC (onboard audio disabled) with a SB X-Fi 5.1 USB sound card.

    I read the installation instructions to reassign the Sound Playback under the Sound and Audio Devices Props -> Audio Tab. The device is set to the X-Fi as the Default Device for Sound Playback. In looking at the Sound Recording Device, USB Audio Codec, SB X-Fi What U Hear and SB X-Fi Line/Mic-In are listed.

    I setup the HDRadio application and it works without any major issues.

    I ran the Centrafuse 2 Radio Module HDRadio Update. I installed it in the default location.

    When I try to install the HDRadio in Centrafuse 2, I enter the Advanced Setting menu and click HD Radio, Buffer On, and None for Playback device. When I go to select the Record In device, I get three options: None, X-Fi Line/Mic-In and X-Fi What U Hear. There is no USB Audio Codec listed as an option.

    First question, should the USB Audio Codec item be listed as a selection in the Centrafuse AM/FM Radio (w/ Advanced Settings) Recording Line In based on the steps/description of settings listed above? If not, what steps have I missed?

    Second question, is what I have described the XP-enumeration issue where I need to change the RADIOLINEIN to get the device to HDRadio? (I think the answer is no, for now and this is a later step, but I ask it anyways.)

    Assuming that I have not missed any steps, I have worked on trouble shooting why the USB Audio Codec is listed as an option in the Audio Tab and in the HDRadio app, but not in the Centrafuse AM/FM Radio (w/ Advanced Settings) Recording Line In.

    In looking at the Playback Line In list, I see several selections including None, several SB X-Fi (speaker, wave, MIDI, CD, etc) and several USB Audio (wave, CD, MIDI, etc).

    In checking Device Manager, I see the "MJS Gadgets ..." under ports. When I look under Sound, video ... I see a Audio Device item and when clicked, it lists USB Audio CODEC in parenthesis. I have tried uninstall/reinstall the device with no change in Centrafuse Record In device list. I have tried updating the driver, but XP says its the latest. I have tried connecting to different USB ports, still no luck in the USB Audio Codec showing up.

    Third question, based on the description I have given for Device Manager, am I missing any items that would be needed for Centrafuse to "see" the USB Audio Codec device?

    Fourth question, is there an xml-file or config file that maintains a list of devices that can be configured and feeds the Centrafuse program its device lists?

    Fifth question, is there a K.I.S.S. solution that I am missing?

    Again, sorry for the length and if I do not have the precise names for all of the settings. Please let me know if you need any additional info to arrive at a possible solution. Thanks in advance for your help.

  • #2
    its a BUG in CF2 on XP systems!!!
    plain and simple...

    you will have to edit, that config.xml file like i explained in the other post...

    its usually a 1

    so just edit the setting

    heck its even a issue in cf3 on XP

    "Did you test it in carwings??"

    Sun, Come shine my way
    May healing waters bury all my pain
    Wind, Carry me home
    The fabric of reality is tearing apart
    The piece of me that died
    Will return To live again