Announcement

Collapse
No announcement yet.

Can't switch between Sirius and HD Radio in CF 3.1

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Can't switch between Sirius and HD Radio in CF 3.1

    I have mitchjs's sirius interface and a boomzbox configured to work in CF 3.1. I assigned the recording line-in for sirius to be the line-in port of my sound card and the recording line-in for am/fm to be the recording device created with the boomzbox drivers. Everything works great if I only ever play one or the other, but if I try to switch between sirius and radio, things go belly up. For example, if I am playing sirius and then switch into radio, the scrolling text seems to indicate that it's locked on a station, but Sirius continues to play. If at that point, I close centrafuse and restart it, the radio station I selected begins playing at startup. Now if I go into Sirius and select a station, the radio stops playing, but it doesn't pick up sirius. If I close at that point and restart centrafuse, sirius beings playing immediately.

    I submitted this to CF support and they think it's a problem on the boomzbox side.

  • #2
    i set up a sc-c1 and boomzbox hd...

    NO issues switvhing back and fourth...

    you need to define "playing"

    i did notice, CF doesnt set the mute on Sirius when going to radio...
    one thing for sure... in the radio settings, you SHOULD NOT have a PLAYBACK line SET!!!
    only the RECORD, and since CF doesnt enumerate Audio devices correctly you cant select that in XP...and have to use the external program


    sounds like you are using the word "playing" to mean i still hear it...

    double check your audio settings!!!
    which is really hard cause of issues with CF, i have pointed this out to them years ago!
    -Thanks
    Mitch
    www.rush2112.net

    "Did you test it in carwings??"

    Sun, Come shine my way
    May healing waters bury all my pain
    Wind, Carry me home
    The fabric of reality is tearing apart
    The piece of me that died
    Will return To live again

    Comment


    • #3
      since you imply buffered audio with sat... make sure the SAT PLAYBACK line is set to none

      and hopefully CF mutes it...
      i cant set that up 100% (long story), but i do know they dont PROPERLLY mute SAT, when its not inuse
      -Thanks
      Mitch
      www.rush2112.net

      "Did you test it in carwings??"

      Sun, Come shine my way
      May healing waters bury all my pain
      Wind, Carry me home
      The fabric of reality is tearing apart
      The piece of me that died
      Will return To live again

      Comment


      • #4
        i just messed with CF in xp, very much an issue with setting of the devices
        in Win7, no issue

        now... at least we can set the device manually with editing of files

        the winmixer.log file helps!
        located at: C:\Documents and Settings\All Users\Application Data\Centrafuse\Centrafuse Auto\mitchjs\MixerModules\Windows
        -Thanks
        Mitch
        www.rush2112.net

        "Did you test it in carwings??"

        Sun, Come shine my way
        May healing waters bury all my pain
        Wind, Carry me home
        The fabric of reality is tearing apart
        The piece of me that died
        Will return To live again

        Comment


        • #5
          Sorry, this is Windows 7 x64. For both radio and satellite settings, only the recording device is set. Playback is set to none for both. Buffering is also set for both.

          Yes, by playing I mean hear it. If I'm in Sirius and switch to HD Radio, I ONLY hear Sirius. CF updates to show the station, but the only sound is from Sirius. If I'm in HD Radio and switch into Sirius, the HD Radio device mutes, but Sirius never starts playing.

          Comment


          • #6
            ah, at least we on the same OS

            i have no issues

            maybe they not switching thier internal audio souce...
            for buffered audio...
            i cant set up sirius as buffered audio, do to cable limitations, in a few days that will change
            or maybe your input is muted and they not unmuting it... you can check in recording devices...

            for sure not any issue with Boomzbox HD itself



            not to mention, what version of CF? v3.1.
            -Thanks
            Mitch
            www.rush2112.net

            "Did you test it in carwings??"

            Sun, Come shine my way
            May healing waters bury all my pain
            Wind, Carry me home
            The fabric of reality is tearing apart
            The piece of me that died
            Will return To live again

            Comment


            • #7
              like i said, reviewing the mixer log...

              Code:
              Switching to Sirius:
              
              19:45:72> RecordLine(): inputdevice = 1, name = HD Radio (USB Audio CODEC ), selected = False
              19:45:92> SetMasterVolume(): device = -1, volume = 23593, vctrl = CFVOL_VOLUME
              19:47:83> RecordLine(): inputdevice = 0, name = Line In (Realtek High Definition Audio), selected = True
              
              Switching to HD Radio:
              
              20:14:76> RecordLine(): inputdevice = 0, name = Line In (Realtek High Definition Audio), selected = True
              20:14:97> SetMasterVolume(): device = -1, volume = 20971, vctrl = CFVOL_VOLUME
              20:15:00> RecordLine(): inputdevice = 1, name = HD Radio (USB Audio CODEC ), selected = True
              both set up as record inputs, buffered audio...
              clealy you can see its setting one to false, and one to true
              -Thanks
              Mitch
              www.rush2112.net

              "Did you test it in carwings??"

              Sun, Come shine my way
              May healing waters bury all my pain
              Wind, Carry me home
              The fabric of reality is tearing apart
              The piece of me that died
              Will return To live again

              Comment


              • #8
                Here is a snippet from an abnormal execution. Here I exited while Sirius was playing and restarted:

                Code:
                ------------------->SIRIUS GOOD
                ------------------->EXITING
                
                58:54:38> RecordLine(): inputdevice = 1, name = Line In (Auzen X-Meridian 7.1), selected = True
                ************************************************************************************************************
                10/13/2010 7:59:06 PM
                59:06:47> LoadMixers(): startup
                ************************************************************************************************************
                59:06:47> LoadMixers(): Vista = True
                59:06:49> LoadMixers(): Vista default audio endpoint: Speakers (Auzen X-Meridian 7.1)(ID {0.0.0.00000000}.{1a268290-9a68-4b6d-be6a-ed510b11cae9})
                59:06:50> LoadMixers(): MinDB=-96, MaxDB=0
                59:06:51> LoadMixers(): Current Balance = 0
                59:13:58> RecordLine(): inputdevice = 1, name = Line In (Auzen X-Meridian 7.1), selected = True
                
                ------------------->SIRIUS GOOD
                ------------------->SWITCHING TO HD RADIO
                
                00:06:09> RecordLine(): inputdevice = 1, name = Line In (Auzen X-Meridian 7.1), selected = True
                00:11:82> SetMasterVolume(): device = -1, volume = 16535, vctrl = CFVOL_VOLUME
                00:12:32> RecordLine(): inputdevice = 4, name = HD Radio (4- USB Audio CODEC ), selected = True
                
                ------------------->SIRIUS STILL PLAYING - BOTH RECORDING DEVICES SHOW ACTIVITY


                The above clearly looks like a problem with centrafuse since it set both sirius and hd radio to true when going from sirius to hd radio. This next example isn't quite asclear.

                Here is another example, where I exit after HD Radio is active, but there is no sound. After starting up with HD Radio playing, I switch to Sirius and there was no sound. I switch to the media library and centrafuse started playing a mp3. Then switching back and forth between the two worked. However, I exit with either HD Radio or Sirius active and start back up, I'm still not able to bounce between them.

                Code:
                ------------------->HD RADIO SELECTED BUT NOT PLAYING
                ------------------->EXITING
                
                ************************************************************************************************************
                52:34:93> LoadMixers(): startup
                ************************************************************************************************************
                52:34:93> LoadMixers(): Vista = True
                52:34:96> LoadMixers(): Vista default audio endpoint: Speakers (Auzen X-Meridian 7.1)(ID {0.0.0.00000000}.{1a268290-9a68-4b6d-be6a-ed510b11cae9})
                52:34:97> LoadMixers(): MinDB=-96, MaxDB=0
                52:34:98> LoadMixers(): Current Balance = 0
                52:48:25> SetMasterVolume(): device = -1, volume = 16535, vctrl = CFVOL_VOLUME
                52:49:00> RecordLine(): inputdevice = 4, name = HD Radio (4- USB Audio CODEC ), selected = True
                
                ------------------->HD RADIO GOOD
                ------------------->SWITCH TO SIRIUS
                
                53:04:36> RecordLine(): inputdevice = 4, name = HD Radio (4- USB Audio CODEC ), selected = False
                53:05:72> RecordLine(): inputdevice = 1, name = Line In (Auzen X-Meridian 7.1), selected = True
                
                ------------------->UGH NO SOUND
                ------------------->SWITCH TO MEDIA LIBRARY
                
                55:16:29> RecordLine(): inputdevice = 1, name = Line In (Auzen X-Meridian 7.1), selected = True
                
                ------------------->SOUND!
                ------------------->BACK TO HD RADIO
                
                57:06:99> SetMasterVolume(): device = -1, volume = 16535, vctrl = CFVOL_VOLUME
                57:07:09> RecordLine(): inputdevice = 4, name = HD Radio (4- USB Audio CODEC ), selected = True
                
                ------------------->HD RADIO GOOD
                ------------------->BACK TO SIRIUS
                
                57:58:27> RecordLine(): inputdevice = 4, name = HD Radio (4- USB Audio CODEC ), selected = False
                57:59:15> RecordLine(): inputdevice = 1, name = Line In (Auzen X-Meridian 7.1), selected = True
                
                ------------------->SIRIUS GOOD
                ------------------->EXITING

                Comment


                • #9
                  yes.. i would forward all this info to CF team
                  -Thanks
                  Mitch
                  www.rush2112.net

                  "Did you test it in carwings??"

                  Sun, Come shine my way
                  May healing waters bury all my pain
                  Wind, Carry me home
                  The fabric of reality is tearing apart
                  The piece of me that died
                  Will return To live again

                  Comment

                  Working...
                  X