No announcement yet.

Help required with Infill T3 - power up

  • Filter
  • Time
  • Show
Clear All
new posts

  • Help required with Infill T3 - power up

    Hi everyone,

    I've just acquired a secondhand Infill T3 and am having trouble getting it to fire up on a Molex supply.

    I have to 'fiddle', plugging and unplugging the 2 unit's power cables and the large black connector that links the units whilst pushing the PC unit's power button. Every once in a while I get lucky and it starts - I then plug in the screen and it opens to show the normal boot screen however the hard drive is not being found. I've tried swapping with a spare 40Gb HDD and still no luck.

    Is this a problem with not enough power getting to the unit or something else?

    I notice the fan on the back of the PC unit is running when the ignition wire is connected without the unit actually being on.

    Also, I sometimes get continuous flashing LEDs on the PC unit?

    The PSU is rated at 30A on the 12v rail and is 550W but a voltage tester shows 11.44volts.

    Unfortunately I don't have any instructions apart from a wiring install I found on the 'net.

    Any help would be very welcome!!



  • #2
    Ok, have now got the T3 to power up... sometimes!

    I've found 2 of the FFC cables (very thin ribbons) to be damaged.

    One was an IDE connector - now have HDD but no optical drive.

    The other is the connector cable from the PC unit to the front panel - this is the one causing most problems as it seems to have some control over the power up process.

    Can I by these cables as spares from anywhere??

    Please help!!


    • #3
      Fixed it!

      Cannot believe I've managed to get it all up and running.

      I sourced some 0.5mm pitch 50 pin FFC cables from and they arrived in the UK in 5 days.

      Bought 3 different lengths and had to modify the width (no of pin outs) for the front panel and motherboard to fixed front cable but was quite easy.

      Now have a fully working T3 and am very pleased.


      • #4
        Now have sourced the cables and the machine works 100%.