Announcement

Collapse
No announcement yet.

G4 and screen flicker?

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • G4 and screen flicker?

    Well, after such a long time, I've finally gotten around to actually installing the G4 in the truck. I had to do a lot of dash trimming to make it fit, but it goes in now without problem.

    My issue now is that it flickers when plugged into the factory harness. No issues on the test bench--even removed it and brought it back in to make sure I didn't stress the wiring too much and short something. No problems at all. Annoying flicker when plugged in.

    I searched around for some troubleshooting tips, but I didn't see anything posted that seemed to solve anyone's problems. Any ideas on how to best start isolating this problem?

    Thx,
    Rip

  • #2
    Unhook the illumination wire and see if it solves the problem. The illumination wire can't have varying voltage, just on or off. I am pretty sure that will fix your problem. You can use a relay instead of directly connecting to the factory illumination wire to fix it.

    Comment


    • #3
      The wiring kit for my 2007 Saturn VUE (GMOS-LAN-06) has both an illumination (orange wire) and a dimmer (orange/white). Which one should I connect if I want to avoid this flicker issue myself. I haven't installed it yet, just mapping out what all the wires need to be connected to.
      Attached Files
      _______________________________________________
      All installed, and ready for visitors. Infill G4 in a 2007 Saturn VUE

      Comment


      • #4
        IandI, you're onto something there.

        I figured out a few things. Just an FYI in case anyone else has this problem.

        As long as it's set for daytime, there's no flicker problem. When it adjusts for night, it flickers when there's any dimming at all. If I adjust the interior dash lights to full (which I never drive with on full), then the flicker stops.

        However, if I adjust the screen brightness settings so that ultimately there's no real switching of the G4 from daylight to night modes, of course, there's no flicker.

        Hope that helps someone out there...

        Rip

        Comment


        • #5
          had the same problem.

          Just wired a relay in place so when lights are on the G4 has a full power source.
          www.ssw.com.au

          Comment


          • #6
            Now what would be very cools is have the backlight of the g4 dimmable based on that varying g4 voltage. Somehow I doubt this is a standard voltage range, but none the less this could be an interesting idea to incorporate.

            Comment


            • #7
              Originally posted by Fiberoptic View Post
              Now what would be very cools is have the backlight of the g4 dimmable based on that varying g4 voltage. Somehow I doubt this is a standard voltage range, but none the less this could be an interesting idea to incorporate.
              That would be sweet. Even on the darkest setting, the G4 is still a bit bright for me at night.

              I may have to try the relay thing... No matter what I do, the Nav maps flash with the illumination wire connected.

              --Rip

              Comment

              Working...
              X