No announcement yet.

'Could not connect to the GPS on COM 1' error message at launch

  • Filter
  • Time
  • Show
Clear All
new posts

  • 'Could not connect to the GPS on COM 1' error message at launch

    I just started getting the following error message when SD launches on my new G4:

    'Could not connect to the GPS on COM 1.'

    I am currently running the G4 inside my home off a PC power supply, while I get everything working before having it installed in my car. The GPS antenna is securely connected, but I'm guessing that wouldn't even matter.

    The GPS was working until an hour ago today, shortly after I installed the X10 drivers ( for the VA11A composite_video-to-USB adapter that I just bought (so that I can always have the rearview camera on, by splitting the signal from the backup camera and feeding it to both the USB adapter and the G4's backup camera video input).

    Though I don't think the video-to-USB adapter is likely at fault anyway, because I'm pretty sure I launched SD at least a couple of times with no GPS error after installing the X10 driver. But without restoring Windows to an earlier backup, I can't tell for sure because the X10 uninstaller won't launch (gives a "Can't find install.log" error, which also happens when I tried on another non-G4 PC). Unplugging the X10 adapter and rebooting doesn't help.

    (I get the same error when I switch to COM2 in the G4's GPS Settings), though of course it says COM 2 in that case.)

    Is there some kind of diagnostic I can run to see what the problem might be? I have to figure this out soon because I am planning to get my G4 installed in my car this week.

  • #2
    G4 GPS issues

    I just got my G4 installed and couldn't get my gps receiver to work either. Only mine hasen't worked at all. When I try to use the option to "detect" the receiver I get the error message:

    " A valid device could not be found on any of the COM ports! Please try selecting the proper COM port manually."

    I looked through the manuals for the G4 and Streetdeck and couldn't find anything relevent. Someone posted something about changing the baud rate to 9600 for their gps receiver to work with Streetdeck but it wasn't related to the G4. Can anyone offer any input on this?


    • #3
      Unfortunately for me, decided to turn off the System Restore feature, so I'm going to have to completely restore the whole C: drive, instead of just spending 5 minutes to undo the X10 driver changes.

      MP3Car guys, you need to turn that feature back on by default.


      • #4
        I recently had those same exact problems with my G4 and found that the antenna shipped with the G4 was causing the problem. The GPS worked for a day after I installed the G4 and then got no signal for a while and then no GPS message. I thought I had cut the antenna wire or the plug got messed up in the rear, but it was neither. I installed another similar looking GPS antenna and everything was fine.


        • #5
          It's definitely the software (mangled OS drivers from the X10 camera installer, I assume), as I restored a backup I had made on my first G4 and that made it work.

          I'm really mad at myself that I didn't already backup the new G4 (I could have sworn I had done it), but I'm also made that didn't have System Restore enabled by default, which would have fixed it (which it did on another PC I tested the X10 drivers on - on that PC, the X10 drivers disabled access to my optical drives, sound card, and other hardware).

          Now I'm just gonna have to start over with a new Windows install and spend a lot more hours reconfiguring everything.