Announcement

Collapse
No announcement yet.

Real solution to G4 GPS being detected by Windows as crazy serial mouse?

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Real solution to G4 GPS being detected by Windows as crazy serial mouse?

    Has anyone else had their G4's GPS go haywire?

    A few weeks ago, my GPS spontaneously started being detected by Windows as a serial mouse. The mouse goes around the screen extremely fast and clicking everywhere (causes massive mayhem and makes the system completely unusable). The problem even occurs during Windows XP/Vista setup (the only time it doesn't happen is Safe Mode). It happens even if nothing is plugged in, including the GPS antenna (no connections other than power). After finally figuring out that it was being detected as a serial mouse (by turning off COM ports in the BIOS), I found a number of supposed solutions on the Internet. None of them helped:
    • Adding /noserialmice or /noserialmouse in c:\boot.ini (no effect).
    • Disabling the "serial mouse" in the device manager (stops the spastic mouse, but the GPS is not detected by Streetdeck or Centrafuse).
    • Disabling serial mouse detection by setting SkipEnumerations=FFFFFFFE in the registry under [HKLM\SYSTEM\CurrentControlSet\Enum\ACPI\PNP0501\Po rt#\Device Parameters] (stops the spastic mouse, but the GPS is not detected by Streetdeck or Centrafuse).
    At this point I have just disabled COM1 in the BIOS, and of course have no GPS capability. I am planning on buying a USB GPS, but have several questions:
    1. Has anyone else had this problem with the G4? If so, did you find a real solution to keep using the integrated GPS?
    2. Is there any way to keep using my existing GPS antenna? I'm thinking of a device that would accept my GPS antenna and then plug into a USB port. It just seems like a waste to throw out my current GPS antenna (and maybe worse, to have to rewire the new antenna).
    3. If I have to buy a USB GPS, are there any recommendations?
    Thanks,
    John

  • #2
    Are you using XPort. If so, it is reported:

    "Cursor sometimes jumps all over the screen clicking left/right? Here's the fix: Open Regedit. Navigate to HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Servic es\SerMouse, and change the value "Start" from 3 to 4. Reboot."

    http://curioustech.home.insightbb.com/xport.html

    Comment


    • #3
      Thanks, but I'm not using XPort (or any other com port splitter).

      I got a USB GPS working (GlobalSat BU-353), but it kind of sucks because it takes about 2 minutes for it to initialize (at least by Centrafuse) after resuming the PC from a suspend state (my original one on a real COM port worked immediately).

      Comment


      • #4
        I've to agree GlobalSat BU-353 took longer to initialised on my previous Hi-info N5 than the built-in gps with G4 which is pretty fast (if it resumes properly in my case . Not only that, Garmin nRoute and Mapking coordinates does not refresh fast enough to accomodate normal driving speed with GlobalSat BU-353 while G4 built-in GPS feeds Garmin Mobile PC almost instantaneously. Obviously it makes sense to stick to the built-in rather than the GlobalSat BU-353.

        I did encounter similar symptom as yours only once though after I recently updated XPort to the latest version. My first initial reaction was to check if the keyboard I stashed in the glove compartment was being accidently pressed but what appeared to be random clicks continue until I rebooted and have no such occurance since without further intervention nor did I need to do the fix I posted.

        Perhaps we may be able to offer some clues to help each other problems since yours resume fine while mine did not suddenly decide to become a mouse except once.

        Does your G4 shutdown itself when battery charge is low and does the GPS works after that? Or does the GPS resume from hibernation if you choose to hibernate?

        Comment


        • #5
          My G4 shuts itself down after 12-15 hours in standby, which I think is earlier than it used to (even with a new battery). So just like you mentioned in your other thread, I try to remember to put it in hibernate on the weekend to avoid data loss. I don't think XP has a way of transitioning to hibernate like you asked; that is one feature of Vista I would really like (Sleep mode in Vista is like Standby, but it also makes a hibernation file so that it can resume from hibernation if power is lost).

          But I do not ever remember the built-in GPS failing to initialize after resuming from the suspend state (standby or hibernate).

          I've found that while sometimes it only takes about 20 seconds for the BU353 GPS to initialize in CF, it often takes a couple of minutes and sometimes never initializes. Restarting CF always makes it work, so I think it's a CF bug like discussed at http://forums.fluxmedia.net/gps/4645-bu353-cf.html.

          I am going to try several things (hopefully will have time sometimes this week):
          - Latest Prolific driver for the BU353 GPS: http://www.prolific.com.tw/eng/downloads.asp?ID=31
          - XPort
          - GPS Gate (http://franson.com/gpsgate)
          - Test the internal GPS again using the registry modification mentioned at http://curioustech.home.insightbb.com/xport.html:

          HKLM\SYSTEM\CurrentControlSet\Services\SerMouse\"S tart"=4


          Also you asked in your other post if the G4's GPS is possibly using USB. I don't think it is, since COM1 appears in the BIOS.

          Comment


          • #6
            It sounds like you have more than one problem.

            The spaz-mouse is an easy fix though. The registry fix for SerMouse is the same as disabling MS BallPoint in Device Manager. Don't do any of those other things though, and keep COM1 enabled. You shouldn't have any more crazy mouse attacks.

            Not being detected may be software related or may not be. Setup XPort and when SD or CF can't detect the GPS, bring up XPort and look at the status bar to see if data is being received. If it is, then your GPS is working. If not... well, you can't easily unplug it can you? Not sure how to test that yet.

            Also, do you notice any difference when rebooting vs. hibernate/standby?

            Comment


            • #7
              I tried the SerMouse registry hack as a last attempt to get the internal serial GPS working, and it did not help. It did prevent a serial mouse from being detected, and so the mouse pointer didn't go crazy, but it did not make CF detect a GPS on the COM port. So I guess that maybe the COM port got fried.

              I don't think I've seen a difference in standby vs hibernate.

              I installed the new Prolific USB-serial driver, and it made things worse. At first CF was still detecting the GPS after a couple of minutes, but it soon completely stopped working no matter how many times I rebooted or toggled the GPS settings in CF. (Yet it still worked in the GPS utility that came with the GPS, so I think it is a bug in CF.)

              The last thing I did today was to install Xport, and so far that has made it work for the 4-5 times I've put the PC into standby/suspend. It still takes about 40 seconds after resuming for the GPS to start working in CF, but it also takes about that long for it to resume working when I sleep the PC while the GPS utility is open (showing the raw data). I definitely appreciate the authors of XPort, but that is one of the most confusing UI's I've seen.

              Comment


              • #8
                LOL Well, XPort might get easier use at some point from what I hear. The delays you're seeing now are pretty much expected. It takes some units 5 minutes to get a lock, so 40 seconds is pretty fast. You should uninstall that Prolific driver though. It's for a USB receiver that you don't have.

                Comment


                • #9
                  johnk, Curiosity is the programmer of XPort.

                  Curiosity, even if you do not own a G4, I'm sure you've already helped a lot of grateful G4 users already. During the course of helping them, perhaps you may have got to know more about G4. Will you be able to advise if any of the devices listed in XPort is related to the G4 built-in GPS on com port 1 cos some of the devices has Infill names but I'm not sure what devices are those and if I should select them to resolve my own issue. Also, I only have the built-in GPS com port 1 not initializing properly out of hibernation but not out of resuming from sleep or cold boot. When it happens, XPort status bar will show weird characters rather than GPS coordinates. Not wanting to hijack johnk's thread, if you feel your answer does not help him, kindly reply in my thread.

                  Comment


                  • #10
                    johnk, did you ever tried uninstalling the com port 1? If so, what happens when you reboot? Does it automatically detects it again? Are there any drivers needed for the built-in GPS on com port 1? All the drivers & bios that can be found here I supposed are the latest outside of Korea but definately not the latest in Korea. It is a shame the official site is in Korean. I once tried to register but gave up when the registration form insist on certain fix address format Korean use.

                    Comment


                    • #11
                      I tried completely reinstalling Windows. The crazy-mouse problem even happens during the Windows setup (before it has gotten to the Windows desktop stage).


                      It also turns out that CF is even buggier than I thought. It worked with XPort for less than a day, and then after a few more resumes from standby/hibernate it completely broke again. Restarting CF would not help, even though my GPS Info program works perfectly showing the data (and no, I am not trying to use the GPS in CF while it is being used by the other program). I had to go into the CF setup, save it to a "wrong" com port, and then save it back to the correct com port. So obviously CF is not properly talking to the com port (since the GPS Info program worked fine).

                      This is extremely frustrating. GPS is one of the main reasons for me getting an all-in-one solution.

                      Is there *any* USB GPS that CF supports?

                      Comment


                      • #12
                        You should probably disable COM1 in the BIOS while installing Windows, then enable it again and do the SerMouse hack. At least you can use your mouse while installing Windows.

                        A good GPS is the BU-353. Many of us use it.

                        Comment


                        • #13
                          > Will you be able to advise if any of the devices listed in XPort is related to the G4 built-in
                          > GPS on com port 1 cos some of the devices has Infill names but I'm not sure what devices are those

                          Carz,

                          I'm almost positive that the "INFILL" device is the touchscreen, and the "InFill" device is a USB controller (they appear almost exactly the same in Device Manager).

                          Comment


                          • #14
                            Originally posted by Curiosity View Post
                            You should probably disable COM1 in the BIOS while installing Windows, then enable it again and do the SerMouse hack. At least you can use your mouse while installing Windows.

                            A good GPS is the BU-353. Many of us use it.

                            Are you saying that even though the SerMouse hack did not work for me already (it keeps the mouse from going crazy, but does not make the G4's internal GPS actually work), it should work if I reinstall Windows with COM1 disabled, and then reenable COM1 and apply the SerMouse hack? I just don't understand what difference that would make (not trying to be argumentative; I'd like to be educated). (I really think the COM port or GPS electronics got fried, to make it just suddenly start having the problem after months of normal use.)

                            I do have the BU-353 USB GPS, but Centrafuse seems to have a very hard time with it. So I was hoping for something/anything that would actually work for me.


                            I also found out that just toggling the GPS com port in CF is not enough to fix it. It looks like I have to exit CF, start up the GPS monitoring in the GPS Info utility that came with the BU-353, stop the GPS monitoring, and then restart CF. At least that worked the last 2 times I tried this evening. (This is with or without XPort.)

                            Comment


                            • #15
                              I reenabled my COM1 port and used the sermouse registry hack to keep it from going crazy (this makes a MS Serial Mouse item appear in the Device Manager, with an exclamation point).

                              Then I set XPort to redirect COM1 to COM7. The GPS data *does* appear at the bottom of the XPort window. But it never works in CF. And even in my GPS Information utility from GlobalSat, I only see GPS data if I tell XPort to do a scan while the GPS Information app is already in its GPS read mode.

                              Comment

                              Working...
                              X