Announcement

Collapse
No announcement yet.

04 Grand prix radio stopped working

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • 04 Grand prix radio stopped working

    Hello, does anyone know the location of the stock amplifier on an 04 Grand Prix GT? My radio stopped working one day & I have checked the 2 radio fuses that I can find. Is ther an additional fuse for the "door chime module" or the on-board amp?
    The display works and the radio collects & displays the station/song info data, but there is no audio coming out. Please help, I'm going on 5 months without tunes!

    Thnks

    Mistakang

  • #2
    Originally posted by mistakang View Post
    Hello, does anyone know the location of the stock amplifier on an 04 Grand Prix GT? My radio stopped working one day & I have checked the 2 radio fuses that I can find. Is ther an additional fuse for the "door chime module" or the on-board amp?
    The display works and the radio collects & displays the station/song info data, but there is no audio coming out. Please help, I'm going on 5 months without tunes!

    Thnks

    Mistakang

    Mp3car.com == CarPC

    Might want to go to a forum specific to your car. You might find some answers but not as quickly as you would elsewhere.

    And if it is an "onboard" amp meaning in the HU itself, then the fuse on the back of it is the one.
    Fusion Brain Version 6 Released!
    1.9in x 2.9in -- 47mm x 73mm
    30 Digital Outputs -- Directly drive a relay
    15 Analogue Inputs -- Read sensors like temperature, light, distance, acceleration, and more
    Buy now in the MP3Car.com Store

    Comment


    • #3
      Originally posted by mistakang View Post
      Hello, does anyone know the location of the stock amplifier on an 04 Grand Prix GT? My radio stopped working one day & I have checked the 2 radio fuses that I can find. Is ther an additional fuse for the "door chime module" or the on-board amp?
      The display works and the radio collects & displays the station/song info data, but there is no audio coming out. Please help, I'm going on 5 months without tunes!

      Thnks

      Mistakang
      stock amplifier eh? If you've got a premium sound system in the car then there would be a small amplifier inside your consol somewhere...probably in the general direction of below and to the back from your stereo. The fuse for that kind of amplifier is the same as one of the two fuse you already checked so in that regard, you're S.O.L.

      OEM HU's are a pain in the ***...there's no real good way to fix stuff that goes wrong with them. Because they're mass produced only slightly slower than bunnies you end up getting a few bad eggs. They also opporate at lower power ouputs so when they start to wear out they shut off pretty quick. I'm guessing your deck is probably on it's last leg...

      Comment


      • #4
        Your stock amp. is located in the truck between the speakers

        Comment


        • #5
          i would just throw the stock HU away and install a TS and PC... Problem solved
          MY INSTAllS:

          http://www.mp3car.com/vbulletin/show...e-install.html

          http://www.mp3car.com/vbulletin/show...tallation.html

          Comment


          • #6
            Originally posted by david69leonard View Post
            i would just throw the stock HU away and install a TS and PC... Problem solved

            Not me I'd hit it with a hammer while it is still in the car cause that would just freak the out of anybody watching plus since there isnt a p.c. in there you would have a reason to put one in.
            Aron
            New Ipad
            Zapco DSP-6SL
            Zapco Reference 360.4: H-Audio Soul, x2 right side
            Zapco Reference 360.4: H-Audio Soul, x2 left side
            Zapco Reference 500.1: JL Audio 10W3V3 Stealth box

            Comment


            • #7
              Carputer Haiku (thanks Ian Hughes)
              Serious error.
              All shortcuts have disappeared.
              Screen. Mind. Both are blank.

              Comment

              Working...
              X