No announcement yet.

New Car Speakers and Amp Issues

  • Filter
  • Time
  • Show
Clear All
new posts

  • New Car Speakers and Amp Issues

    Ok, I recently bought a 2004 Chevy Silverado. With the stock stereo, the front right speaker would distort randomly at different volumes. I installed an aftermarket Pioneer Deck, with new 6.5 compnent speakers up front, and new 4x6 speakers in the back, topping it all off with a older MTX 404 4 channel amp. The speakers will distort and crack at random, no matter what volume I have the stereo at, and when you turn the volume up passed a certain level, the sound cuts out. What sucks is, I have checked the ground numerous times on the deck, and the amp. Cannot find a problem there, and the amp doesn't get very hot at all. The head unit gets pretty hot. I cannot figure out why the stock system cracked randomly as well, like this new set-up. I bought one of theose special harnesses and wired the amp directly to the stock speaker wire, then the rest into the deck. PLEASE HELP! Any advice would be great.

  • #2
    check your speaker connections, maybe they're loose and shorting against something. Also, do you have your gains set properly?


    • #3
      It sounds to me that you might have a short some where in your speaker wires. It may be that at one point, the insulation may have been rubbed off and it is shorting to ground. Intermitten problems are the hardest to try to troubleshoot. Good Luck!
      08 Dodge Ram QC


      • #4
        I fixed it

        It was my car deck all along. It was overheating and causing all of my problems. Thanks for all of the help.