Announcement

Collapse
No announcement yet.

2x DVC not Working Subwoofers Plus Touchscreen PROBLEMS

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • 2x DVC not Working Subwoofers Plus Touchscreen PROBLEMS

    Hi all been a while since I posted a problem but yes Its happened ,
    We re did my sub box put it in the boot the box fell over and was facing upwards with the back on the amp.
    We fully run the system out on a saturday night sounded great but all of a sudden it stopped!
    We have checked
    Amp (3000wrms at 1ohm) 12v in Light is going
    Outputs to subs still outputting voltage
    The subs are DVC 2 running at 1ohm
    The cable looks fine done the battery test on both subs and nothing happens.... Any idea no way we would have blown both at the same time right?

    Also on another note my touch screen has gone funny after a rebuild apparently it could be the ribbon on the GAIN unit but the ribbon looks fine , maby I should just RMA the board all it displays is white.

    I would greatly appreciate any help in regards to the subs not fun after spending weeks building boxes with mirrors and perspecs will post pics soon!

    Thanks
    my TURBO! Altezza!

    ATEZZA / IS200 3SGE-TURBO 6SPD MANUAL , EPIA 13000, 512 RAM W/LAN , 100GIG , GPS , TOUCH, 3X LCD, FLUSH TOUCHPAD MOUSE, SOUNDBLASTER EXTERNAL

  • #2
    Double check your sub wiring. If you wired the DVC wrong, they will fight against each other magnetically/electrically and you won't get any output. If you leave it like that too long, you might have destroyed the subs.

    The screen problem sounds like your ribbon cable is not plugged in all the way. Recheck that too. That was my problem in the past.
    System always under construction


    Comment


    • #3
      Now my soundblaster external has blown up all other usb devices get power but the sounblaster gets no lights Bummer

      Thanks for your post durwood I dont think they were fighting against each other im sure they were wired correctly
      my TURBO! Altezza!

      ATEZZA / IS200 3SGE-TURBO 6SPD MANUAL , EPIA 13000, 512 RAM W/LAN , 100GIG , GPS , TOUCH, 3X LCD, FLUSH TOUCHPAD MOUSE, SOUNDBLASTER EXTERNAL

      Comment


      • #4
        Regards the touchscreen the only thing that we changed was gluing it down with some glue that we think had some metal in it ...... that could have caused some problems! damn one of the chips gets really hot but we think its only on the touchscreen controller board
        my TURBO! Altezza!

        ATEZZA / IS200 3SGE-TURBO 6SPD MANUAL , EPIA 13000, 512 RAM W/LAN , 100GIG , GPS , TOUCH, 3X LCD, FLUSH TOUCHPAD MOUSE, SOUNDBLASTER EXTERNAL

        Comment

        Working...
        X