Announcement

Collapse
No announcement yet.

help 2003 suburban

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • help 2003 suburban

    ihave a 03 suburban that has rds radio with cd casette and rear stereo and boise speakers no on star, it has a 2amp drain on the battery and i remvd the rear stereo and retested and still same so i removed the 15 amp radio fuse to stop the drain and now i dont have door chimes , is it possible for the front stereo to pull that much amp and be bad it all worked ok it killed my battery

  • #2
    The fact that you pulled the 15 amp fuse and now you don't have door chimes suggests that there are other things on your radio circuit besides your radio. It's very possible that your 2 amp draw isn't from your radio at all.

    Comment


    • #3
      or maybe the door chimes coming from the radio is the result of an implementation of databus technology where the radio is sent a signal saying "give me door chime noises please". I think there are a few posts on this in here, maybe try a search with chevrolet and radio and relocate. maybe even "chimes" also.

      So you pulled the 15 amp fuse and it stopped?

      What fuse exactly was it, and what is the specific model of suburban is it.
      It's been a while...

      Comment


      • #4
        Ahhh good point. I had completely forgotten about the databus aspect. My 2006 Chevy Express work van chimes through the radio...

        Comment


        • #5
          Originally posted by h3rk View Post
          or maybe the door chimes coming from the radio is the result of an implementation of databus technology where the radio is sent a signal saying "give me door chime noises please". I think there are a few posts on this in here, maybe try a search with chevrolet and radio and relocate. maybe even "chimes" also.

          So you pulled the 15 amp fuse and it stopped?

          What fuse exactly was it, and what is the specific model of suburban is it.
          it is the 15 amp radio fuse circuit that has the drain and the suburban is just a ls model nothin fancy,the rds radio is supposed to have everythng to do with the theft deterent and chimes but everything worked fine it just draines the battery and it all still works but the radio and chimes when i pulled the fuse for the radio and now i have no current draw which is good in away that its nothing major but no tunes sucks

          Comment


          • #6
            well, my advice here is limited by the model information, but the fact that you said you had rear audio helps:

            That fuse supplies more than just that front radio hardware here is the list I've come up with:
            Radio
            Rear Seat Audio Controller
            Audio Amplifier
            Rear Seat Entertainment Assembly (if equipped)
            Digital Radio Receiver (if equipped)

            You can try to disconnect each from the harness, in succession, until the current draw stops, to determine specifically which component is causing this, or if the problem is maybe in the harness side.
            It's been a while...

            Comment


            • #7
              Originally posted by h3rk View Post
              well, my advice here is limited by the model information, but the fact that you said you had rear audio helps:

              That fuse supplies more than just that front radio hardware here is the list I've come up with:
              Radio
              Rear Seat Audio Controller
              Audio Amplifier
              Rear Seat Entertainment Assembly (if equipped)
              Digital Radio Receiver (if equipped)

              You can try to disconnect each from the harness, in succession, until the current draw stops, to determine specifically which component is causing this, or if the problem is maybe in the harness side.
              the radio amp has its own fuse and i dont have any thing in the rear except the radio that you can hook head phones in so the kids can listen to the radio when we listen to a cd or vice-versa and i removed the rear harness and tested still had drain so it looks like im going to have to get in the front harness and test that way thanks for the help if you have any other sugestions let me know thanks i was hoping that i wouldnt have to get in the front stereo

              Comment


              • #8
                if the front stereo is what the problem is can i get an aftermarket stereo to put in there and stil make the rear one and the chimes and the security to function correct or will i have to get another rds radio

                Comment


                • #9
                  I'm unaware of an aftermarket radio that provides the chimes functionality and the security function but there are adapters:

                  They have this for non-bose:
                  http://cgi.ebay.com/PAC-OS-2-Onstar-...QQcmdZViewItem

                  but since that doesn't apply, maybe this will work:

                  http://www.bizrate.com/caraccessorie...-pid332386508/

                  That should help a little on your search, just be sure to ask about compatability with your specific setup (bose, etc.).
                  It's been a while...

                  Comment


                  • #10
                    hey i appreciate the help thanks im going to taken out the front stereo tomorrow after iget home from work and make sure that the problem is in that or the wiring

                    Comment

                    Working...
                    X