Announcement

Collapse
No announcement yet.

Directed HD Radio static and popping

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Directed HD Radio static and popping

    So I've picked up the Directed DMHD1000 HD Receiver unit, and wired it into my existing head unit (Pioneer BT700 if I remember correctly). Problem is, I get a metric tonne of static and popping, whereas on the aftermarket head unit, I get practically none. It's going in a 350Z, and I have tried a bunch of combinations, but I'm hoping someone can help me figure out if this is a one-off issue, or if this is an issue everyone has had. I've done some searching on the forums, but haven't seen much in the way of the same situation.

    What I've done to troubleshoot is:

    HD Rec'r connected via RCA (white/red) to my head unit AUX IN
    HD Rec'r connected via RCA (white/red) to a regular home theater rec'r
    HD Rec'r connected via stereo headphone jack to the input of my head unit

    All three tests resulted in loud popping/crackling when any bass audio would come through, and volume levels changed all the time.

    I know it's not my antenna as my normal head unit gets great reception, even when daisy-chaining through the HD Rec'r. It's only when the HD Rec'r gets switched on do I get the static and popping. My antenna is amplified whenever the car is on (verified), and all these tests were done with the ignition on.

    I've tried connecting this via independent power sources like battery jumper packs, and another antenna which I know works as it is used on my vintage mustang, but with the same result.

    At this point, I'll be happy to hear any input on this I can get, prior to calling Directed Tech.

    Cheers!

  • #2
    ::UPDATE::

    I got it to work great by using the FM Modulation, but that doesn't really solve the problem when I put my mac mini in the car and don't have a HU to pick it up with. Any ideas?

    Comment


    • #3
      Check the grounds on the RCA connectors. If I recall, there was a potential problem there that could have been improved, and it used to cause noise.
      2001 Mustang Convertible Worklog
      Indigo Custom Frontend (Flash/Delphi)
      Blog

      Qube v1.3 Now Available at the mp3Car Store!!!!!!
      The simplest IO controller you'll ever use!

      Comment


      • #4
        Originally posted by colin View Post
        Check the grounds on the RCA connectors. If I recall, there was a potential problem there that could have been improved, and it used to cause noise.
        You mean on the circuit board inside the box where the RCA connectors are soldered to the board? I'd just as soon have Directed Tech send me a new box than deal with trying to fix that.

        If I'm completely off-base and missed your point though, please let me know.

        As another update however, I've gotten better results connecting the RCA connectors to my macbook pro's line-in. It still had a bit of static and crackle, but not as bad as previously.

        Oh, and grounding the unit through the supplied harness' black wire heats the main box up unlike anything. Instead, I'm grounding it through the unit's chassis. That seams to reduce the heat by quite a bit. I think the noice reducer (which doesn't seem to work very well) is acting more like a transformer than a capacitor.

        Comment


        • #5
          Yeah, I think that's what colin is talking about. Mitch, who sells the interface cables, mentioned this problem and a possible fix.

          Here's his link: http://www.rush2112.net/phpBB3/viewt...4&p=2711#p2711

          This will require opening it up. So if you could return it, I'd try that first. If it still happens with the new unit, it could have something to do with your enviroment and the rca grounding may be the only fix. If you'd still like to keep it and you have half-decent soldering skills, take a shot at it, it doesn't look that difficult.

          Comment


          • #6
            Well you could always put it on a switch and check whether it works better with the RCA grounded or not. Its cheap and quick so there's no reason not to try it... it seems like the only proper explanation IF the FM modulation works great but the RCA output doesnt.
            2001 Mustang Convertible Worklog
            Indigo Custom Frontend (Flash/Delphi)
            Blog

            Qube v1.3 Now Available at the mp3Car Store!!!!!!
            The simplest IO controller you'll ever use!

            Comment


            • #7
              Originally posted by colin View Post
              Well you could always put it on a switch and check whether it works better with the RCA grounded or not. Its cheap and quick so there's no reason not to try it... it seems like the only proper explanation IF the FM modulation works great but the RCA output doesnt.
              Yeah, I looked at the post cited, and it seems like this should be pretty simple. My soldering skills aren't on the level of robotic arm, but they're good enough to get this done I think. I'll give it a shot tonight. It would be great if it solved the issue, cause I was having serious doubts about the hardware prior to that. It might also explain the heat when the RCA connectors are hooked up.

              I'll post an update tonight after I give it a shot.

              Comment


              • #8
                That did it. What an amazing difference in sound. Now that $60 I spent on the kit went from being a waste to incredibly worthwhile. Took about 10 minutes to fix it (most of that time was waiting for the soldering iron to get hot).

                Thanks for the suggestion!

                Comment


                • #9
                  Glad to help!
                  2001 Mustang Convertible Worklog
                  Indigo Custom Frontend (Flash/Delphi)
                  Blog

                  Qube v1.3 Now Available at the mp3Car Store!!!!!!
                  The simplest IO controller you'll ever use!

                  Comment

                  Working...
                  X