No announcement yet.

Problem with USB adaptor for XM Direct

  • Filter
  • Time
  • Show
Clear All
new posts

  • Problem with USB adaptor for XM Direct

    Hey all - I am having problems with my new USB Adaptor for XM Direct.

    OS: Windows 7 32-bit

    When I plug the device in Windows it fails to automatically install a driver (no surprise). I go to Control Panel-Device Manager and sure enough there is an exclamation mark and no driver installed.

    I click Update Driver and point to the driver downloaded from The window says Installing Driver and then invariably throws the error "The system cannot find the file specified".

    I have tried everything to fix this. Registry changes, uninstall reinstall, moving the installer files... same thing every time.

    I just tried the last resort and re-installed Windows altogether. Still getting the same error.

    Is this a hardware issue of some sort? I've googled around and it seems people often get this error with NICs, printers, etc...